Introduction - FHIR v0.01

Introduction

Fast Healthcare Interoperability Resources (FHIR) defines a set of "resources" for health. These resources represent granular clinical concepts that can be exchanged in order to quickly and effectively solve problems in healthcare and related process. The resources cover the basic elements of healthcare - patients, admissions, diagnostic reports, medications, and problem lists, with their typical participants, and also support a range of richer and more complex clinical models. The simple direct definitions of the resources are based on thorough requirements gathering, formal analysis and extensive cross-mapping to other relevant standards.

Technically, FHIR is designed for the web; where possible or appropriate, open internet standards are used for data representation. The resources are based on simple XML, with an http-based RESTful protocol where each resource has predictable URL. Note that while the resources are defined to support an HTTP based RESTful infrastructure, it is not necessary to use such an infrastructure when using the resources. This specification also defines a class messaging based framework and way to use the resources to build clinical documents. In addition, the resources can be used in a SOA-based solution. This flexibility offers coherent solutions for a range of interoperability problems.

Roadmap

This specification has the following parts:

  • Background: foundation infrastructure for implementing resources (XML rules, data types, terminology basics, extensibility rules, and a conformance infrastructure).
  • Exchange: actual schemes for exchanging resources (HTTP RESTful protocol, Messaging and Documents, along with a general implementation resources page)
  • Administrative Resources: basic resources encountered throughout the healthcare process
  • Basic Clinical Components: Core reusable clinical resources that are encountered in most clincal practice
  • etc

The contents of this specification are navigated using the right-hand side bar.

Resources

All resources have the following parts:

  • A master id that is never changed
  • Structured Data - the formal representation of the resource in a computable fashion
  • Extensibility section - additional data not defined by HL7
  • Text Representation - a human readable fall back presentation

Because the master resource id is never changed or reused, resources may refer to other resources by the master id knowing that this is stable reference. While each resource can be read and/or changed without explicit reference to these other resources, the presence of these references influences the behaviour of the system: implementations are required to maintain system and data integrity at all times.

The exchange specifications are simple and straight forward and based around a direct description of the XML representation of the resource. Each resource is described separately, though there are some common data patterns used across all the resources (called "data types").

For each resource, this specification defines

  • scope and meaning of the resource
  • semantics and business implications of the resource
  • the XML content model of the resource (as XML, UML, and schema)

In addition to the simple XML definitions, a W3C XML schema and UML class diagram are available for each resource. The UML class diagram represents the same logical model as the XML format (though because of UML issues, implementors should not expect software built from the UML models to be automatically interoperable or conformant with the XML defined in this specification).

Each xml element (or matching UML class, attribute and composition association) has a formal definition that includes a definition, statement of requirements, additional comments, a mapping to the v3 RIM, and an indicative v2 mapping.

In addition, for each resource, some RESTful specific features are described:

  • the relative URL for RESTful implementations derived from the id, the type, and a local base URL
  • transactions specfically associated with the resource
  • additional search parameters specifically associated with the resource

Each resource supports the same list of transactions - read, update, delete, etc. One particularly important transaction supported by every resource type is the provision of a conformance statement which specifies what parts of the defined content model are supported by the system, and what other transactions or interactions are supported. If any of the other interactions are supported, the conformance interaction must be supported. (i.e. if the conformance interaction returns an error, no operations are supported).

Warning: FHIR is a draft specification that is still undergoing development prior to balloting as a full HL7 standard
Implementers are welcome to experiment with the content defined here, but should note that the contents are subject to change without prior notice.
© HL7.org 2011 - 2012. FHIR v0.01 generated on Mon, May 14, 2012 09:48+1000.


Resource XML - FHIR v0.01

Resource XML

In this specification, resources are described in a simple XML format. This page documents how the XML content for resources is described and controlled. The XML may be validated by schema, and schemas are provided, but validation is not required in operational systems (though the XML must always be valid against this specification). In addition, W3C Schema and UML models are provided that may be a useful aid for system implementation.

XML Content Models

All the content model definitions provided in this specification follow the same general pattern:

 <name xmlns="...">
   <nameA> opt type description of content <nameA>
   <nameB> mand type Zero+ description </nameB>
   <nameC> <!-- One+ -->
     <nameD mand type="?">Relevant records </nameD>
   </nameC>
 <name>

Notes:

  • The XML character set is always unicode. Specifying the character encoding is optional but recommended. Any encoding that is round trip compatible with unicode is allowed
  • All the XML is in the namespace http://www.hl7.org/fhir, which is usually specified as the default namespace on the root element (except for XHTML discussed below)
  • The elements are assigned types. All the types are defined in the data types except for "Resource" and "Narrative" that are documented below. The type names are hyperlinked.
  • In addition, elements have a control flag shown in red, that specifies whether the element must be present, is optional or may be marked as not present. This is explained below. The control flags are hyperlinked to their definitions.
  • Unless specified otherwise, by the appearance of Zero+ or One+, an element can only appear once. If an element that can repeat is labelled as Zero+ mand, that means that any element that appears is mandatory
  • In the Resource definitions, each element name is also a hyperlink to the formal definition of the element in the data dictionary that underlies the exchange formats.
  • Any of the XML elements may have an xml id attribute to serve as the target of an reference.

Every resource contains the following common elements:

<[Name] xmlns="http://www.hl7.org/fhir">
  <id> mand id Master Resource Id, always first. Never changes after creation</id>
  <extensions> opt  See Extensions </extensions>
  <text> mand Narrative Text summary of resource, for human interpretation</text>
</[Name]>

The id element is always mandatory except in the case that a resource is posted to a server to create it, and the id of the resource is not yet known. In this case, the id element is absent. The use of the id element is discussed further below. The use of the extensions element is discussed under "Extensibility". The text ("Narrative") is discussed below. In addition to these data elements, there are several pieces of metadata about a resource that are not part of the resource content, but are delegated to the infrastructure:

Metadata Item | Type | Usage
Version Id | id | Changed each time the content of the resource changes. Can be referenced in a resource reference (see below). Can be used to ensure that updates are based on the latest version of the resource
Last Modified Date | dateTime | Change each time the content of the resource changes. Can be used by a system or a human to judge the currency of the resource content
Master Location | uri | Reports the location of the master for the resource. Useful when a resource is re-used by another system - it can report the location of the master should any system need to know this.

In any environment where the resources are used, the technical details of the delegation will have to be resolved. For further details, see Implementation Details.

dataAbsentReason & Control Flags

Data Quality - or the lack thereof- is a ubiquitious issue in healthcare. In order to handle this, every element defined as part of a resource data structure may have a dataAbsentReason attribute, which is used to specify why the normally expected content of the data element is missing.

 <x dataAbsentReason=""/>

The dataAbsentReason attribute can have one of the following values:

unknown | The value is not known
asked | The source human does not know the value
temp | There is reason to expect (from the workflow) that the value may become known
notasked | The workflow didn't lead to this value being known
masked | The information is not available due to security, privacy or related reasons
unsupported | The source system wasn't capable of supporting this element
astext | The content of the data is represented as text (see below)
error | Some system or workflow process error means that the information is not available

Notes:

  • Using "masked" may be breach of security or confidentiality, but there are times when it's use is required to support alternate workflows for gaining access to denied information.
  • If the dataMissingReason attribute is present, the element may still have additional content from it's definition. Usually this is where the contained elements define what data is missing.
  • Systems are not required to process any provided data when a dataAbsentReason is present, except as described in their conformance statement.
  • The dataAbsentReason attribute cannot be used inside the data types, nor can it be used in the text portion of a resource, nor inside an extension block (with the exception of the value of the extension)

Every element has a control flags which is used to control the degree to which missing or poor quality data is tolerated on a per element basis. The control flag must have one of the following values:

mand | The element must be present, and must be populated with correct data. i.e. Resource.id. No dataAbsentReason is allowed.
req | The element must be present, but may have a dataAbsentReason (todo: when would this be used?)
cond | The element may not be present, but if it is, may not have a dataAbsentReason. The condition must be explained in the notes that follow the definition
opt | The element doesn't have to be present. If it is present, it might have a dataAbsentReason. If the normal structure can be replaced with text, it might be.

Narrative

Every resource includes a human readable narrative that contains a summary of the resource, and may be used to represent the content of the resource to a human. The narrative need not encode all the structured data, but is required to contain sufficient detail to make it "clinically safe" for a human to just read the narrative. Each resource will define what content must be represented in the narrative to ensure clinical safety

The narrative for a resource is allowed to contain additional information that is not in the structured data, including human edited content. Such additional information must be in the scope of the definition of the resource.

Each narrative has a flag that specifies the relationship of the narrative from the structured data, which may have one of the following codes:

generated | The contents of the narrative are entirely generated from the structured data in the resource.
extensions | The contents of the narrative are entirely generated from the structured data in the resource, and some of the structured data is contained in extensions
additional | The contents of the narrative contain additional information not found in the structured data

In addition to this general flag that specifies the status of the narrative, there is an optional mapping between the narrative and the structured data. Each mapping has narrative id, and structured data id which map to xml:id attributes found in the narrative and the structured data respectively, and a flag for whether the text was generated from the data, or the data was generated from the text (by some form of retrospective processing, whether human or computer), or whether both come from an external source. The structured data target may be an empty element with a dataAbsentReason of "astext"; this means that the value of the text could not be properly represented in the data type. Any element defined as part of the resource content, or any repeating element inside a data type, may carry an id attribute to serve as the target of a narrative mapping. When using xml:id attributes, the comments in the aggregation section about the value of the xml:id attribute should be kept in mind.

The narrative is an xhtml fragment that also includes images if appropriate:

<x xmlns="http://www.hl7.org/fhir">
  <status> cond code generated | extensions | additional</status>
  <div xmlns="http://www.w3.org/1999/xhtml"mand limited xhtml content</div>
  <image> opt  <!-- Zero+ -->
   <mimeType> mand code mime type of image</mimeType>
   <content> mand base64Binary base64 image data</content>
  </image>
  <map> opt  <!-- Zero+ -->
   <text> mand xml:ID Narrative source (xml:id)</text>
   <data> mand xml:ID Data source (xml:id)</data>
   <source> mand code text | data</source>
  </map>
</x>

Terminology Bindings

  • Narrative.status is bound to the concept domain NarrativeStatus: "The status of a resource narrative". Possible values:
    generated | The contents of the narrative are entirely generated from the structured data in the resource.
    extensions | The contents of the narrative are entirely generated from the structured data in the resource, and some of the structured data is contained in extensions
    additional | The contents of the narrative contain additional information not found in the structured data
  • Narrative.image.mimeType is bound to the concept domain MediaType: "The mime type of an attachment". The possible values are those specified in BCP 13 (RFCs 2045, 2046, 2047, 4288, 4289 and 2049)
  • Narrative.map.source is bound to the concept domain NarrativeMapSource: "Which is the source in a Narrative <-> Data mapping". Possible values:
    text | The text is the original data
    data | The data is the original data

The status is required when the narrative is the full resource narrative, but not required in resource references (see below).

The contents of the xhtml element are an XHTML fragment containing only the basic html formatting elements described in chapters 7-11 (except section 4 of chapter 9) and 15 of the HTML 4.0 standard, <a> elements (either name or href), images, and internally contained stylesheets. The XHTML content may not contain a head, a body element, external stylesheet references, scripts, forms, base/link/xlink, frames, iframes, and objects. Technically, the content of the text element is a union of the XHTML Schema types "block", and "inline", with the additional rules above applied.

  <narrative>
    <div xmlns="http://www.w3.org/1999/xhtml">This is a simple
          example with only plain text</div>
  </narrative>

  <narrative>
   <div xmlns="http://www.w3.org/1999/xhtml">
     <p>
       This is an <i>example</i> with some <b>xhtml</b> formatting.
     </p>
   </div>
  <narrative>

An additional address scheme is defined for use within the xhtml for image location:

  <img src="fhir:#45"/>

This is a reference to an id attribute on an element in the same resource, either in the image attachments on the text element directly, or an element of type "Attachment".

  <narrative>
    <html xmlns="http://www.w3.org/1999/xhtml">
      <p>
        <img src="fhir:#a1/>.
      </p>
    </html>
    <image id="a1">
      <mimeType>image/png</mimeType>
      <data>MEKH....SD/Z</data>
    </image>
  <narrative>

Applications processing the html should always be able to strip external images (images not using the alternative "fhir" scheme above), and still be able to present the information correctly to a human reader (since these images are not part of the resource, their presence cannot be assured). Additionally, applications processing the html should always be able to strip the HTML tags completely (correcting for implicit paragraph elements such as headers) and still be clinically safe (so where internal images are used, they must include an appropriate caption).

The dataAbsentReason is not used on the narrative element, or any elements contained in it. The xhtml element must have some non-whitespace content.

Resource References

The "Resource" type indicates a reference from one resource to another. Since each resource is identified by a master id that never changes (a different id implies a different resource), references are done by id.

  <x>
    <type> cond ResourceType Resource Type</type>
    <id> cond id Id of the reference</id>
    <version> opt id Specific version Id of resource referenced</version>
    <text> opt string Text alternative for the resource</text>
  </x>

The resourceType type is the name of one of the resources defined in this specification, such as "Patient". Whether or not the type of the resource is fixed for a particular element, the reference includes the resource type (this is to assist with future prooting the specification).

A specific version of the resource may be referenced by specifying a version Id in addition to the resource identifier. The version identifier is only known to be unique in the context of a given resource, so the resource Id is always required. Note that locating and retrieving a particular version of a resource is implementation specific, like accessing the latest version of the resource.

  <id>
    <type>Patient</type>
    <id>034AB16</id>
  <id>

The id type can take one of the following forms:

A whole number in the range 0 to 2^64-1. May be represented in hex
A uuid (guid) (in lowercase, without wrapping with the characters "{}[]" which sometimes occur)
An ISO OID (reference)
Any other combination of letters, numerals, "-" and "."

Resource ids must be represented in lowercase. Ids are always opaque, and systems should not and need not attempt to determine their internal structure. However the id is represented, it must always be represented in the same way in resource references and URLs.

Some narrative may be provided that describes the resource in addition to the resource reference (or in place of, unless the resource reference is mandatory).

  <id>
    <type>Organisation</type>
    <id>1234</id>
    <text>HL7, Inc</text>
  <id>

Use

Unless the resource reference element has a dataAbsentReason flag, it must contain a valid type and id, or, if it is not mandatory, a text alternative.

Inter-version Compatibility

There is no explicit version marker in the XML. Subsequent versions of this specification may introduce new elements at any point in the content models, but the path or meaning of existing data elements will not be changed.

Given that in a typical scenario, mixed versions may need to exist, applications would best ignore elements that they do not recognize. However in a healthcare context, many application vendors are unwilling to consider this approach because of concerns about clinical risk. Applications are not required to ignore unknown elements, but must declare whether they will do so in their conformance statements.

XML Schema

This specification provides schema definitions for all the content models described here. The base schema is called "fhir-base.xsd" and defines all the datatypes and also the base infrastructure types described on this page. In addition, there is a schema for each resource, and a common schema fhir-all.xsd that includes all the resource schemas.

XML that is exchanged must be valid against the schema, though there is no requirement to validate instances against the schema, nor is being valid against the schema sufficient to be a conformant instance (this specification makes many rules that cannot be checked by schema). Exchanged content must not specify the schema or even the schema instance namespace in the resource XML.

Should schema based validation or code generation be of interest, applications can define their own schemas that more closely match the working content mode given their conformance statement. These schemas can eliminate elements not used by the application, and explicitly define extensions that are used. However the xml format they describe must be consistent with the XML and rules defined in this specification.

JSON Format

Though the formal representation of the resources is in XML, many systems wish to use JSON to exchange the resources, and it is useful to standardise a single JSON format for this use. The JSON format for the resources follows the standard XML format closely:

 <name xmlns="...">
   <nameA> opt type description of content <nameA>
   <nameB> mand type Zero+ description </nameB>
   <nameC> <!-- One+ -->
     <nameD mand type="?">Relevant records </nameD>
   </nameC>
 <name>

is represented in JSON as

{"name":
  "nameA" : {...},
  "nameB" :
    [
      {...},
      {...}
    ],
  "nameC" :
    [
      { "nameD" : {...} }
    }
}

Notes:

  • There is no namespaces in the JSON representation
  • The names are the same, including for elements that may repeat. This means that queries written against the XML form can also be executed against the JSON form (though there seems to be no general XPath for JSON implementation)
  • The xml attributes id (xml:id) and dataAbsentReason become JSON object attributes with the names "id" and "dataAbsentReason"; they come in that order before other defined elements
  • In the data types, the value representations for primitive types such a string, decimal etc are identical between the XML and the JSON form
  • Items that can repeat are represented as arrays even if they do not repeat in the actual instance
  • JSON property attributes never have empty values; omit a value if it is empty (same as for the xml)
  • The XHTML <div> element is represented as a single escaped string of XHTML
  • The last two items means that a generic XML -> JSON converter will not be able to perform a correct conversion. The reference platforms provide XML <--> JSON conversion functionalty

Object Models

In addition to the schema, this specification also provides object models defined in UML that may be of assistance in defining systems that work with the resources defined here.

Although the UML models provided express the same contents as the xml formats, because of the wide variation in how different architectures and tools map from UML to XML, there should be no expectation that any particular tool will produce compatible XML from these UML diagrams. Systems are welcome to use these object models as a basis for serialization internally, or even between trading partner systems, with any form of exchange technology (including JSON). Systems that use this form of exchange cannot claim to be conformant with this specification, but can describe themselves as using "FHIR consistent object models".

Warning: FHIR is a draft specification that is still undergoing development prior to balloting as a full HL7 standard


Data Types - FHIR v0.01

Data Types

The data types include primitive types imported from XML schema, and also additional data types that capture patterns that are ubiquitious throughout the scope of the healthcare data that will be exchanged.

The data types defined on this page on this page are categorised as either "Core Types" or "Structures". "Structures" are higher level concepts that some systems internally treat differently from the "Core Types". There is no functional difference betweent the two categories, and systems are not required to treat them any differently. This table summarises the types:

Core Types |  |  | Structures
Attachment | Identifier | Interval | HumanId | Contact
CodeableConcept | Quantity | Ratio | HumanName |
Coding | Choice |  | Address | Schedule

Primitive Types

The following table summarises the primitive types that are used in the exchange specifications. The posssible values for these types are those specified in the W3C Schema specification part 2.

boolean | values can be true or false
integer | A whole number (32 bit number; for values larger than this, use decimal)
decimal | A rational number. Do not use a IEEE type floating point type, instead use something that works like a true decimal, with inbuilt precision (i.e. Java BigInteger)
base64Binary | A stream of bytes, base64 encoded
instant | An instant in time - known at least to the second. Note: For system times, not human times (see below). Timezone is always required
string | Unicode. Note that FHIR strings may not exceed 1MB in size
uri | Ref to W3C spec

Implementations that convert the xml described in this specification to other formats such as JSON or some object based notation will have to find equivalent types.

String Patterns

In addition to these assumed primitive types, this specification define a few simple string patterns that are commonly used:

code | a string which has at least one character and no whitespace
oid | An ISO oid [ref ISO std]
uuid | A UUID [ref DEC std]. Sometimes called a GUID. Always represented in lowercase
sid | A system id, which is a uri taken from the list of known definition systems. sid values never contain a '#'
id | A whole number in the range 0 to 2^64-1, optionally represented in hex, a uuid, an oid, or any other combination of letters, numerals, "-" and ".", with a length limit of 36 characters
date | A date, or partial date (e.g. just year or year + month). There is no timezone. The format is a union of the schema types gYear, gYearMonth, and date.
dateTime | A date, date-time or partial date (e.g. just year or year + month). Generally, there is no timezone, though one may be populated if hours and minutes are specified. The format is a union of the schema types gYear, gYearMonth, date, and dateTime. Seconds may be provided but may also be ignored.

Examples

date (e.g. Date of birth):

  <x>1951-06-04</x>

Types

Attachment

This type is for referring to data content defined in other formats. The most common use of this to include images or reports in some report format such as PDF, but it can be used for any data that has a mime type.

<x xmlns="http://www.hl7.org/fhir">
  <mimeType> mand code the mime type of the content</mimeType>
  <data> opt base64Binary data inline, base64ed</data>
  <url> opt uri uri where the data can be found</url>
  <hash> opt base64Binary sha-256 hash of the data (base64 )</hash>
  <lang> opt code ISO 639-3 language code</lang>
  <title> opt string A name to display in place of the data</title>
</x>

Terminology Bindings

  • Attachment.mimeType is bound to the concept domain MediaType: "The mime type of an attachment". The possible values are those specified in BCP 13 (RFCs 2045, 2046, 2047, 4288, 4289 and 2049)
  • Attachment.lang is bound to the concept domain Language: "A human language". The possible values are those specified in ISO 639-3

The mimeType element must always be populated. The actual content of the Attachment can be conveyed directly using the data element, or a url reference can be provided. If both are provided, they must point to the same content. The reference can never be reused to point to different data (which means that the reference is version specific). The url reference must point to a location that resolves to actual data; some uri's such as cid: meet this requirement.

The hash is included so that applications can verify that the contents of a location have not changd, and also so that a signature of the xml content can implicitly sign the content of an image without having to include the data or reference the url in the signature. The lang element can help a consumer choose between multiple different Data elements.

In many cases where Attachment is used, the cardinality is >1; repeats are used to convey the same content in different mime types and languages, or to provide a thumbnail of a large image.

Use

Unless the Attachment element has a dataAbsentReason flag, it must contain a data or a url. If neither data nor a url is provided, the value should be understood as an assertion that no content for the specified mimeType and/or lang is available for the reason stated.

The context of use may frequently make rules about the kind of attachment (and therefore, the kind of mime types) that can be used.

Examples

A PDF document:

  <x>
   <mimeType>application/pdf</mimeType>
   <data>/9j/4...KAP//Z</data> <!-- covers many lines -->
   <lang type="code">en-us</lang>
   <title type="string">Definition of Procedure</title>
  </x>

A reference to a DICOM image:

  <x>
   <mimeType>application/dicom</mimeType>
   <url>http://10.1.2.3:1000/wado?requestType=WADO&wado details...</url>
   <hash>>EQH/..AgME</hash>
  </x>

Identifier

An identifier defined by some external system.

<x xmlns="http://www.hl7.org/fhir">
  <system> cond uri The system that defines the id</system>
  <id> cond string the actual identifier</id>
</x>

The system may be either a specific application, or a recognised concept for which the specific application may be implicit. The system is a URI that may be an OID (oid:) or a UUID (uuid:), a sid (a specially defined URI from the named systems list), or a URL that references a definition of the identifier. OIDs and UUIDs may be registered in the HL7 OID registry, and should be if the content is shared or exchanged across institutional boundaries.

In some cases, the system may not be known - only the id is known (i.e. a simple device that scans a barcode). In this case, no useful matching may be perfomed using the id unless the system can be safely inferred by the context.

Note that the system defines the scheme that controls uniqueness of the id. The id must be unique for within the defined system. If the id itself is actually an OID, a UUID, or a URI, then the system will be either "urn:hl7-org:sid/oid", "urn:hl7-org:sid/uuid" or "urn:hl7-org:sid/uri" respectively, and the OID, UUID would be in the id element. Ids are always case sensitive. UUIDs must be represented in lower case.

Use

Unless the Identifier element has a dataAbsentReason flag, it must contain a an id. If the Identifier element is marked as mandatory, it must contain a system.

Examples

A primary key from an application table (an OID in the space allowcated by HL7 to some organisation to further sub-allocate):

  <x>
   <system>oid:2.16.840.1.113883.16.4.3.2.5</system>
   <id>123</id>
  </x>

An identifier of a resource defined by this specification, on a particular system:

  <x>
   <system>http://pas-server/xxx/patients</system>
   <id>443556</id>
  </x>

A guid:

  <x>
   <system>urn:hl7-org:sid/uuid</system>
   <id>a76d9bbf-f293-4fb7-ad4c-2851cac77162</id>
  </x>

CodeableConcept

A CodeableConcept represents a represents a field that is usually defined by formal reference to one or more terminologies or ontologies, but may also be defined by the provision of text.

<x xmlns="http://www.hl7.org/fhir">
  <coding> Zero+ Coding  <!-- A reference to a code defined by a terminology system  -->
   <code> cond code Symbol in syntax defined by the system</code>
   <system> mand uri Identity of the terminology system </system>
   <display> opt string Representation defined by the system</display>
  </coding>
  <text> cond string A plain text representation of the concept</text>
  <primary> opt xml:ID Which code was chosen directly by the user</primary>
</x>

This data type has text and/or one more "codings" that all represent a single notional concept, though the multiple codings will often have slightly different granularity due to the differences in the definitions of the underlying codes. Each "coding" is a representation of the concept using a symbol from a defined "code system", which may be an enumeration, a list of codes, a full terminology such as SNOMED-CT or LOINC, or a formal ontology. The concept may be coded multiple times in different code systems (or even multiple times in the same code systems, where multiple forms are possible, such as with SNOMED-CT). Whether or not coding elements are present, the text is a human language representation of the concept as seen/selected/uttered by the user who entered the data, and/or which represents the intended meaning of the user or concept. Very often the text is the same as a display of one of the codings.

For each coding, there must be a system the identifies the terminology or ontology the code is defined by. The system is a URI that may be an OID (oid:) or a UUID (uuid:), a specially defined URI from the named systems list, or a url that references a definition of the system, or any other URI. OIDs and UUIDs may be registered in the HL7 OID registry, and should be if the content is shared or exchanged across institutional boundaries. The system reference is version independent; applications are never required to process the content of the system URI in order to determine whether two codes are the same. Note though, that merely because a code/system pair is different does not mean that concept is different - applications have to consult the ontologies or terminologies to make those kind of comparisons.

If present, the code must be a syntactically correct symbol as defined by the system. Note that codes are case sensitive unless specified otherwise by the code system. If no code is present, the coding means that the concept cannot be encoded in the identified system. The display is a text representation of the code that is defined by the system, which can be used to display the code by an application that is not aware of the system. One of the codings may be flagged as the primary - the code that the user actually chose directly. If present, the value of the primary element is an ID that must match an xml:id on one of the codings.

Use

Unless the CodeableConcept element has a dataAbsentReason flag, it must contain at least one coding with a code, or a text. Each coding must contain a system element, and should contain a display if it contains a code.

The context of use may frequently make rules about what codings are allowed or required.

"Coding" Data Type

The CodeableConcept data type represents a commonly encountered pattern around the use of coding, with multiple codings and a text. In some circumstances, the resources and/or models that use these data types may be more prescriptive about the use of multiple codings, the way that the text element interacts with the codings, and/or the way that codings are derived from each other. In these circumstances, the "Coding" Data Type is used. The Coding type has the contents of the coding element as defined in the CodeableConcept data type.

Examples

A simple code for headache, in ICD-10, with the text on which the coding is based:

  <x>
    <coding>
      <code>G44.1</code>
      <system>urn:hl7-org:sid/icd-10</system>
    </coding>
    <text>general headache</text>
  </x>

A concept represented in an institutions local coding systems for which no snomed equivalent exists:

  <x>
    <coding>
      <code>burn</code>
      <system>oid:2.16.840.1.113883.19.5.2</system>
    </coding>
    <coding>
      <system>http://snomed.info</system>
    </coding>
    <text>Burnt ear with iron. Burnt other ear calling for ambulance</text>
  </x>

A Snomed-CT expression:

  <x>
    <coding>
      <code>128045006:{363698007=56459004}</code>
      <system>http://snomed.info</system>
    </coding>
    <text>Cellulitis of the foot</text>
  </x>

Choice

A code taken from a short list of codes that are not defined in a formal code system. Choice is generally used for things like pain scales, questionnaires or formally defined assessment indexes. The possible codes may be ordered with some arbitrarily defined scale. Note: Choice is not an appropriate data type to use when the possible codes are defined in a formal code system, such as a value set, or otherwise stord on a terminology server.

<x xmlns="http://www.hl7.org/fhir">
  <code> cond code Selected code</code>
  <value> mand  <!-- One+ A list of possible values for the code -->
   <code> mand code Possible code</code>
   <display> opt string Display for the code</display>
  </value>
  <isOrdered> opt boolean If the order of the values has meaning</isOrdered>
</x>

The code is the selected value. A list of possible values must be provided; at least a code must be provided for each value. The selected code must be found in the list of possible codes.

If isOrdered is true, then the values have an inherent meaningful order, and the list of values must be provided in the correct order.

Use

Unless the Choice element has a dataAbsentReason flag, it must contain a code. The Choice element must always contain at least one possible value.

Example

The results on a urinalysis strip:

  <x>
    <code>+</code>
    <value>
      <code>neg</code>
    </value>
    <value>
      <code>trace</code>
    </value>
    <value>
      <code>+</code>
    </value>
    <value>
      <code>++</code>
    </value>
    <value>
      <code>+++</code>
    </value>
    <isOrdered>true</isOrdered>
  </x>

Quantity

A measured amount (or an amount that can potentially be measured).

<x xmlns="http://www.hl7.org/fhir">
  <value> cond decimal Numerical value (with implicit precision)</value>
  <status> opt code how the value should be understood and represented</status>
  <units> cond string unit representation</units>
  <code> cond code A coded form of the unit</code>
  <system> cond uri The system that defines the coded form</system>
</x>

Terminology Bindings

  • Quantity.status is bound to the concept domain QuantityStatus: "how the Quantity should be understood and represented". Possible values:
    < The actual value is less than the given value
    <= The actual value is less than or equal to the given value
    >= The actual value is greater than or equal to the given value
    > The actual value is greater than the given value

The value contains the numerical value of the quantity, including an implicit precision. The status indicates how the value should be understood and represented. If no status is specified, the value is a point value. The status element can never be ignored.

The units element must contain a displayable unit that defines what is measured. The units may additionally be coded in the code and the system, which is a URI, OID, or a SID that defines the code (see CodeableConcept for further information about system).

If the units are able to be coded in UCUM, and a code is provided, it SHOULD be a UCUM code. If a UCUM unit is provided in the code then a canonical value can be generated for purposes of comparison between quantities. Note that the units element will often contain text that is actually a valid UCUM unit, but it cannot be assumed that it does.

Use

Unless the Quantity element has a dataAbsentReason flag, it must contain at a value and a unit. If a code is present, a system is also required.

The context of use may frequently define what kind of quantity this is, and therefore what kind of units can be used. The context of use may additionally require a code from a particular system. The context of use may also restrict the values for status.

Defined Variations on Quantity

These are used as types in resource content models, but they are really just Quantity with some rules:

Duration | The unit must be an amount of time, and a UCUM unit must be provided.
Distance | The unit must be an amount of length, and a UCUM unit must be provided.
Count | The value must a whole number, and the UCUM unit must be "1"
Money | The unit must be a currency, and the code must from ISO 4217 (system = "urn:hl7-org:sid/iso-4217")

Examples

A duration:

  <x>
    <value>25</value>
    <unit>sec</unit>
    <code>s</code>
    <system>urn:hl7-org:sid/ucum</system>
  </x>

A concentration where the value was out of range:

  <x>
    <value>40000</value>
    <status>&gt;</status>
    <unit>mcg/L</unit>
    <code>ug</code>
    <system>urn:hl7-org:sid/ucum</system>
  </x>

An amount of prescribed medication:

  <x>
    <value>3</value>
    <unit>capsules</unit>
    <code>385049006</code>
    <system>http://snomed.info</system>
  </x>

A price:

  <x>
    <value>25.45</value>
    <unit>US$</unit>
    <code>USD</code>
    <system>urn:hl7-org:sid/iso-4217</system>
  </x>

Interval

A set of ordered values defined by a low and high limit.

An interval may be applied to Quantity, dateTime, and date. The context where the type is used must specify which of these types is used. An interval specifies a range of values; the context of use will specify whether the entire range applies (e.g. "the patient was an inpatient of the hospital for this time range") or one value from the range applies (e.g. "give the patient between 2 and 4 tablets").

<Interval xmlns="http://www.hl7.org/fhir">
  <low> cond [param] Low value (Text or elements from specified type)</low>
  <high> cond [param] High value (Text or elements from specified type)</high>
</Interval>

If the low or high elements are missing, the meaning is that the low or high boundaries are not known. A dataAbsentReason flag may be used on the low or high elements in this case. On intervals over a time period, if the high is missing, it means that the interval is current and ongoing.

If the interval applies to the Quantity type, the status flag on the quantity cannot have the values <, <=, =>, or >. Note that the Interval type should not be used to represent measurements where the status flag might be used instead.

When the interval applies to a date or dateTime, the high value includes any matching date/time. When the interval applies to the other types, the high value is assumed to have arbitrarily high precision. For example:

1.5 to 2.5 | includes 1.50, and 2.50 but not 1.49 or 2.51
2011-05-23 to 2011-05-27 | includes all the times of 23rd May through to the end of the 27th May

Use

Unless the Interval element has a dataAbsentReason flag, it must contain a low and, if it does not apply to a date or dateTime, a high.

Examples

Interval of Quantity (distance):

  <x>
   <low>
     <value>2.8</value>
     <unit>m</unit>
   </low>
   <high>
     <value>4.6</value>
     <unit>m</unit>
   </high>
  </x>

23rd May 2011 to 27th May, including 27th May:

  <x>
   <low>
     <date>2011-05-23</date>
   </low>
   <high>
     <date>2011-05-27</date>
   </high>
  </x>

Ratio

A ratio of two Quantity values - a numerator and a denominator.

<x xmlns="http://www.hl7.org/fhir">
  <numerator> cond Quantity The numerator</numerator>
  <denominator> cond Quantity The denominator</denominator>
</x>

Common factors in the numerator and denominator are not automatically cancelled out. The Ratio data type is used for titers (e.g., "1:128") and other quantities produced by laboratories that truly represent ratios. Ratios are not simply "structured numerics" and blood pressure measurements (e.g. "120/60") are not ratios. In addition, ratios are used where common factors in the numerator and denominator do not cancel out. The most common example of this is where the ratio represents a unit cost, and the numerator is a currency.

Use

Unless the Ratio element has a dataAbsentReason flag, it must contain a numerator and a denominator. The context of use may require particular types of Quantity for the numerator or denominator.

Examples

Titer (Ratio of integer:integer)

  <x>
   <numerator>
     <value>1</value>
   </numerator>
   <denominator>
     <value>128</value>
   </denominator>
  </x>

Unit cost (Ratio of Money:Quantity):

  <x>
   <numerator>
     <value>103.50</value>
     <unit>US$</unit>
     <code>USD</code>
     <system>urn:hl7-org:sid/iso-4217</system>
   </numerator>
   <denominator>
     <value>128</value>
     <unit>day</unit>
     <code>day</code>
     <system>urn:hl7-org:sid/ucum</system>
   </denominator>
  </x>

Structures

HumanId

An identifier that humans use. This is different to a system identifier because identifiers that humans use are regularly changed or retired due to human intervention and error. Note that an human identifier may be a system identifier on some master system, but becomes a human identifier elsewhere due to how it is exchanged between humans. Driver's license nunmbers are a good example of this. Also, because human mediated identifiers are often invoked as implicit links to external business processes, such identifiers are often associated with multiple different resources. Human identifiers often have some type associated with them that is important to allow the identifier to be picked as a basis for exchange elsewhere, either in other electronic interchanges, or paper forms.

<x xmlns="http://www.hl7.org/fhir">
  <type> opt Coding Code for identifier type</type>
  <identifier> cond Identifier Actual identifier</identifier>
  <period> opt Interval(dateTime) Time period when id was valid for use</period>
  <assigner> opt (Organization) Organisation that issued id</assigner>
</x>

Terminology Bindings

  • HumanId.type is bound to the concept domain IdentifierType: "The type of human identifier" (sid = urn:hl7-org:sid/fhir/identifier-type). Use one of these values if possible:
    account | Account number | An identifier that is unique to an account.
    credit | Credit Card Number | A credit card number (or debit card).
    microchip | Microchip Number | implanted, for animals, or a worn RFID for humans
    registry | A Registry Number
    insurance | Insurance Scheme Member Number | Identifies the person as a member of an insurance scheme.
    national | National Healthcare Identifier | May not only be used for healthcare.
    ssn | National Social Security Number
    state | State Healthcare Identifier | May not only be used for healthcare.
    patient | Patient identifier | Frequently called MRN (medical record number) or UR (unit record number).
    facility | Facility ID
    provider | Provider number | a number allocated to a person as a provider of healthcare resources.

Note that in many cases, the assigner is used to indicate what registry/state/facility etc assigned the identifier. Another possible source for the type of an identifier is HL7 v2 table 0203.

The resource elements often use HumanId for an identifier that may be an external human mediated reference, or that may also come from a direct unambiguous reference to a resource, or may be from a seperate workflow, possibly human mediated. When the identifier is actually a direct resource reference, the type should be a resource type, the identifier.system should be the URL of the source system or, if a particular end point is not known, then "urn:hl7-org:sid/fhir/[X]" where "[X]" is the resource name , and the identifier.id should be the resource id.

Use

An identifier with an id element is required unless a dataAbsentReason flag is provided on the identifier element. If the HumanId is mandatory, then either an identifier.system or an type must be provided (In some cases, the type of the identifier will be known, but not the identifier.system. For instance, a driver's license number, where the state, province or country that issues the license identifier is unknown).

The assigner.id may be replaced with assigner.text when used with the dataAbsentReason "astext".

Examples

A US SSN:

  <x>
    <type>
      <code>ssn</code>
      <system>urn:hl7-org:sid/fhir/identifier-type</system>
    </type>
    <identifier>
      <system>urn:hl7-org:sid/us-ssn</system>
      <id>000111111</id>
    </identifier>
  </x>

Notes:

  • US SSNs are often presented like this: 000-11-1111, the dashes are for presentation and should be removed, as specified in the definition of ssn-us
  • There is apparent duplication between type and system; the type says that this is a national social security identifier from some country, while the system specifically identifies the US SSN. Not all countries will have a registered system id like USA does; it might be useful to also reference the country in the assigning authority

A medical record number assigned on 5-July 2009:

  <x>
    <type>
      <code>patient</code>
      <system>urn:hl7-org:sid/fhir/identifier-type</system>
    </type>
    <identifier>
      <system>oid:0.1.2.3.4.5.6.7</system>
      <id>2356</id>
    </identifier>
   <period>
     <low>2009-06-05</low>
   </period>
  </x>

HumanName

A name of a human, or a name given to an animal by a human.

Names may be changed, or repudiated, or people may have different names in different contexts. Names may be divided into parts of different type that have variable significance depending on context, though the division into parts does not always matter. With personal names, the different parts may or may not be imbued with some implicit meaning; various cultures associate different importance with the name parts, and the degree to which systems must care about name parts around the world varies widely.

<x xmlns="http://www.hl7.org/fhir">
  <use> opt code The use of this name</use>
  <text> cond string Text representation of the full name</text>
  <part> cond  <!-- Zero+ A part of a name -->
   <type> opt code Type of name part (see below)</type>
   <value> mand string The content of the name part</value>
  </part>
  <period> opt Interval(dateTime) Time period when name was/is in use</period>
</x>

Terminology Bindings

  • HumanName.use is bound to the concept domain NameUse: "The use of a human name". Possible values:
    usual | Known as/conventional/the one you normally use
    official | The formal name as registered in an official (government) registry, but which name might not be commonly used. May be called legal name.
    temp | A temporary name. A name valid time can provide more detailed information. This may also be used for temporary names assigned at birth or in emergency situations.
    anonymous | Anonymous assigned name, alias, or pseudonym (used to protect a person's identity for privacy reasons)
    old | This name is no longer in use (or was never correct, but retained for records)
    maiden | A name used prior to marriage. Marriage naming customs vary greatly around the world. This name use is for use by applications that collect and store maiden names. Though the concept of maiden name is often gender specific, the use of this term is not gender specific. The use of this term does not imply any particular history for a person‘s name, nor should the maiden name be determined algorithmically
  • HumanName.part.type is bound to the concept domain NamePartType: "Type of a part of a human name". Possible values:
    family | Family name, this is the name that links to the genealogy. In some cultures (e.g. Eritrea) the family name of a son is the first name of his father.
    given | Given name. NOTE Not to be called first name since given names do not always come first. .
    title | Part of the name that is acquired as a title due to academic, legal, employment or nobility status etc. NOTE Title name parts include name parts that come after the name, such as qualifications.

The text element specifies the entire name as it should be represented. This may be provided instead of or as well as specific part elements. Every part must have a value.

Use

Either text or at least one part is required unless a dataAbsentReason flag is provided on the name element.

Example

Full name of Peter James Chalmers, with a preferred name of James.

  <x>
    <use>usual official</use>
    <part>
      <type>given</type>
      <value>Peter</value>
    </part>
    <part>
      <type>given</type>
      <value>James</value>
    </part>
    <part>
      <type>family</type>
      <value>Chalmers</value>
    </part>
  </x>

See further examples

Address

A postal address. There is a variety of postal address formats defined around the world. This format defines a superset that is the basis for addresses all around the world Note: address is for postal addresses, not physical locations.

<x xmlns="http://www.hl7.org/fhir">
  <use> opt code The use of this address</use>
  <text> cond string Text representation of the address</text>
  <part> cond  <!-- Zero+ -->
   <type> opt code Type of address part (see below)</type>
   <value> mand string The content of the address part</value>
  </part>
  <period> opt Interval(dateTime) Time period when address was/is in use</period>
</x>

Terminology Bindings

  • Address.use is bound to the concept domain AddressUse: "The use of an address". Possible values:
    home | A communication address at a home.
    work | An office address. First choice for business related contacts during business hours.
    temp | A temporary address. The period can provide more detailed information.
    old | This address is no longer in use (or was never correct, but retained for records)
  • Address.part.type is bound to the concept domain AddressPartType: "Type of address part". Possible values:
    part | Part of an address line (typically used with an extension that further defines the meaning of the part).
    line | A line of an address (typically used for street names & numbers, unit details, delivery hints etc) .
    city | The name of the city, town, village, or other community or delivery centre.
    state | sub-unit of a country with limited sovereignty in a federally organized country. A code may be used if codes are in common use (i.e. US 2 letter state codes).
    country | Country. ISO 3166 3 letter codes can be used in place of a full country name.
    zip | A postal code designating a region defined by the postal service.
    dpid | A value that uniquely identifies the postal address. (often used in barcodes).

The text element specifies the entire address as it should be represented. This may be provided instead of or as well as specific part elements. Every part must have a value.

Use

Either text or at least one part is required unless a dataAbsentReason flag is provided on the address element.

Example

HL7 office's address.

  <x>
   <use>work primary</use>
   <text>
       1050 W Wishard Blvd
       RG 5th floor
       Indianapolis, IN 46240
     </html>
   </text>
   <part>
     <type>city</type>
     <value>Indianapolis</value>
   </part>
   <part>
     <type>state</type>
     <value>IN</value>
   </part>
   <part>
     <type>zip</type>
     <value>46240</value>
   </part>
  </x>

See further examples

Contact

All kinds of technology mediated contact details for a person or organisation, including telephone, email, etc.

<x xmlns="http://www.hl7.org/fhir">
  <system> cond code What kind of contact this is</system>
  <value> cond string The actual contact details</value>
  <use> opt code How to use this address</use>
  <period> opt Interval(dateTime) Time period when the contact was/is in use</period>
</x>

Terminology Bindings

  • Contact.system is bound to the concept domain ContactSystem: "What kind of contact this is". Possible values:
    phone | the value is a telephone number used for voice calls. Use of full international numbers starting with + is recommended to enable automatic dialing support but not required.
    fax | the value is a fax machine. Use of full international numbers starting with + is recommended to enable automatic dialing support but not required.
    email | the value is an email address
    url | The value is a url. This is intended for various personal contacts including blogs, twitter, facebook etc. Do not use for email addresses
  • Contact.use is bound to the concept domain ContactUse: "How to use this address". Possible values:
    home | A communication contact at a home; attempted contacts for business purposes might intrude privacy and chances are one will contact family or other household members instead of the person one wishes to call. Typically used with urgent cases, or if no other contacts are available.
    work | An office contact. First choice for business related contacts during business hours.
    temp | A temporary contact. The period can provide more detailed information.
    old | This contact is no longer in use (or was never correct, but retained for records)
    mobile | A telecommunication device that moves and stays with its owner. May have characteristics of all other use codes, suitable for urgent matters, not the first choice for routine business

The value should be a properly formatted telephone number according to ITU-T E.123, but this is frequently not possible due to legacy data and/or recording methods.

Use

A value is required unless a dataAbsentReason flag is provided on the contact element. A system is required if a value is provided.

Example

Phone number for some one who works at home:

  <x>
   <system>phone</system>
   <value>+15556755745</value>
   <use>home</use>
  </x>

See further examples

Schedule

A schedule that specifies an event that may occur multiple times. Schedules are not used for recording when things did happen, but when they are expected or requested to occur. A schedule can be either a list of events - intervals on which the event occurs, or a single event with repeating criteria, or just repeating criteria with no actual event.

Note: a possible enhancement to this is to have the repeat content repeat with each event. This is richer and more complex - is the added functionality useful?

<x xmlns="http://www.hl7.org/fhir">
  <event> mand Zero+ Interval(dateTime) When the event occurs</event>
  <repeat> opt  <!-- Only if there is none or one event -->
   <frequency> cond integer Event occurs frequency times per duration</frequency>
   <when> cond code Event occurs duration from common life event</when>
   <duration> mand Duration repeating or event-related duration</duration>
   <count> cond integer number of times to repeat</count>
   <end> cond dateTime when to stop repeats</end>
  </repeat>
</x>

Terminology Bindings

  • Schedule.repeat.when is bound to the concept domain EventTiming: "A real world event that a schedule is related to". Possible values:
    HS | event occurs duration before the hour of sleep (or trying to)
    WAKE | event occurs duration after waking
    AC | event occurs duration before a meal (from the latin ante cibus)
    ACM | event occurs duration before breakfast (from the latin ante cibus matutinus)
    ACD | event occurs duration before lunch (from the latin ante cibus diurnus)
    ACV | event occurs duration before dinner (from the latin ante cibus vespertinus)
    PC | event occurs duration after a meal (from the latin post cibus)
    PCM | event occurs duration after breakfast (from the latin post cibus matutinus)
    PCD | event occurs duration after lunch (from the latin post cibus diurnus)
    PCV | event occurs duration after dinner (from the latin post cibus vespertinus)

If events are specified, at least a low must be specified for each event. If no high is specified, the event is assumed to last a limited but unknown time as clinically relevant.

If the schedule has repeating criteria, the repeat can occur a given number of times per the specified duration, or in relation to some real world event. Also, if the event repeats, a time to end the schedule can be specified, either by specifying a count number of times it can occur, or a date at which to end the schedule. If no end condition is specified, the Schedule will terminate on some criteria which is expressed elsewhere.

There are 3 rules concerning the contents of a Schedule:

  1. There can only be a repeat element if there is none or one event
  2. Only one of frequency and when can be present
  3. Only one of count and end can be present

Use

At least one event or a repeat is required unless a dataAbsentReason flag is provided on the Schedule element. If a repeat is present, either frequency or when is required.

Example

A series of appointments for radiotherapy:

  <x>
    <event>
      <low>2012-01-07T09:00</low>
      <high>2012-01-07T13:00</high>
    </event>
    <event>
      <low>2012-01-14T09:00</low>
      <high>2012-01-14T13:00</high>
    </event>
    <event>
      <low>2012-01-22T11:00</low>
      <high>2012-01-22T15:00</high>
    </event>
  </x>

BID (twice a day) (no start or end specified):

  <x>
   <repeat>
     <frequency>2</frequency>
     <duration>
       <value>1</value>
       <units>day</units>
       <code>d</code>
       <system>urn:hl7-org:sid/ucum</system>
     </duration>
   </repeat>
  </x>

1/2 an hour before breakfast for 10 days from 23-Dec 2011:

  <x>
    <event>
      <low>2011-12-23</low>
    </event>
    <repeat>
      <when>ACM</when>
      <duration>
        <value>30</value>
        <units>min</units>
        <code>min</code>
        <system>urn:hl7-org:sid/ucum</system>
      </duration>
      <end>2012-01-02</end>
    </repeat>
  </x>

Note that the end date is inclusive like the high date of an Interval.

Schema & UML models

Data Types Schema.

With regard to the UML models, see notes about the UML Object models, and particularly the note regarding the UML representation of dataAbsentReason

Change History

  • 20-Mar 2011: Removed version from system in Coding - version and module pushed to extensions
  • 19-Mar 2011: Renamed dateTime to instant, humanDate to dateTime, and introduced date.


UML Models and dataAbsentReason - FHIR v0.01

UML Models and dataAbsentReason

This specification describes the use of the dataAbsentReason attribute, which is used throughout the content models on elements of any type to indicate missing data. The dataAbsentReason attribute "may appear on any element in a resource other than those marked mandatory".

In Object-Orientated paradigms, the dataAbsentReason is a mixin. The definition of a mix-in is that it is an abstract class that provides functionality that is not inherited by specialization but rather by collecting functionality. A mixin can be thought of as a generic class that specializes it's parameter class:

This shows a mixin called "DataQualityAspect" which expresses the attribute "dataAbsentReason". The two derived classes, DataQualityAspectQuantity which inherits both Quantity and DataQualityAspect and DataQualityAspect(Quantity), which binds Quantity to the paramter T on the DataQualityAspect mixin both have the same semantics (are identical other than their type derivation).

The problem with this approach is that not only is the <<mixin>> stereotype not a recognised standard UML sytnax, but most mainstream programming languages cannot implement multiple inheritence in this form. There is two alternative approaches for implementing this in these platforms. The first is using a wrapper class:

The problem with this variation is that Quantity and DataQualityAspect(Quantity) are no longer both types of Quantity, as with a pure mixin, and this will have a series of knock on effects in implementations. The other alternative is simply to make DataQualityAspect a base class:

This is the simplest approach, but has the disadvantage that all instances of the Quantity data type carry the dataAbsentReason attribute, whether it is appropriate or not.

Implementors that use these objects in an environment where mixins are not supported must choose either of these two approaches. For simplicity, the object models defined in this specification simply bind the target type directly to the specified data type, and ignore the issue of the dataAbsentReason mixin.

Note that the dataAbsentReason may also be associated with primitive types as well.


Terminologies - FHIR v0.01

Terminologies

Throughout the FHIR specification, many elements are assigned a type of either code, Coding, or CodeableConcept. These elements are bound to a "Concept Domain", which defines the set of concepts that may be associated with the element. Each Concept Domain has a formal definition, and a binding type that may define a particular set of acceptable concepts:

Code List | The concept is directly bound to a code list defined in this specification (mostly used with elements of type "code"). In some circumstances, other additional codes may be used (not for elements with type "code")
External | The possible list of codes (concepts) is defined by an external specification, usually ISO or W3C. A reference is provided
Preferred | The concept domain is bound directly to an external coding system, and values from this coding system must be use if appropriate values exist
Unbound | The FHIR specification does not bind the concept domain to any particular set of concepts (a value set). Instead, jurisdictions, Institions, projects or applications bind the concept domain. Within the unbound concept domains, FHIR may recommend a particular value set (or coding system), or suggest values as illustrative

Note that this approach is based on the framework defined in the HL7 V3 core principles in section 5.1. Also note that when a CodeableConcept has a concept domain, this means that one of the codes in the coding list meet the binding of the concept domain, and all the codes must conform to the definition of the concept domain.

Named Systems List

This specification defines the following names (URIs) as fiexed names that may be used in the system element of the Identifier, Coding or data types.

URI | Source | Comment
Code Systems
http://snomed.info SNOMED-CT: (IHTSDO) The version, module etc may be appended to this uri following the IHTSDO specifications
OID=2.16.840.1.113883.6.96
urn:hl7-org:sid/loinc LOINC (LOINC.org)

The LOINC sid can also be used to indicate a LOINC property value by append one of the following values to the URL:

/property | PROPERTY
/time-aspect | TIME_ASPCT
/system | SYSTEM
/scale | SCALE_TYPE
/method | METHOD_TYPE
/class | CLASS

The acceptable values for these URLs are the literal values found in the definition of LOINC for the given column name.

The version of LOINC may be appended to this uri like so: urn:hl7-org:sid/loinc?v=2.36

OID=2.16.840.1.113883.6.1.
urn:hl7-org:sid/ucum UCUM: (UnitsOfMeasure.org) Generally used in the Quantity Data Type
OID=2.16.840.1.113883.6.8
urn:hl7-org:sid/icd-10 ICD-10 International (WHO)
OID=2.16.840.1.113883.6.3
urn:hl7-org:sid/icd-9 ICD-9 USA (CDC)
OID=2.16.840.1.113883.6.42
urn:hl7-org:sid/v2-[X] Version 2 table code [X] is the 4 digit identifier for a table. i.e. urn:hl7-org:sid/v2-0203
OID=2.16.840.1.113883.12.[X]
urn:hl7-org:sid/iso-639 Language Codes as defined in (ISO 639) 3 letter codes known as 639-3
OID=1.0.639.3
urn:hl7-org:sid/iso-4217 Currency Codes as defined in (ISO 4217) 3 digit currency designators
OID=1.0.4217
urn:hl7-org:sid/atc Anatomical Therapeutic Chemical Classification System (WHO)
OID=2.16.840.1.113883.6.73
Identifier Systems
urn:hl7-org:sid/uri URIs (W3C) As defined by various applicable RFCs including X
No OID
urn:hl7-org:sid/oid | OIDs | The identifier is an OID itself
urn:hl7-org:sid/uuid UUIDs Also called GUIDs
No OID
urn:hl7-org:sid/us-ssn SSN (W3C) SSN for USA. Represented with dashes removed
OID=2.16.840.1.113883.4.1

Internal Code Systems

In addition to this, a number of code sytems are defined informally through the specification. This table enumerates them, and assigns sid and OID values for them, though these are not generally used directly in this specification:

Special Values | urn:hl7-org:sid/fhir/special-values | 2.16.840.1.113883.6.305
Resource Types | urn:hl7-org:sid/fhir/resources | 2.16.840.1.113883.6.306
Logical Interactions (RESTful framework) | urn:hl7-org:sid/fhir/interactions | 2.16.840.1.113883.6.308
Message Events (Messaging framework) | urn:hl7-org:sid/fhir/message-events | 2.16.840.1.113883.6.307
Data Absent Reason | urn:hl7-org:sid/fhir/data-absent-reason | 2.16.840.1.113883.6.309

Note that all the codes in these code systems are case sensitive, and must be used in lowercase.

Special Values

Internally defined codes useful throughout the specification where Coding or CodeableConcept is used. These are defined by the code system "urn:hl7-org:sid/fhir/special-values" which has OID 2.16.840.1.113883.6.305.

true | Boolean true
false | Boolean false
trace | The content is greater than zero, but too small to be quantified (used in formulations)
sufficient | The specific quantity is not known, but is known to be non-zero and is not specified because it makes up the bulk of the material. (e.g. 'Add 10mg of ingredient X, 50mg of ingredient Y, and sufficient quantity of water to 100mL.' The null flavor would be used to express the quantity of water. )
withdrawn | The correct value is no longer available

Resource Types

In several places, the resource types themselves are used as codes, with the sid, where required, of "urn:hl7-org:sid/fhir/resource-types". This is a formal list of such codes:

Conformance | A conformance statement returned by request in an RESTful framework
Document | A documentation of clinical observations and services that are aggregated together into a single statement of clinical meaning that establishes it's own context. A clinical document is composed of a set of resources that include both human and computer readable portions. A human must attest to the accuracy of the human readable portion, and may authenticate and/or sign the entire whole
Message | A message that contains FHIR resources
Animal | An animal that has relevance to the care process -usually this is for animals that are patients.
Agent | A person who represents an organisation, and is authorised to perform actions on it's behalf
MessageConformance | A conformance statement about how an application uses FHIR messaging
Organization | For any organization/institution/government department that has relevance to the care process
Prescription | Directions provided by a prescribing practitioner for a specific medication to be administered to an individual
Profile | A Resource Profile - a statement of constraint on one or more Resources and/or Concept Domains
InterestOfCare | Yet to be defined
Admission | Yet to be defined
Specimen | Yet to be defined
Device | Yet to be defined
Patient | A patient is a person or animal that is receiving care
Group | Yet to be defined
Person | A person who is involved in the healthcare process
LabReport | The findings and interpretation of pathology tests performed on tissues and body fluids. This is typically done in a laboratory but may be done in other environments such as at the point of care
DocumentConformance | A conformance statement about how one or more FHIR documents


Extensibility - FHIR v0.01

Extensibility

This exchange specification is based on generally agreed common requirements across healthcare - many jurisdications, domains, and different functional approaches. As such, it is common for specific implementations to have valid requirements that will not be adopted by this specification. Adopting all of these requirements would make this specification very cumbersome and difficult to implement. Instead, this specification expects that these additional common requirements will be implemented as extensions.

As such, extensibility is a fundamental part of the design of this specifications. Every resource includes an extensions section that may be used to represent additional information that is not part of the basic definition of the resource. Conformant applications are not allowed to reject resources because they contain extensions, though they may need to reject resources because of the specific contents of the extensions.

Note that unlike in many other specifications, there can be no stigma associated with the use of extensions by any application, project, or standard, whatever institution or jurisdiction uses or defines them; their use of such extensions is what allows the specification to retain a core simplicity for everyone.

In order to make the use of extensions safe, and manageable, there is a strict governance applied to the definition and use of extensions. Though any implementer is allowed to define an extension, there is a set of reqiurements that must be met as part of the definition of the extension.

Extensibility Element

Each resource includes the optional extensions element before the narrative element at the end of the resource.

<x xmlns="http://www.hl7.org/fhir">
  <code> mand id Code that identifies the meaning of the extension</code>
  <definition> mand uri Source of the definition for the code</definition>
  <ref> opt id Internal reference to context of the extension (xml:id)</ref>
  <state> opt code must-understand | superceded</state>
  <value[x]> cond Value of extension</value[x]>
  <extension> cond  <!-- Zero+ Nested Extensions -->
    <!-- Content as for Extension -->
  </extension>
</x>

Terminology Bindings

  • Extension.state is bound to the concept domain ExtensionState: "The state of an extension". Possible values:
    must-understand | The extension contains information that qualifies or negates another element, and must be understood by an application processing the resource
    superceded | The extension has been promoted into the main content of the resource, and the content is found at the reference. The extension continues to be defined for backward compatibility

Notes:

  • The code identifies the meaning of the extension. The only codes that can be used are those defined using the methodology described below.
  • The source of the definition must be declared using the definition element. The definition may point directly to a computable or human readable definition of the extensibility codes, or it may be a logical URI as declared in some other specification. The definition should be version specific.
  • If present, the id in the ref element identifies a target element that is extended by the content as if it contained the extension itself. The id must point within the same resource
  • The order that extensions appear in is significant - where multiple extensions have the same ref id, they extend the target element in the order in which they appear in the extensions
  • When using xml:id attributes, the comments in the aggregation section about the value of the xml:id attribute should be kept in mind
  • Any element defined as part of the resource content, or any repeating element inside a data type, may carry an id attribute to serve as the target of an extension
  • An extension may have a value, or nested extensions, but not both. The actual name of the value element has the type added to it in place of the [x], such as valueQuantity

As well as providing additional undescribed information, extensions may be used to qualify the meaning of other elements in a way that makes them unsafe to ignore, or even to negate the meanings of other elements. Such extensions must have a state of "must-understand". Over time, an extension may be promoted to become part of the resource itself. In order to properly send the data, the extension should still be present, but should have no value element. Instead, the state of the extension is "superceded", and the ref points to the correct location for the data.

Any application processing the data of a resource must check for extensions with state="must-understand". If the application does not recognise the code on an extension that is labeled "must-understand", and where the extension either has no internal reference, or the reference is data processed by the application, it SHALL either refuse to process the data, or carry a warning concerning the data along with any action or output that results from processing the data. Note that it must always be safe to show the narrative to humans; any extension that is labelled as must-understand must be represented in the narrative. Applications are encouraged to ignore un-required extensions that they do not recognise. Applications that do not accept unknown extensions should declare this in their conformance statement.

The value[x] element has the [x] replaced with the name of one of the defined types, and the contents as defined for that type, or another extension. The value type may be one of the following:

  • dateTime
  • string
  • uri
  • humanDate
  • Attachment
  • CodeableConcept
  • Coding
  • Identifier
  • Quantity
  • Choice
  • Interval_Quantity
  • Interval_humanDate
  • Ratio
  • HumanId
  • HumanName
  • Address
  • Contact

Nested extensions cannot have a ref element. The [type] element is optional unless the definitions of the extension codes make rules about it. Extensions can never have a default value.

Defining Extensions

Extensions may be defined by any project or jurisdication, up to and including international standards organisations such as HL7 itself.

Extensions are always defined against some particular context. The following are possible contexts for an extension:

  • A particular element in a single resource
  • Anywhere a particular data type is used
  • A set of elements across one or more resources
  • a particular context in one of the mapped reference models
  • Another extension

In addition, an element definition might apply additional constraints with regards to particular element values of the target that make it's use appropriate. Extensions SHALL only be used in the contect against which they are defined.

Each extension is defined using the following fields:

todo: metadata, context

Code | Required | The code that is used in a resource to identify this extension
Context | Required | The context of this extension. See below
TargetType | Optional | The type of the path to which this applies, if it matters. This must be a valid FHIR data type as described above
Cardinality | Required | The cardinality of this extension. Specifying a minimum cardinality of 1 means that if the source system declares that it conform to the set of extensions containing this extension, it must be included in the resource
Conformance | Required | Whether the use of the extension is mandatory, conditional, optional, or prohibited. If the extension is conditional, the conditions must be described in the comments field. This field overlaps with the cardinality, and must be consistent with it.
Type | Required | The type(s) of the extension. This must be a valid FHIR data type as described above, or "Extension: x,y,z" which indicates that the extension codes x,y, and z will be contained in the extension
Concept Domain | Conditional | For the types CodeableConcept and Coding. see Terminologies
Must Understand | Required | Whether the extension must be understood by any system reading the resource. There is 3 possible values: "true" - the extension must be understood, "false" - the extension does not need to be understood, and "sender" - the sender can decide whether the extension needs to be understood
Definition | Required | A formal statement of the meaning of the content of the field
Requirements | Required | Discussion of the reason for the extension / what use cases it was defined to handle
Comments | Optional | Additional other information about the extension, including information concerning it's conditionality if indicated in the conformance field
RIM Mapping | Conditional | The formal mapping from this extension to the RIM. Required for HL7 defined extensions, but may be optional in other contexts
v2 Mapping | Optional | Mapping to a v2 segment/field/etc, if desired and appropriate.

Notes:

  • Mappings are not required to be computable (i.e. executable logic). Mappings to other specifications can also be provided.

Whenever resources containing extensions are exchanged, the definitions of the extensions must be available to all the parties that share the resources. Each extension contains a URI that references the source of the definitions. The source can be a literal reference, such as an http: url that refers to an end-point that responds with the contents of the definitions, or a logical reference (e.g. using a urn:) - for instance, to a national published standard. Literal references are preferred.

Whether the reference is a literal or logical reference, the extension definitions must be published using the fields defined as above. They may be published in narrative form, possibly as part of a larger specification. This narrative form is for human consumption. In addition, they may be published in a structured form, as either a csv file, or an XML file. The CSV file should have the fields described above as columns in the order described above, with a title row containing the case sensitive field names as above. XML files should use the format described in the XML Definitions schema (note that element and extension definitions from FHIR itself also use the same format).

Todo: extension packs & metadata Control * resources are balloted * implementations (jurisdictions, institutions, projects) must publish their extensions through HL7 extension registry/repository (will be distributed?) * extensions may be submitted to HL7 for endorsement. Committees approve them by in-committee vote, and then HL7 publishes them with endorsement * extensions should never be redefined once in used. (endorsed extensions can't have their RIM mappings changed)

As well as defining the base element structure for resources, HL7 also publishes extensions. When HL7 itself publishes extensions as part of the FHIR specification, these extensions must be used for this data whenever the data is represented in instances. HL7 publishes data definitions as extensions rather than as part of the base resource structure in order to keep the base resource structure simple and concise, and to allow implementors not to engage with an entire world's worth of functionality up front. Note that HL7 extensions are never flagged as must-understand - if HL7 publishes resource content that must be understood, it will be part of the resource content itself, since everyone has to understand it anyway.

Implementations are encouraged to share their extensions with HL7; the domain committees will work to elevate the extensions into HL7 published extensions or the into the base resource structure itself.


Constraint Statement - FHIR v0.01

 todo: conformance and realms

Constraint

This specification describes a set of base resources that are used in many different contexts in healthcare. In order to make this manageable, applications need to be able to provide a structured statement of which elements of a resource are used, and how. In addition the existing elements, the use of extensions also needs to be described. These structured statements are actually constraint statements that describe a particular pattern of usage. As a general tool, they find use in several different contexts:

  • Describing testable conformance rules for applications that read and write FHIR resources
  • Making rules about how information is represented in jurisdictions and institutions
  • Describing common clinical patterns of use of general resources

The final form of these conformance descriptions is a constraint statement, which may be used at run time to assist with application to application negotiation, or it may be used at design time or even purchase time to assist implementers to understand the capabilities of the system. This specification uses the general constraint statement defined here in 4 contexts:

  • Conformance Resource: a statement of functionality for a RESTful server or client
  • Messaging End-Point Description: a statement of services provided or consumed by a messaging interface
  • Document Specification: a description of the contents of a set of resources aggregated into a document
  • Resource Profile: a description of how a resource is used in a particular way - often used as Clinical Templates, which

The constraint statement is a fixed XML format that is used to represent the core part of these various descriptions of use, which is the actual contents of a resource.

Unpicking

One common operation in a constraint statement is to take an element that may occur more than once, and describe a series of different constraints on the elements in the list. In this way, the list is split into a series of individual elements or sub-lists. In FHIR, this operation is known as "unpicking" a list. Here is an example to illustrate the process:

Resource Definition | Profile for Acme, Inc
relationship [0..*] type : Coding name : string | parent [1..2] type = PAR name... guardian [0..1] type = GUARD name... child [0..6] type = CHILD name...

In this example, the resource definition defines the relationship element which may occur multiple times. The profile for Acme, Inc constrains the relationships into 3 different kinds: 1 or 2 parents, up to 6 children, and maybe a guardian. No other relationships are supported by the Acme system.

Note that in FHIR, only the resource is ever actually exchanged. The profile describes a way of using the resource, but the item profile names ("parent", etc in this list) are never exchanged. In order the unpicking to be useful, systems must be able to determine which relationships in the relationship list that is actually exchanged are parent, child, or guardian; in this particular case, the determination is achieved by fixing the value of the relationship type element. Fixing a code value is the most common way to unpick a list.

Constraint Statement

Note that the context of appearing will make it clear whether this resource constraint specification is written from the context of the resource instance, a writing or a reading application

<x xmlns="http://www.hl7.org/fhir">
  <type> mand code The Type of the resource being described</type>
  <profile> cond uri Resource Profile that supplies the constraints</profile>
  <name> opt string Name for this Constraint Statement</name>
  <purpose> opt string Human summary: why describe this resource?</purpose>
  <element> cond  <!-- Zero+ -->
   <path> mand string The path of the element (see the formal definitions)</path>
   <name> opt string Name this constraint for re-use & unrolling</name>
   <purpose> opt string Human summary: why describe this element?</purpose>
   <min> mand integer Minimum Cardinality</min>
   <max> mand code Maximum Cardinality (a number or *)</max>
   <type> opt code Type of the element</type>
   <conformance> mand code Mandatory|Conditional|Optional|Prohibited</conformance>
   <condition> cond string Condition if conformance=Conditional</condition>
   <mustSupport> opt boolean If the element must be usable</mustSupport>
   <mustUnderstand> opt boolean If the element must be understood</mustUnderstand>
   <definition> opt string More specific definition</definition>
   <mapping> opt  <!-- Zero+ -->
    <target> mand string Which mapping this is (v2, CDA, openEHR, etc)</target>
    <map> opt string Details of the mapping</map>
   </mapping>
   <resource> cond  <!-- If context includes aggregation and type=Resource() -->
    <aggregated> mand boolean Whether this resource is aggregated</aggregated>
    <profile> opt uri Reference to a Resource Profile</profile>
   </resource>
   <valueSet> opt string Value set id (only if coded)</valueSet>
   <value> opt  <!-- Zero+ -->
    <name> cond string Reference to another element by element.name</name>
    <[type]> cond Fixed value: [as defined for type]</[type]>
   </value>
  </element>
</x>

Terminology Bindings

  • Constraint.type is bound to the concept domain ResourceType which has the allowed values of any defined Resource Type name
  • Constraint.element.type is bound to the concept domain DataType which has the allowed values of any defined data Type name (including Resource)
  • Constraint.element.conformance is bound to the concept domain ConformanceType: "The conformance value for an element". Possible values:
    Mandatory | The element is or must always be present without a dataAbsentReason
    Conditional | The element may need to be present (with no dataAbsentReasons) depending on the condition
    Optional | The element may or may not be present
    Prohibited | The element can not present or will be rejected if received

Notes:

  • The name of the resource is only used as a logical target for .element.aggregation.reference. which may reference another resource constraint in same resource by this name (#[name]), or a different resource by an absolute uri. In the case of an absolute uri, it must resolve literally or logically to a Resource Profile
  • The constraint statement has a flat list of elements. The path element provides the overall structure and matches the value in the formal definitions exactly
  • The condition element must be present if the conformance value is conditional. There is no formal computable grammar for the condition
  • The type of the element is mostly fixed in the underlying resource definitions, so it can be left out of the constraint specification. However when the type is open (resource link to a choice, or a link to any resource, or a choice of data types), then this field can be used to pick a narrower set of types
  • Definition is provided so that the constraint statement can provide a more specific definition for the field in a specific context. For instance, the underlying resource definition might be "Result value", and the more specific resource definition could be "Plasma Cholesterol Test Value". The meaning needs to be consistent with the underlying definition, but narrower - a constraint on it. If no definition is provided, the inherited definition still applies
  • There can be more than one definition for each element path. The constraint specification can define multiple different constraints for any element, and then use them in different places. In practice, this is useful for elements in a list, and the differently named constraint profiles are invoked using the values element. The name of the element constraint must be unique within the constraint specification for that resource
  • For an element with a maximum cardinality of 1, there can only be one entry in the value list, which is either a literal fixed type (with an element name matching the type of the fixed value), or a name, which is a reference to a named constraint pattern. If the element has a type of "list", then there can be multiple values - again, either fixed values with a type, or a named constraint. Each of these appears in the list with the order and cardinality specified. By this means, a list may be "unpicked" into a series of different components
  • The extensions element can be unpicked using this mechanism in order to define the applicable extensions

TODO: Is any control over narrative required?

Formal Definitions

The formal definitions for the elements above. Also available as an XML file.

Constraint
Control | Mandatory, 1..1
Constraint.type
Definition | The Type of the resource being described
Control | Mandatory, 1..1
Type | code from ResourceType
Constraint.profile
Definition | Reference to a resource profile which includes the constraint statement that applies to this resource
Control | Conditional, 0..1: Provide either a profile reference or constraints on the resource elements
Type | uri
Constraint.name
Definition | The name of this aggregation profile
Control | Optional, 0..1
Type | string
Comments | This field is the target for a named aggregation definition (aggregation.name)
Constraint.purpose
Definition | Human summary: why describe this resource?
Control | Optional, 0..1
Type | string
Constraint.element
Control | Conditional, 0..*: Provide either a profile reference or constraints on the resource elements
Constraint.element.path
Definition | The path of the element (see the formal definitions)
Control | Mandatory, 1..1
Type | string
Constraint.element.name
Definition | Name this constraint for re-use & unrolling
Control | Optional, 0..1
Type | string
Constraint.element.purpose
Definition | Human summary: why describe this element?
Control | Optional, 0..1
Type | string
Constraint.element.min
Definition | Minimum Cardinality
Control | Mandatory, 1..1
Type | integer
Constraint.element.max
Definition | Maximum Cardinality (a number or *)
Control | Mandatory, 1..1
Type | code
Constraint.element.type
Definition | Type of the element
Control | Optional, 0..1
Type | code from DataType
Constraint.element.conformance
Definition | Mandatory|Conditional|Optional|Prohibited
Control | Mandatory, 1..1
Type | code from ConformanceType
Constraint.element.condition
Definition | Condition if conformance=Conditional
Control | Conditional, 0..1: Required if conformance = conditional
Type | string
Constraint.element.mustSupport
Definition | If the element must be usable
Control | Optional, 0..1
Type | boolean
Constraint.element.mustUnderstand
Definition | If the element must be understood
Control | Optional, 0..1
Type | boolean
Constraint.element.definition
Definition | More specific definition
Control | Optional, 0..1
Type | string
Constraint.element.mapping
Control | Optional, 0..*
Constraint.element.mapping.target
Definition | Which mapping this is (v2, CDA, openEHR, etc)
Control | Mandatory, 1..1
Type | string
Constraint.element.mapping.map
Definition | Details of the mapping
Control | Optional, 0..1
Type | string
Constraint.element.resource
Definition | If context includes aggregation and type=Resource()
Control | Conditional, 0..1: If context includes aggregation and type=Resource()
Constraint.element.resource.aggregated
Definition | Whether this resource is aggregated
Control | Mandatory, 1..1
Type | boolean
Constraint.element.resource.profile
Definition | Reference to a Resource Profile
Control | Optional, 0..1
Type | uri
Comments | The reference might be a simple name in the form #[name], which is a reference to another named constraint in a resource - where the resource contains more than one constraint, or a RUL which is a reference to a resource Profile
Constraint.element.valueSet
Definition | Value set id (only if coded)
Control | Optional, 0..1
Type | string
Constraint.element.value
Control | Optional, 0..*
Constraint.element.value.name
Definition | Reference to another element by element.name
Control | Conditional, 0..1: Either a name or a fixed value is required
Type | string
Constraint.element.value.[type]
Definition | Fixed value: [as defined for type]
Control | Conditional, 0..1: Either a name or a fixed value is required
Type | *


Implementation Details - FHIR v0.01

Implementation Details

While the FHIR Resources are designed with a simple RESTful HTTP-based implementation in mind, it is not necessary to use this implementation framework. This specification also defines a straight messaging based implementation framework for FHIR resources, and a document-based framework, as well as documenting how FHIR resources are used with hData.

SOA

Alternatively, it is not necessary to use any of these approaches; resources can be exchanged or persisted using any technical means that is appropriate to the context at hand. A common use of FHIR resources or aggregations is as parameters of service interfaces. FHIR itself does not define any particular service interface; instead, other standards and implementations define their own service interfaces and architecture that use FHIR resources. As long as the resources that are used are conformant with regard to this specification, and the rules for authoring and reading applications are followed, then the implementation can claim conformance to "FHIR Resources". Such implementations will need to resolve several issues:

  • Resource references need to be able to be resolved. There are a variety of solutions to this, from ensuring that the all the relevant resources are aggregated together, or that all relevent resources are passed as parameters in a service call, through to a resource repository that provides access to all reference resources.
  • The Resource metadata items "Version Id" and "Last Modified Date" are provided for use in resolving resource versioning and concurrency issues, both from a technical and human perspective. Most contexts of use will require at least one if not both of these attributes for some uses, and the implementation framework will need to resolve how and when they are exchanged
  • The resource metadata item "Master Location" may be useful as part of a solution towards resolving resource references, and/or handling issues pertaining to distrubed use and re-use of resources, and implementations should describe how this data item is handlded
  • The basic conformance statement allows authoring and reading applications to describe their rules concerning the contents of a resource. The implementation will need to describe how this constraint statement fits into the exchange/persistence context.
  • How transactional information such as data enterer, author(s), responsible party, consent, and approvals is treated

The resolution to these issues should be documented and published somewhere.

Using Resources

Given these options, there are many ways to implement any particular workflow. There are many ways to use resources to build working systems:

  • A RESTful paradigm where resources are exchanged separately using http transactions directly as defined in this specification. Implementations can use both push and pull, or a mix of the two
  • The resources can be exchanged in messages or some other SOA implementation, where the resources are directly the contents/parameters that are exchanged
  • The resources can be "aggregated" into documents that are self-contained and complete collections of linked resources, and then these documents can be exchanged and/or persisted
  • The resources can be embedded in HTML pages or other web content such as content feeds

Useful Resources

General Resources:

  • All schemas as a .zip (includes base schemas, resource schemas, and metadata schemas)
  • Single combined definitions, including data types
  • The UML definitions as an XMI file (or the Enterprise Architect source)

Resource specific resources:

Note: the JSON examples are simply the XML examples auto-converted to JSON by the json.org code. TODO: Add note about why JSON is included.

All of these resources except the JSON format are normative (i.e. Ballot comments may be made against these resources with regard to their correctness, other comments may be ruled out of scope). The reference implementations below are informative, and not subject to ballot.

Reference Implementations

Reference implementations are provided for implementer interest and assistance. Other implementations can be used, including code generated from the schemas.

  • Delphi: Resource Definitions, and XML & JSON parsers. D5+. TODO: remove dependencies on unpublished code.
  • Java: Resource Definitions + parser (+ more todo). The java reference implementation depends on XmlPull (http://www.xmlpull.org/) and the Apache Commons Codec library (http://commons.apache.org/codec/).
  • C#: Resource definitions (+ more todo)
  • ECore: Formal Object Definitions in OCLinECore text format - under development

Default Values

This is a list of the all the default values defined in the FHIR specification:

  • In the RESTful conformance declaration, support for a transaction is declared on an element of type boolean. If no element is present, the transaction is not supported.


Aggregations - FHIR v0.01

Aggregation

One basic operation performed with resources is to aggregate a group of resources into a single XML document. This is performed in many of the implementation frameworks. Aggregated resources are useful for grouping resources together for a variety of different reasons, including:

  • Listing a set of resources that have changed since a given instant in time
  • Exchanging a set of resources as a single batch
  • Grouping a self contained set of resources to act as an exchangeable and persistable group with clinical integrity (i.e. a clinical document)

Resources are aggregated using the Atom format (http://tools.ietf.org/html/rfc4287), following this template:

<feed xmlns="http://www.w3.org/2005/Atom" xmlns:gd="http://schemas.google.com/g/2005">
  <title mand type="string">text statement of purpose</title>
  <updated mand type="dateTime">when aggregation happened</updated>
  <id mand type="id">unique id for this aggregation</id>
  <link mand rel="via" href="aggregating application url"/>

  <entry gd:etag="version id">    <!-- Zero+ -->
    <title mand type="string">text summary of resource</title>
    <link mand rel="self" href="Master Location for Resource"/>
    <id mand type="id">Master Id for this resource</id>
    <updated mand type="dateTime">Last Updated for resource</updated>
    <published opt type="dateTime">Time resource sourced for aggregation</updated>
    <author>
      <name mand type="string">Name of Human or Device that authored the resource</name>
      <uri opt type="uri">Link to the resource for the author</uri>
    </author>
    <category term="[Resource Type]" scheme="urn:hl7-org:sid/fhir/resource-types"/>
    <content mand type="text/xml">
      <[ResourceName] xmlns="http://www.hl7.org/fhir">
         <id mand type="id">Resource Id (i.e. normal resource content)</id>
         <!-- Content for the resource -->
      </[ResourceName]>
    </content>
    <summary opt type="xhtml">
         <!-- Narrative from resource for a browser. Must be wrapped in a <div> -->
    </summary>
    <Signature xmlns="http://www.w3.org/2000/09/xmldsig#" opt>
         <!-- Enveloped Digital Signature (see Atom section 5.1) -->
    </Signature>
  </entry>
</feed>

Notes:

  • Logically, an aggregation is a set of resources that are prepared to send somewhere for consumption - a "feed". There is no implication that the feed is a standing arrangement (though this is not precluded)
  • The title for the feed and the entry are arbitary human readable content and not to be used for any automated processing. Applications may populate these in any useful way
  • Every aggregation must have a unique id, which must be a valid id. UUIDs are recommended
  • The link elements are mandatory in the atom feed format.
  • The type attribute on the content element does appear in the xml instance (it's an atom type, not a FHIR type)
  • The entry element carries the three pieces of resource metadata: Version Id, Last Updated, and Master Location
  • Author is a required element by the atom element. The author of a resource is not explicit in the FHIR resource model; instead it is delegated to the infrastructure. The name is the name of a human author, or a device. The uri is a link to the resource for the author
  • In a RESTful implementation, the Master Location is the URL of the resource on a system that is the master for that resource. In the absence of a known master, or a RESTful implementation, some other location may be used.
  • An xml:base element may be specified on the content element, though one is not needed for FHIR resources.
  • The aggregation can be signed with a single Enveloped Digital Signature as described in the Atom specification

Readers of the aggregated resources should always look through the resources in the atom feed when a resource reference is encountered. The resource reference will have the resource type and the id of the target, like this:

  <institution>
    <type>Organization</type>
    <id>1145c09c-73d0-4297-9835-620e4afa9deb</id>
  </institution>

A reader trying to find this institution should always look through the entries in the atom feed prior to looking anywhere else for the institution. If that organization is in the feed, it would look like this:

   .. feed ..
  <entry>
    ..
    <id>1145c09c-73d0-4297-9835-620e4afa9deb<id>
    ..
    <category term="Organization" scheme="urn:hl7-org:sid/fhir/resource-types"/>

    <content type="text/xml">
      <Organization xmlns="http://www.hl7.org/fhir">
         <id>1145c09c-73d0-4297-9835-620e4afa9deb</id>
         <!-- other Content for the resource -->
      </Organization>
    </content>
  ... feed ...

It would also be possible to locate the resouce by the url (todo: explanation of this method).

XML Ids in resources

FHIR resources make use of XML id attributes as targets for pointers elsewhere in the document. XML id attributes must be unique in the context of a single XML document, and the atom feed is a single XML document. it can be difficult and time consuming - or impossible in the presence of a digital signature - to fix the id attributes so they are unique when aggregating resources. For this reason, it is highly recommended that all XML id attributes are prefixed with the type and master id of the resource, like this: [Type]_[master id]_id (e.g. Person_23442_1).

JSON Format

For the same reasons as resources, it is useful to define a standard JSON representation of the atom format. Several existing JSON representations of the atom feed are in general use; this specification adopts the Google GData representation.

Note: All of the existing JSON representations of Atom are lacking in simplicity. The Google conversion is at least algorithmic.

RESTful support for Aggregations

The standard RESTful endpoints (such as [baseurl]/people/#{id}.xml for a Person resource, or [baseurl]/documents/#{id}.xml) handle the individual resources, and not aggregations (though, per the restful spec, they may serve up aggregations for the history and update operations). There is a special end-point for aggregations at the relative url "/assemblies", which supports the following operations:

Instance
read | Retrieve an aggregation
vread | Not supported - aggregations have no version history
update | Not supported - aggregations never change
delete | Delete an aggregation
validate | Check that the content would be acceptable as an update
history | Not supported - aggregations never change
transaction | Not supported
Manager
search Search the aggregations based on some filter criteria. Supported search parameters
  • Document.id - an id of a document. There should only be one aggregation for each document (optional, for systems that support documents)
  • Message.id - an id of a message. There is usually only one aggregation per message. (optional, for systems that archive messages and make them available in this fashion)
  • [ResourceType].id - an id of a resource that may be brought into an aggregation. Multiple aggregations should be expected in the response. (also optional)
create | Create an aggregation (i.e. post to the server. The ID is assigned by the client)
updates | Get a list of updates to resources of this type, optionally with some filter criteria
transaction | Not supported
conformance | Not supported (no conformance statement for aggregations directly)
schema | Not supported (no schema for FHIR atom directly)

For all these resources, the id (as used in the RESTful transactions) is the unique id of the aggregation. Note that creating an aggregation does not mean that any apparent implied transactions in the resources found in the aggregation should be applied to the server resources and/or executed by any system - specific transaction are required, either using the RESTful or messaging frameworks, or a SOA implementation.


HTTP/RESTful Framework - FHIR v0.01

RESTful HTTP Details

In addition to defining a set of base resources, FHIR also provides a RESTful implementation using HTTP. Each resource type has the same set of interactions defined that can be used to manage the resources in a highly granular fashion. Applications claiming conformance to this framework claim to be conformant to "RESTful FHIR".

Note that this RESTful framework adheres as closely as possible to the REST principles. Transactions are performed directly on the server resource using an HTTP request/response. The HTTP calls may be authenticated against a single user account (including using OAuth), but this doesn't cater for common transaction metadata such as multiple users, responsible party, reasons, consents etc that is commonly encountered in healthcare. Instead, it is assumed that appropriate security and logs are managed by the client (perhaps through using ATNA), and the server trusts the client to maintain these. One implication of this is that this RESTful framework is only suitable for use where such trust relationships exist (e.g. in a single institution), and not suitable where such trust does not exist (e.g. state & national EHR systems, and general internet-based ecosystems). Similarly, this simple RESTful interface has no support for explicit archiving, for instance. These type of more sophisticated usages should consider a messaging or SOA-based approach, or some kind of profiled REST interface, such as hData.

The following logical interactions are supported:

Instance |
read | Read the current state of the resource
vread | A version specific read of the resource
update | Update an existing resource by it's id (or create it if it is new)
delete | Delete a resource
validate | Check that the content would be acceptable as an update
history | Retrieve the update history for the resource
transaction | Support for specific transactions defined on the resource
Manager
search | Search the resource type based on some filter criteria
create | Create a new resource with a server assigned id
updates | Get a list of updates to resources of this type, optionally with some filter criteria
transaction | Support for specific transactions defined on the resource type
conformance | Get a conformance statement for support of this resource type
schema | Get the XML schema for this resource

Note that while these same logical interactions are defined on all resources, applications are not required to implement all of them. An application's conformance statement must say what logical interactions are supported.

Base URL

Each resource lives at a specific location with a known URL which is automatically determined from the id, the resource type, and the base url of the system.

The concept of the base URL is defined because because this specification defines an interface rather than any particular system. The base URL is the address at which all the resources defined by this interface are found. The base URL takes the form of

http(s)://server/path

The path may end with a trailing slash or not. Each resource defined in this specification has a manager that lives at the address "/[type name]" where type name is the name of the type in lower case and plural. So, for instance, the resource manager for the type "Patient" will live at:

http://server/path/patients

Note that applications may need to remove the trailing slash from the base URL when appending the resource address. All the logical operations are provided relative to the address of the resource and defined in these terms below. Note that this means that given the address of any one resource on a system, the correct address for all the other resources may be determined. However since application URLs may change, and because local configuration may dictate that the provider of a resource is different to that claimed by any particular provider or consumer, applications should be adroit at replacing base URLs.

HTTP Status Codes

For all interactions, if the requested resource is returned as requested, the HTTP status 200 OK should be used (except for "create" where the status code should be 201). If the resource is not known, the server should return an HTTP status code 404 Not Found. Other HTTP errors may be returned as appropriate.

An HTTP redirect should not be used to indicate that the master id has changed. This is because the ids are treated as stable references elsewhere and used for matching. Changing an id will cause problems with this matching. Redirects may be issued to redirect to a new base URL, or to a master system for a given resource.

Resource Metadata & Versioning

Each resource has an associated set of resource metadata. These map to the http request and response using the following fields:

Metadata Item | HTTP Response Header
Version Id | ETag
Last Modified Date | Last-Modified
Master Location | Content-Location

Security

For this specification, normal HTTP security and authentication rules apply. The base URL will specify whether SSL is required. HTTP authentication, including possibly the requirement for client certificates, may be required by the provider. It is a matter of application requirements and local configuration whether all interactions run under the account of a trusted system user, or whether each interaction runs under the account of the individual user.

All the URLs defined below may be extended to support the OAuth protocol.

Content Types & File Extensions

This same RESTful protocol may be used with either the XML or JSON representations defined for resources. The mime types text/xml and application/json are to be used in the HTTP Content-Type or Accept header respectively to indicate which form is the requested or returned content takes . In addition, the URLs defined below may have the file extensions .xml or .json may be appended to the URL where appropriate, as indicated by (.ext) below. For reasons of general compatibility, servers and clients may accept application/xml, but must specify text/xml themselves.

Servers are required to support the XML form. Support for the JSON format is optional. Servers must support the Content-Type and Accept headers. Because of established browser behaviour, file extensions in the URL overrule the values specified in the headers.

read

The read interaction accesses the current contents of a resource. The interaction is performed by an HTTP GET operation as shown:

  GET [baseurl]/[resourcetype]/{@id} (.ext)

This returns a single instance with the content that which is specified for the resource type. This url may be accessed by a browser. The id is preceded by a ":" to make parsing the url easier. The possible values for the id itself are described in the Resource Type. The http headers ETag, and Last-Modified must be returned by the server, and the Content-Location should be returned.

vread

The vread interaction preforms a version specific read of the resource. The interaction is performed by an HTTP GET operation as shown:

  GET [baseurl]/[resourcetype]/{@id}/version-{:vid} (.ext)

This returns a single instance with the content that which is specified for the resource type. This url may be accessed by a browser. The http headers ETag, and Last-Modified, must be returned by the server, and are the values that apply for this version of the resource.

The version id is an opaque identifier that conforms to the same format requirements as a resource id. The id may be found by performing a history operation (see below), by recording the ETag return with a normal fetch operation, or from a version specific reference in a content model. The vread interaction should succeed even after a resource is deleted as long as a correct version identifier is provided.

update

The update interaction changes an existing resource, or creates a new resource of it doesn't already exist. The update interaction is performed by an HTTP PUT operation as shown:

  PUT [baseurl]/[resourcetype]/{@id} (.ext)

The server returns a copy of the newly updated resource (which may not be the same as that submitted) with the response.

Servers may choose to require version checking, and only accept submitted updates that have an If-Match header that contains a matching version id for the current version of the resource. According to the http specification, it's up to the client to decide whether to provide an If-Match header, and if it does, the server must observe it. On normal update operations the client should not provide an If-Match header, and if the server wishes to receive it, it should return a 412 error with the words "If-Match" in the response text. Upon receiving this error, the client should resubmit with the If-Match header, if it is able. The Last-Modified dateTime may not suitable for concurrency checking as it only has a resolution limit of per-second, and there are other problems with dates as well.

delete

The delete interaction removes an existing resource. The interaction is performed by an HTTP DELETE operation as shown:

  DELETE [baseurl]/[resourcetype]/{@id} (.ext)

Servers may refuse to delete a resource depending on the resource type and/or contents, and on audit requirements. If a server refuses to delete resources of that type on principle, then it should return the status code 405 method not allowed. If the server refuses to delete a resource because of reasons specific to that resource, such as referential integrity, it should return the status code 412 Expectation Failed.

validate

The validate interaction checks whether the attached content would be acceptable as an update to an existing resource. The interaction is performed by an HTTP POST operation as shown:

  POST [baseurl]/[resourcetype]/validate
  POST [baseurl]/[resourcetype]/validate/{@id}

In the first case, the content is checked against the general specification and against the conformance profile that applies to the application. In the second case, the validation occurs as if the resource were submitted as an update, and additional instance specific things such as referential integrity and update rules are applied as well. The return content has status 200 OK if the content validates ok, or 412 Precondition Failed, with the following content:

 <validation xmlns="http://www.hl7.org/fhir">
   <error mand type="string">General error message</errror>
   <messages type="list">   <!-- Zero+ -->
     <message>
       <path opt type="string"xpath to the issue</path>
       <error mand type="string">Description of the problem</error>
     </message>
   <messages>
 </validation>

history

The history interaction retrieves the history of the resource. The interaction is performed by an HTTP Get operation as shown:

  GET [baseurl]/[resourcetype]/{@id} (.ext)?view=history

The return content is an Atom feed aggregration containing the version history for that resource, sorted with oldest versions first.

search

This interaction searches the resource type based on some filter criteria. The interaction is performed by an HTTP Get operation as shown:

  GET [baseurl]/[resourcetype]/search (.ext)

Because of the way that some user agents treat POST requests, POST submissions are also allowed, though the semantics are exactly the same as a GET operation. Search operations take a series of parameters that are encoded in the URL or as an x-multi-part-form submission for a POST. Each resource type defines the applicable search parameters, and servers may declare additional parameters in their conformance statements. In addition, the following common search parameters apply to all resource types:

n | Starting offset of the first record to return in the search set
count | Number of return records requested. The server is not bound to conform.

The search results may be divided into a number of pages using offsets. It is at the discretion of the server how many results to return, though the client may request a particular number of a count parameter. If the client wishes for more results, it should use the n parameter. More generally, the client uses parameters to narrow the search and increase it's usefulness. Note that which parameters to support is at the discretion of the server.

The return content is an Atom feed aggregration containing the results of the search in a defined order. This specification does not assign any particular meaning to the order of the resources.

create

The create interaction creates a new resource. The interaction is performed by an HTTP POST operation as shown:

  POST [baseurl]/[resourcetype] (.ext)

The server returns a a copy of the newly created resource (which may not be the same as that submitted) with the acknowledgement, along with a Location: header which also contains the id of the created resource:

 Location: [baseurl]/[resourcetype]/{new-id} (.ext)

The client may submit the content with or without an id included. If the submitted resource contains an id, the server must either honor the requested id, or return a 409 Conflict if a resource already exists by that id, or a 403 Forbidden if it will not honor client defined ids at all

updates

The updates interaction retrieves a list of changes to the resource type. The interaction is performed by an HTTP Get operation as shown:

  GET [baseurl]/[resourcetype]/updates (.ext)

The return content is an Atom feed aggregration containing the update history for that resource type, sorted with oldest updates first.

The client can use parameters to filter the update list. The following table summarises ths search parameters:

since | The time from which to return new updates
from | A version Id (e-tag value) from which to return updates

transaction

The transaction interaction provides support for specific transactions defined against the resource by this specification. The transaction interaction is supported on both individual resources and the type:

  POST [baseurl]/[resourcetype]/transaction/[name](.ext)
  POST [baseurl]/[resourcetype]/transaction/{@id}/[name](.ext)

The name of the transaction, along with the content model of the request and response will be specified against each resource when the possible transactions are defined throughout this specification.

conformance

The conformance interaction retrieves the application's conformance statement for the resource. The interaction is performed by an HTTP Get operation as shown:

  GET [baseurl]/[resourcetype]/conformance (.ext)

For the return content, see the Conformance Resource. If a 404 Unknown is returned, the resource is not supported, and no other interactions are implemented.

schema

The schema interaction retrieves a w3c schema for the resource. The interaction is performed by an HTTP Get operation as shown:

  GET [baseurl]/[resourcetype]/schema.xsd

The return content is a W3C schema that describes the resource. The schema does not have to be the one defined with this specification; it can eliminate elements not supported by the server, and explicitly define extensions supported by the server. However the xml format it describes must be consistent with the rules defined in this specification.

Intermediaries

The HTTP protocol may be routed through an HTTP proxy such as squid. Such proxies are transparent to the applications, though implementors should be alert to the effects of rogue caching.

Interface engines may also be placed between the consumer and the provider; these differ from proxies because they actively change the content and/or destination of the HTTP exchange. Such agents are allowed, but are bound to the conform to this specification. In order to assist with troubleshooting, any agent that modifies an HTTP request or Response content must add a stamp to the HTTP headers like this:

  request-modified-[identity]: [purpose]
  response-modified-[identity]: [purpose]

The identity must a single token defined by the administrator of the agent that will sufficiently identify the agent in the context of use. The header must specify the agents purpose in modifying the content. End point systems must not use this header for any purpose; it's aim is to assist with system troubleshooting.


Conformance - FHIR v0.01

Conformance

A conformance statement returned by request in an RESTful framework.

The relative url is /conformances

Content

<Conformance xmlns="http://www.hl7.org/fhir">
  <id> mand id ConformanceStatement Id (UUID)</id>
  <date> mand dateTime Publication Date</date>
  <publisher> mand
   <name> mand string Publishing Organization</name>
   <address> opt Zero+ Address Address of Organization</address>
   <contact> opt Zero+ Contact Contacts for Organization</contact>
  </publisher>
  <software> mand
   <name> mand string Name software is known by</name>
   <version> mand string Version covered by this statement</version>
   <releaseDate> opt dateTime Date this version released</releaseDate>
  </software>
  <mode> mand code client | server</mode>
  <profile> opt Zero+ uri other profiles that apply (i.e. code binding rules)</profile>
  <resource> mand Constraint Resource Type with constraints</resource>
  <operation> cond
   <read> opt boolean if supported</read>
   <vread> opt boolean if supported</vread>
   <update> opt boolean if supported</update>
   <delete> opt boolean if supported</delete>
   <validate> opt boolean if supported</validate>
   <history> opt boolean if supported</history>
   <transaction> opt  <!-- only if supported -->
    <name> mand One+ code transaction names supported</name>
   </transaction>
   <search> opt  <!-- only if supported -->
    <param> mand One+ string search params supported</param>
   </search>
   <create> opt  <!-- if supported -->
    <id> mand code source of id: client | server | either</id>
   </create>
   <updates> opt boolean  <!-- if supported -->
    <param> mand Zero+ string update filter params supported</param>
   </updates>
   <schema> opt boolean if supported</schema>
  </operation>
  <extensions> opt See Extensions   See Extensions </extensions>
  <text> mand Narrative Text summary of conformance profile for human interpretation</text>
</Conformance>

Schema for Conformance and an example (or formatted for browser)

Terminology Bindings

  • Conformance.mode is bound to the concept domain RestfulConformanceMode: "The mode of a restful conformance statement". Possible values:
    client | The application acts as a server for this resource
    server | The application acts as a client for this resource
  • Conformance.resource is bound to the concept domain ResourceType which has the allowed values of any defined Resource Type name
  • Conformance.operation.create.id is bound to the concept domain ResourceIdSource: "The system responsible for the provision of a resource unique id". Possible values:
    client | The client must provide a unique resource id
    server | The server defines the id and will reject any client attempt to define it
    either | The client can provide a unique resource id, or the server will define it instead

Notes:

  • The MessageConformance resource is a special case; it is only defined for the conformance framework, and is not encountered in other contexts
  • The interpretation of request and resource depends on the mode. If the mode is sender, then request specifies what the application sends, and response specifies what it accepts. If the mode is "listener", then this is reversed
  • If a request or response is not specified for an event, then no rules are made for it
  • Events that are not listed are not supported

Formal Definitions

The formal definitions for the elements above. Also available as an XML file

Conformance
Definition | A conformance statement returned by request in an RESTful framework
Control | Mandatory, 1..1
Conformance.id
Definition | Globally unique Conformance Statement Id (Must be a UUID)
Control | Mandatory, 1..1
Type | id
Conformance.date
Definition | Date that the conformance statement is published
Control | Mandatory, 1..1
Type | dateTime
Conformance.publisher
Definition | The organization that publishes this conformance statement
Control | Mandatory, 1..1
Conformance.publisher.name
Definition | Name of Organization
Control | Mandatory, 1..1
Type | string
Conformance.publisher.address
Definition | Address of Organization
Control | Optional, 0..*
Type | Address
Conformance.publisher.contact
Definition | Contacts for Organization
Control | Optional, 0..*
Type | Contact
Conformance.software
Definition | The software that is covered by this conformance statement
Control | Mandatory, 1..1
Conformance.software.name
Definition | Name software is known by
Control | Mandatory, 1..1
Type | string
Conformance.software.version
Definition | Version covered by this statement
Control | Mandatory, 1..1
Type | string
Conformance.software.releaseDate
Definition | Date this version released
Control | Optional, 0..1
Type | dateTime
Conformance.mode
Definition | client | server
Control | Mandatory, 1..1
Type | code from RestfulConformanceMode
Conformance.profile
Definition | Additional other profiles that apply to this conformance statement.
Control | Optional, 0..*
Type | uri
Comments | Generally these profiles make constraints on the bindings of concept domains / value sets
Conformance.resource
Definition | Resource Type with constraints
Control | Mandatory, 1..1
Type | Constraint from ResourceType
Conformance.operation
Control | Conditional, 0..1: A resource type is required if the event declaration has multiple focal resources
Conformance.operation.read
Definition | if supported
Control | Optional, 0..1
Type | boolean
Conformance.operation.vread
Definition | if supported
Control | Optional, 0..1
Type | boolean
Conformance.operation.update
Definition | if supported
Control | Optional, 0..1
Type | boolean
Conformance.operation.delete
Definition | if supported
Control | Optional, 0..1
Type | boolean
Conformance.operation.validate
Definition | if supported
Control | Optional, 0..1
Type | boolean
Conformance.operation.history
Definition | if supported
Control | Optional, 0..1
Type | boolean
Conformance.operation.transaction
Definition | only if supported
Control | Optional, 0..1
Conformance.operation.transaction.name
Definition | transaction names supported
Control | Mandatory, 1..*
Type | code
Conformance.operation.search
Definition | only if supported
Control | Optional, 0..1
Conformance.operation.search.param
Definition | search params supported
Control | Mandatory, 1..*
Type | string
Conformance.operation.create
Definition | if supported
Control | Optional, 0..1
Conformance.operation.create.id
Definition | source of id: client | server | either
Control | Mandatory, 1..1
Type | code from ResourceIdSource
Conformance.operation.updates
Definition | if supported
Control | Optional, 0..1
Type | boolean
Conformance.operation.updates.param
Definition | update filter params supported
Control | Mandatory, 0..*
Type | string
Conformance.operation.schema
Definition | if supported
Control | Optional, 0..1
Type | boolean
Conformance.extensions
Definition | See Extensions
Control | Optional, 0..1
Conformance.text
Definition | Text summary of conformance profile for human interpretation
Control | Mandatory, 1..1
Type | Narrative


Traditional Messaging Framework - FHIR v0.01

Traditional Messaging Framework

This page describes how FHIR Resources can be used in a traditional messaging context, much like HL7 v2. Applications claiming conformance to this framework claim to be conformant to "FHIR messaging".

In FHIR messaging, a "request message" is sent from a source application to a destination application when an event happens. Events mostly correspond to things that happen in the real world. The request application consists of an aggregation of resources, with the first resource in the aggregation being a Message resource that identifies the nature of the request message and carries additional request metadata. The other resources in the aggregation depend on the request. The events supported in FHIR, along with the resources included in them, are defined below. The destination application processes the request, and returns one or more response messages which are also an aggregation of resources, with the first resource in the aggregation being a Message resource with a response section that reports the outcome of the transaction and any additional response resources required.

Basic Messaging Assumptions

This specification assumes that content will be delivered from one application to another by some delivery mechanism, and then a response will be returned to the source application. The exact mechanism of transfer is irrelevant to this specification, but may include file transfer, http based transfer, LLP (HL7 minimal lower layer protocol), MQ series messaging, or anything else. The only requirement for the transfer layer is that requests are sent to a known location, and responses are returned to the source of the request. This specification considers the source and destination applications as logical entites, and the mapping from logical source and destination to implementation specific addresses is outside the scope of this specification.

In principle, source applications are not required to wait for a response to a transaction before issuing a new transaction. However in some case, the transactions in a given stream are dependent on each other, and must be sent in order. In addition, some transfer options may require sequential delivery of messages.

This specification ignores the existence of interface engines and message transfer agents that lie between the source and destination. Either they are transparent to the message/transaction content, and irrelevant to this specification, or they are actively involved in manipulating the message content. If these middleware agents are modifying the message content, then they become responsible for honoring the contract described below in both directions.

Absence of Reliable Messaging

Some of the message delivery mechanisms mentioned above are reliable delivery systems - the message is always delivered, or an appropriate error is returned to the source. However in most implementations, reliable messaging cannot be assumed, and either the request or the response can get lost in transit. FHIR messaging describes a simple approach to handle this that applications must conform to, whether messaging appears to be reliable or not.

A message receiver must always check the incoming aggregation package ids, and check them against a store of previously received messages (going back a reasonable period in time). If it receives a duplicate message id that it has already responded to, it should assume that it's original response was lost, and resend the original response in a new aggregation package with Message.response.duplicate set to true. If the source application gets no response to it's request from the destination application, the source application should resend the same aggregation with the same aggregation package id.

Message Format

A message is just an aggregation built using the Atom feed format. The first resource of a message is a Message resource. This resource identifies the message event and links to the additional focal resource associated with the message, if any. The list of additional resources which must be included in a given message is provided below. Other resources that are identified in the message resource or included resources may either be left as references that are located/resolved outside the scope of the aggregation, or they may also be included in the aggregation.

Event List

Code | Description | Request | Response | Notes
admin-notify | Notification of a change to an administrative resource (either create or update). Note that there is no delete, though some administrative resources have status or period elements for this use | Person | -- |
 |  | Animal | -- |
 |  | Organization | -- |
 |  | Patient | -- | Patient Links cannot be updated using admin-notify. The links element must be empty
labreport-provide | Provide a lab report, or update a previously provided lab report | LabReport LabReport.patient LabReport.patient.person LabReport.patient.animal LabReport.admission LabReport.requestDetail.clinicalInfo LabReport.specimen LabReport.resultGroup.specimen | -- |
patient-link | Notification that two patient records actually identify the same patient | Patient,Patient | -- | Follow ups: patient-unlink?
patient-unlink | Notification that previous advice that two patient records concern the same patient is now considered incorrect | Patient,Patient | -- |

Conformance Statement

Applications claiming to be conformant to "FHIR messaging" may choose to publish a conformance statement that lists all the message events they support, either as sender or listener, and for each event, which resources are aggregated (sender), or are required to be aggregated (listener), and the conformance statements for the information content of the individual resources. The conformance statement is a resource with the name "MessageConformance".


Message - FHIR v0.01

Message

A message that contains FHIR resources.

The relative url is /messages

Content

<Message xmlns="http://www.hl7.org/fhir">
  <id> mand id Master Resource Id = Message Id</id>
  <threadId> opt id Id of thread of conversation</threadId>
  <instant> mand instant Instant the message was sent</instant>
  <event> mand code Code for the event his message represents</event>
  <response> opt  <!-- If this is a response -->
   <id> mand id Id of original message</id>
   <code> mand code Type of response to the message</code>
   <duplicate> mand boolean if this is not the first response</duplicate>
  </response>
  <source> mand (Device) Message Source Application</source>
  <destination> mand (Device) Message Destination Application</destination>
  <enterer> opt (Person|Device) The source of the data entry</enterer>
  <author> opt (Person|Device) The source of the decision</author>
  <responsible> opt (Person|Organization) final responsibility for event</responsible>
  <effective> opt Interval(dateTime) time of effect</effective>
  <reason> opt CodeableConcept Cause of event</reason>
  <data> cond (Any) The actual content of the message</data>
  <extensions> opt See Extensions   See Extensions </extensions>
  <text> mand Narrative Text summary of message, for human interpretation</text>
</Message>

Schema for Message and an example (or formatted for browser)

Terminology Bindings

  • Message.event is bound to the concept domain MessageEvent which has the allowed values defined for Event List in the messaging framework
  • Message.response.code is bound to the concept domain ResponseCode: "The kind of response to a message". Possible values:
    ok | The message was accepted and processed without error
    error | Some internal unexpected error occured - wait and try again. Note - this is usually used for things like database unavailable, which may be expected to resolve, though human intervention may be required
    rejection | The message was rejected because of some content in it. There is no point in re-sending without change. The response narrative must describe what the issue is
    rules | The message was rejected because of some event-specific business rules, and it may be possible to modify the request and re-submit (as a different request). The response data must clarify what the change would be, as described by the event definition
    undeliverable | A middleware agent was unable to deliver the message to it's supposed destination
  • Message.reason is bound to the concept domain EventReason: "The reason for an event occurring"

Notes:

  • The Message resource is a special case; it is only defined for the messaging framework, and is not encountered in other contexts
  • The Message resource is always found in an aggregation. The resource references source, destination, enterer, author, and responsible may all be included in the aggregation or left out on the basis that the recipient (and any intermediaries) are able to locate/resolve the resources independently. The former would be suitable for loosely coupled systems, and the latter for tightly coupled systems. The messaging conformance statement for an application must describe what aggregation occurs or is required here
  • The actual content of the data is specified per message event. The data resource is always aggregated

Formal Definitions

The formal definitions for the elements above. Also available as an XML file

Message
Definition | A message that contains FHIR resources
Control | Mandatory, 1..1
Requirements | Many implementations are not prepared to use REST, and need a message based infrastructure
Message.id
Definition | Unique Id for this message
Control | Mandatory, 1..1
Type | id
Must Understand | true
Requirements | Each message needs a unique identifier so other messages and underlying infrastructure can reference it
Comments | must be unique within a channel, but should be globally unique. UUIDs are recommended
Message.threadId
Definition | Id of the thread - a series of messages that pertain to the same logical sequence, and are all identified by the same thread identifier
Control | Optional, 0..1
Type | id
Message.instant
Definition | Instant the message was sent
Control | Mandatory, 1..1
Type | instant
Must Understand | true
Message.event
Definition | Code that identifies the event this message represents, and connects it with the event definition in the FHIR specification
Control | Mandatory, 1..1
Type | code from MessageEvent
Must Understand | true
Message.response
Definition | Information about the the message that this message is a response to - if it is a response
Control | Optional, 0..1
Must Understand | true
Message.response.id
Definition | The id of the message that this a response to
Control | Mandatory, 1..1
Type | id
Must Understand | true
Comments | this message must have the same threadId as the original message (including missing if the original message threadId was missing)
Message.response.code
Definition | Code that identifies the type of response to the message - whether it was successful or not, and whether it should be resent or not
Control | Mandatory, 1..1
Type | code from ResponseCode
Must Understand | true
Comments | This is a generic response to the request message. Specific data for the response will be found in Message.data
Message.response.duplicate
Definition | True if this is not the first response, because the request message has been received more than once
Control | Mandatory, 1..1
Type | boolean
Must Understand | true
Comments | The request shouldn't be received more than once if reliable message delivery applies, but mostly it doesn't
Message.source
Definition | The source application from which this message originated
Control | Mandatory, 1..1
Type | Resource(Device)
Message.destination
Definition | The destination application which the message is intended for
Control | Mandatory, 1..1
Type | Resource(Device)
Message.enterer
Definition | The person or device that performd the data entry leading to this message. Where there is more than one candidate, pick the most proximal to the message. Can provide other enterers in extensions
Control | Optional, 0..1
Type | Resource(Person|Device)
Requirements | Need to know for audit/traceback requirements
Comments | Usually only for the request, but can be used in a response
Message.author
Definition | The logical author of the message - the person or device that decided it should happen. Where there is more than one candidate, pick the most proximal to the message. Can provide other enterers in extensions
Control | Optional, 0..1
Type | Resource(Person|Device)
Requirements | Need to know for audit/traceback requirements
Comments | Usually only for the request, but can be used in a response
Message.responsible
Definition | The person or organization that accepts overall responsbility for the contents of the message. The implication is that the message event happened under the policies of the responsible party
Control | Optional, 0..1
Type | Resource(Person|Organization)
Requirements | Need to know for audit/traceback requirements
Comments | Usually only for the request, but can be used in a response
Message.effective
Definition | The effective time - the real world time of the even that the message represents. Usually this is just a starting time, but some message events also have an end time (do x for period y)
Control | Optional, 0..1
Type | Interval(dateTime)
Requirements | Need to know for understanding the content of the message
Comments | Usually only for the request, but can be used in a response
To Do | Grahame thinks this is not 80/20. Also, that it reall should be domain modeled, not tucked away here
Message.reason
Definition | The cause of the event - a reason for why this message is being sent
Control | Optional, 0..1
Type | CodeableConcept from EventReason
Requirements | Need to be able to track why resources are being changed and report in the audit log / history of the resource
RIM Mapping | ControlAct.reasonCode
Message.data
Definition | The actual data of the message - a reference to the focus class of the message.
Control | Conditional, 0..1: Mandatory unless the message is a response, in which case the element is optional
Type | Resource(Any)
Must Understand | true
Requirements | Every message event is about actual data, a single resource, that is identified in the definition of the event, and perhaps some or all linked resources
Comments | The data is defined where the transaction type is defined. The transaction data is always aggregated with the transaction resource
Message.extensions
Definition | See Extensions
Control | Optional, 0..1
Message.text
Definition |
Control | Mandatory, 1..1
Type | Narrative


MessageConformance - FHIR v0.01

MessageConformance

A conformance statement about how an application uses FHIR messaging.

The relative url is /messageconformances

Content

<MessageConformance xmlns="http://www.hl7.org/fhir">
  <id> mand id ConformanceStatement Id (UUID)</id>
  <date> mand dateTime Publication Date</date>
  <publisher> mand
   <name> mand string Publishing Organization</name>
   <address> opt Zero+ Address Address of Organization</address>
   <contact> opt Zero+ Contact Contacts for Organization</contact>
  </publisher>
  <software> mand
   <name> mand string Name software is known by</name>
   <version> mand string Version covered by this statement</version>
   <releaseDate> opt dateTime Date this version released</releaseDate>
  </software>
  <profile> opt Zero+ uri other profiles that apply (i.e. code binding rules)</profile>
  <event> mand  <!-- One+ -->
   <code> mand code Declare support for this event</code>
   <resource> cond code Which resource if event has multiple</resource>
   <mode> mand code Sender | Receiver</mode>
   <request> opt
    <resource> mand One+ Constraint Constraint on a resource used in request</resource>
   </request>
   <response> opt
    <resource> mand One+ Constraint Constraint on a resource used in response</resource>
   </response>
  </event>
  <extensions> opt See Extensions   See Extensions </extensions>
  <text> mand Narrative Text summary of conformance statement for human interpretation</text>
</MessageConformance>

Schema for MessageConformance and an example (or formatted for browser)

Terminology Bindings

  • MessageConformance.event.code is bound to the concept domain MessageEvent which has the allowed values defined for Event List in the messaging framework
  • MessageConformance.event.resource is bound to the concept domain ResourceType which has the allowed values of any defined Resource Type name
  • MessageConformance.event.mode is bound to the concept domain MessageConformanceEventMode: "The mode of a message conformance statement". Possible values:
    sender | The application sends requests and receives responses
    receiver | The application receives requests and sends responses

Notes:

  • The MessageConformance resource is a special case; it is only defined for the conformance framework, and is not encountered in other contexts
  • The interpretation of request and resource depends on the mode. If the mode is sender, then request specifies what the application sends, and response specifies what it accepts. If the mode is "listener", then this is reversed
  • If a request or response is not specified for an event, then no rules are made for it
  • Events that are not listed are not supported

Formal Definitions

The formal definitions for the elements above. Also available as an XML file

MessageConformance
Definition | A conformance statement about how an application uses FHIR messaging
Control | Mandatory, 1..1
MessageConformance.id
Definition | Globally unique Conformance Statement Id (Must be a UUID)
Control | Mandatory, 1..1
Type | id
MessageConformance.date
Definition | Date that the conformance statement is published
Control | Mandatory, 1..1
Type | dateTime
MessageConformance.publisher
Definition | The organization that publishes this conformance statement
Control | Mandatory, 1..1
MessageConformance.publisher.name
Definition | Name of Organization
Control | Mandatory, 1..1
Type | string
MessageConformance.publisher.address
Definition | Address of Organization
Control | Optional, 0..*
Type | Address
MessageConformance.publisher.contact
Definition | Contacts for Organization
Control | Optional, 0..*
Type | Contact
MessageConformance.software
Definition | The software that is covered by this conformance statement
Control | Mandatory, 1..1
MessageConformance.software.name
Definition | Name software is known by
Control | Mandatory, 1..1
Type | string
MessageConformance.software.version
Definition | Version covered by this statement
Control | Mandatory, 1..1
Type | string
MessageConformance.software.releaseDate
Definition | Date this version released
Control | Optional, 0..1
Type | dateTime
MessageConformance.profile
Definition | Additional other profiles that apply to this conformance statement.
Control | Optional, 0..*
Type | uri
Comments | Generally these profiles make constraints on the bindings of concept domains / value sets
MessageConformance.event
Definition | An event supported by the application
Control | Mandatory, 1..*
MessageConformance.event.code
Definition | The code for the event
Control | Mandatory, 1..1
Type | code from MessageEvent
MessageConformance.event.resource
Definition | The focal resource for the event
Control | Conditional, 0..1: A resource type is required if the event declaration has multiple focal resources
Type | code from ResourceType
MessageConformance.event.mode
Definition | The mode of this event declaration - whether application is sender or receiver
Control | Mandatory, 1..1
Type | code from MessageConformanceEventMode
MessageConformance.event.request
Definition | Information about the request for this event
Control | Optional, 0..1
MessageConformance.event.request.resource
Definition | Constraint on a resource used in the event request
Control | Mandatory, 1..*
Type | Constraint
MessageConformance.event.response
Definition | Information about the response for this event
Control | Optional, 0..1
MessageConformance.event.response.resource
Definition | Constraint on a resource used in the event response
Control | Mandatory, 1..*
Type | Constraint
MessageConformance.extensions
Definition | See Extensions
Control | Optional, 0..1
MessageConformance.text
Definition |
Control | Mandatory, 1..1
Type | Narrative


Document Framework - FHIR v0.01

Document Framework

This page describes how FHIR Resources can be used to build clinical documents, like CDA. Applications claiming conformance to this framework claim to be conformant to "FHIR documents".

Documents are a collections of resources that a fixed in scope and frozen in time, and authored and/or attested by a collection or humans, orgnisations and devices, and gathered together into a single aggregation using an atom feed. Documents built in this fashion may be exchanged between systems, and also persisted in document storage and management systems, including systems such as IHE XDS.

Document Format

All documents have the same structure: an aggregation that has Document Resource first, followed by a series of other resources referenced from the Document resource.

The document resource identifies the document and it's purpose, sets the context of the document, and carries key information such as the subject and author, and divides the document up into sections that each contain a content resource, which is some other resource identified in this specification. Any resource referenced directly in the Document resource must be included in the aggregation when the document is assembled; other resources that these documents refer to may also be aggregated if the document originator chooses to.

Document profiles and/or application conformance statements can make additional rules about which resources must be aggregated along with the resources that are directly referenced in the Document resource. In addition, Document Profiles and conformance statements can specify what sections a document contains, and what the constraints on their content resource are.

Handling Documents

Since documents are attested at a fixed point in time with known contents, any handling of documents must ensure that the content has not changed at all. Applications are allowed to extract content from the document and use it in other contexts, but it is no longer part of the document. When storing documents, applications may store the entire document as a single byte stream, which would ensure that it can be reproduced exactly, or they can disassemble the document into component resources (or another disassembly strategy), as long as the original document can be assembled in it's original form if the original document is required. Applications are not mandated to store all documents, though most actual usages will require the document to persist.

Documents and the RESTful Framework

The standard RESTful framework, there is an manager for the Document resource which uses the standard HTTP Transactions applied to Document resources. In this fashion, a RESTful framework can be used to build a logical description of a document by updating the appropriate resources. Note that although this can form a logically complete description of the document a full document only exists once the resources that are part of the document are built into a single aggregation.

Note that the standard /document end point defined with the Document resource handles individual Document resources, not full documents that are aggregations. Using this resource directly is mostly confined to the process of constructing a document using the RESTful framework. The RESTful end point for full aggregated documents is /aggregations

Applications that handle and process documents are not required to make the individual constituent resources that are part of a document available through the their resource specific URL, though they may choose to do so.

Issues: images & attachments

Document Profile / Conformance Statement

Applications claiming to be conformant to "FHIR documents" may choose to publish a conformance statement that lists all the document types they support, and for each type, what the document and section content is, and which resources are aggregated (originator), or are required to be aggregated (recipient), along with constraint statements for the information content of the individual resources. The conformance statement is a resource with the name "DocumentConformance".

The same structure can be used to declare a document profile. Such profiles may be defined and published by HL7, other standards organisations, institutions, and projects.


DocumentConformance - FHIR v0.01

DocumentConformance

A conformance statement about how one or more FHIR documents.

The relative url is /documentconformances

Content

<DocumentConformance xmlns="http://www.hl7.org/fhir">
  <id> mand id ConformanceStatement Id (UUID)</id>
  <date> mand dateTime Publication Date</date>
  <publisher> mand
   <name> mand string Publishing Organization</name>
   <address> opt Zero+ Address Address of Organization</address>
   <contact> opt Zero+ Contact Contacts for Organization</contact>
  </publisher>
  <software> opt  <!-- If this is for an application -->
   <name> mand string Name software is known by</name>
   <version> mand string Version covered by this statement</version>
   <releaseDate> opt dateTime Date this version released</releaseDate>
  </software>
  <profile> opt Zero+ uri other profiles that apply (i.e. code binding rules)</profile>
  <document> mand  <!-- One+ document definition -->
   <name> mand string Name for this particular document profile</name>
   <purpose> opt string Human description of this particular profile</purpose>
   <resource> mand One+ Constraint Constraint on a resource used in the document</resource>
  </document>
  <extensions> opt See Extensions   See Extensions </extensions>
  <text> mand Narrative Text summary of conformance profile for human interpretation</text>
</DocumentConformance>

Schema for DocumentConformance and an example (or formatted for browser)

Notes:

  • Document profile names are not used elsewhere in this specification - they are for human consumption
  • For each document profile, multiple resources will need to be profiled. The document resource must always come first
  • Ideally, the criteria in different document profile should be able to distinguish between multiple document profiles, so that there is no ambiguity concerning which profile any given document conforms to. However this is not always possible

Formal Definitions

The formal definitions for the elements above. Also available as an XML file

DocumentConformance
Definition | A conformance statement about how one or more FHIR documents
Control | Mandatory, 1..1
DocumentConformance.id
Definition | Globally unique Conformance Statement Id (Must be a UUID)
Control | Mandatory, 1..1
Type | id
DocumentConformance.date
Definition | Date that this conformance statement is published
Control | Mandatory, 1..1
Type | dateTime
DocumentConformance.publisher
Definition | The organization that publishes this conformance statement
Control | Mandatory, 1..1
DocumentConformance.publisher.name
Definition | Name of Organization
Control | Mandatory, 1..1
Type | string
DocumentConformance.publisher.address
Definition | Address of Organization
Control | Optional, 0..*
Type | Address
DocumentConformance.publisher.contact
Definition | Contacts for Organization
Control | Optional, 0..*
Type | Contact
DocumentConformance.software
Definition | The software that is covered by this conformance statement
Control | Optional, 0..1
DocumentConformance.software.name
Definition | Name software is known by
Control | Mandatory, 1..1
Type | string
DocumentConformance.software.version
Definition | Version covered by this statement
Control | Mandatory, 1..1
Type | string
DocumentConformance.software.releaseDate
Definition | Date this version released
Control | Optional, 0..1
Type | dateTime
DocumentConformance.profile
Definition | Additional other profiles that apply to this conformance statement.
Control | Optional, 0..*
Type | uri
Comments | Generally these profiles make constraints on the bindings of concept domains / value sets
DocumentConformance.document
Definition | A document definition
Control | Mandatory, 1..*
DocumentConformance.document.name
Definition | Name for this particular document profile
Control | Mandatory, 1..1
Type | string
DocumentConformance.document.purpose
Definition | Human description of this particular profile
Control | Optional, 0..1
Type | string
DocumentConformance.document.resource
Definition | Constraint on a resource used in the document
Control | Mandatory, 1..*
Type | Constraint
Comments | The first resource is the document resource
DocumentConformance.extensions
Definition | See Extensions
Control | Optional, 0..1
DocumentConformance.text
Definition | Text summary of conformance profile for human interpretation
Control | Mandatory, 1..1
Type | Narrative


Using FHIR Resources with hData - FHIR v0.01

Using FHIR Resources with hData

To do.

content profile for hData for each resource template for a content profile - available @ hdata wiki page on hl7 wiki (ArB is going to review that) schema + rddl (see rddl.org) set link rel in atom feed on per type


Profile - FHIR v0.01

Profile

A Resource Profile - a statement of constraint on one or more Resources and/or Concept Domains.

The relative url is /profiles

Content

<Profile xmlns="http://www.hl7.org/fhir">
  <id> mand id fixed identifier for this profile (UUID)</id>
  <name> mand string Informal name for this profile</name>
  <author> mand  <!-- (Organisation or individual) -->
   <name> mand string Name of the recognised author</name>
   <reference> opt Zero+ uri Web reference to the author</reference>
  </author>
  <intention> opt string Why this profile was written</intention>
  <code> opt Zero+ Coding assist with indexing and finding</code>
  <description> mand string natural language description of the Template</description>
  <evidence> opt Zero+ uri Supporting evidence for the design</evidence>
  <comments> opt string Guidance for use, usage notes, etc</comments>
  <status> mand code draft | testing | production | withdrawn | superceded</status>
  <date> mand dateTime date for given status</date>
  <endorser> opt  <!-- Zero+ (Organisation or individual) -->
   <name> mand string Name of the recognised endorser</name>
   <reference> opt uri Web reference to the endorser</reference>
  </endorser>
  <changes> cond string notes about changes since last version</changes>
  <supercedes> opt Zero+ uri references to previous versions</supercedes>
  <profile> opt Zero+ uri other profiles that apply (i.e. code binding rules)</profile>
  <resource> mand Zero+ Constraint Resource Type with constraints</resource>
  <binding> mand  <!-- Zero+ -->
   <name> mand string concept domain name</name>
   <type> mand code binding type</type>
   <details> cond string extra details - see notes</details>
   <reference> cond uri source of binding content</reference>
   <code> cond Zero+ Coding enumerated codes that are the binding</code>
  </binding>
  <extensions> opt See Extensions   See Extensions </extensions>
  <text> mand Narrative Text summary of resource profile for human interpretation</text>
</Profile>

Schema for Profile and an example (or formatted for browser)

Terminology Bindings

  • Profile.status is bound to the concept domain ResourceProfileStatus: "The lifecycle status of a Resource Profile". Possible values:
    draft | This profile is still under development
    testing | this profile was authored for testing purposes (or education/evaluation/evangelisation)
    production | This profile is ready for use in production systems
    withdrawn | This profile has been withdrawn
    superceded | This profile was superceded by a more recent version
  • Profile.binding.type is bound to the concept domain ConceptBindingType: "The type of a binding for a concept domain". Possible values:
    Unbound | The concept domain is not bound to anything
    CodeList | The concept domain is bound to a list of supplied codes - only those codes are allowed
    Reference | The concept domain references some external definition by a provided reference
    Preferred | The concept domain references a set of preferred terms
    Suggestion | This profile was superceded by a more recent version
    External | The concept domain is defined by an external authority identified in the reference

Notes:

  • The name of the profile is not required to be globally unique, but the name should have some scoping information (i.e. Acme Inc (USA), Allergy List)
  • Multiple codes may be assigned to the profile. These may either describe the template, or the focus of the template, or both. They are solely to help find the profile by searching for structured concepts
  • If other profiles are referenced, then any constraints in those profiles also apply to this profile. If a resource or binding is found in this profile, the constraints described must include all the constraints found in the referenced profiles, so that it is not necessary to search the referenced profiles and merge the constraints. The primary use of referencing other profiles is to re-use concept binding constraints

Searching Criteria

The following simple search/filter parameters are defined for Resource Profiles:

name | a portion of the name of the resource
author | name or id of the author
code | a code in the format uri::code
status | a status of the profile
type | type of resource that is constrained in the profile
domain | concept domain that is constrained in the resource

The standard search parameters also apply (see Searching).

Formal Definitions

The formal definitions for the elements above. Also available as an XML file

Profile
Definition | A Resource Profile - a statement of constraint on one or more Resources and/or Concept Domains
Control | Mandatory, 1..1
Comments | Often called a clinical template
Profile.id
Definition | Globally unique Profile Id (Must be a UUID)
Control | Mandatory, 1..1
Type | id
Must Understand | true
Profile.name
Definition | A free text natural language name identifying the Template.
Control | Mandatory, 1..1
Type | string
Comments | Not expected to be unique
Profile.author
Definition | Details of the author who accepts responsibility for publishing the profile
Control | Mandatory, 1..1
Comments | Usually an organisation, but may be an individual
Profile.author.name
Definition | The name of the author
Control | Mandatory, 1..1
Type | string
Profile.author.reference
Definition | Reference to the author to assist a user in finding and communicating with the author
Control | Optional, 0..*
Type | uri
Comments | may be a web site, an email address, a telephone number
Profile.intention
Definition | A free text natural language description of the intent and scope of the Template. The purpose is to provide the author’s initial intent for the Template in the language specified below.
Control | Optional, 0..1
Type | string
Profile.code
Definition | A set of terms from a controlled reference terminology that may be used to assist with indexing and searching of templates
Control | Optional, 0..*
Type | Coding
Profile.description
Definition | A free text natural language description of the Template. Generally, this field should be used for things such as goals, variable lists, instructions for clinical use and interpretation, literature, examples from paper world, mapping from natural language to HL7 and the model itself, etc
Control | Mandatory, 1..1
Type | string
Profile.evidence
Definition | A description, reference or link to a published medical knowledge that was used in the definition of this Template
Control | Optional, 0..*
Type | uri
Profile.comments
Definition | A statement regarding when this Template should not be used, or may be used erroneously. To define roles where the Template should not be used, or should be used with care. This field is used to expand in detail on the iIntention
Control | Optional, 0..1
Type | string
Profile.status
Definition | draft | testing | production | withdrawn | superceded
Control | Mandatory, 1..1
Type | code from ResourceProfileStatus
Must Understand | true
Profile.date
Definition | The date that the current value for publicationStatus was applied to the Template
Control | Mandatory, 1..1
Type | dateTime
Profile.endorser
Definition | A list of bodies who have reviewed the Template for clinical accuracy and relevance, and endorsed it for use.
Control | Optional, 0..*
Profile.endorser.name
Definition | The name of the endorsing body
Control | Mandatory, 1..1
Type | string
Profile.endorser.reference
Definition | Reference to the author to assist a user in finding and communicating with the endorsing body
Control | Optional, 0..1
Type | uri
Profile.changes
Definition | A free text description describing the changes in this version of the profile as compared to the previous version.
Control | Conditional, 0..1: This field must be populated if the template is not the first version.
Type | string
Profile.supercedes
Definition | A template that is supercded by this template (maybe a previous version)
Control | Optional, 0..*
Type | uri
Profile.profile
Definition | Additional other profiles that apply to this conformance statement.
Control | Optional, 0..*
Type | uri
Comments | Generally these profiles make constraints on the bindings of concept domains / value sets
Profile.resource
Definition | Resource Type with constraints
Control | Mandatory, 0..*
Type | Constraint
Profile.binding
Control | Mandatory, 0..*
Profile.binding.name
Definition | The name of the concept domain that this profile is declaring a constraint on
Control | Mandatory, 1..1
Type | string
Profile.binding.type
Definition | The form of the binding
Control | Mandatory, 1..1
Type | code from ConceptBindingType
Profile.binding.details
Definition | extra details - see notes
Control | Conditional, 0..1: May be required depending on the value of binding.type
Type | string
Profile.binding.reference
Definition | source of binding content
Control | Conditional, 0..1: May be required depending on the value of binding.type
Type | uri
Profile.binding.code
Definition | enumerated codes that are the binding
Control | Conditional, 0..*: May be required depending on the value of binding.type
Type | Coding
Profile.extensions
Definition | See Extensions
Control | Optional, 0..1
Profile.text
Definition | Text summary of resource profile for human interpretation
Control | Mandatory, 1..1
Type | Narrative


Person - FHIR v0.01

Person

A person who is involved in the healthcare process.

The relative url is /people

Content

<Person xmlns="http://www.hl7.org/fhir">
  <id> mand id Master Resource Id, always first in all resources</id>
  <identifier> Zero+ HumanId A Human identifier for this person</identifier>
  <name> Zero+ HumanName A name associated with the person</name>
  <address> Zero+ Address An address for the person</address>
  <contact> Zero+ Contact A contact detail for the person</contact>
  <dob> opt dateTime The birth date for the person</dob>
  <gender> opt CodeableConcept Administrative Gender</gender>
  <religion> opt CodeableConcept Religion of the person</religion>
  <race> opt Zero+ CodeableConcept The race of a person</race>
  <qualification>  <!-- Zero+ Qualifications, Accreditations, Certifications -->
   <id> opt Identifier Identifier for the qualification</id>
   <code> opt CodeableConcept A code for the qualification</code>
   <institution> opt (Organization) Who conferred it</institution>
   <period> opt Interval(date) When the qualification is valid</period>
  </qualification>
  <language>  <!-- Zero+ -->
   <code> mand code ISO 639-3 code for language</code>
   <use> opt code How well the language is used</use>
  </language>
  <relatedPerson>  <!-- Zero+ Kin, Guardians, Agents, Caregivers -->
   <id> opt HumanId Identifier for the person</id>
   <role> mand CodeableConcept Type of relationship</role>
   <name> opt HumanName Name of the person</name>
   <contact> Zero+ Contact Contact details for the person</contact>
  </relatedPerson>
  <extensions> opt See Extensions   See Extensions </extensions>
  <text> mand Narrative Text summary of person, for human interpretation</text>
</Person>

Schema for Person and an example (or formatted for browser)

Terminology Bindings

  • Person.gender is bound to the concept domain AdministrativeGender: "The gender of a person used for administrative purposes"
  • Person.religion is bound to the concept domain Religion: "The denomination to which a person professes affiliation"
  • Person.race is bound to the concept domain Race: "The race of the person". If an appropriate code exists in HL7 v2 table 0200 then it should be used
  • Person.qualification.code is bound to the concept domain Qualifications: "Formal qualifications, accreditations, and Certifications acquired by a person"
  • Person.language.code is bound to the concept domain Language: "A human language". The possible values are those specified in ISO 639-3
  • Person.language.use is bound to the concept domain LanguageUse: "How well a person speaks a language". Possible values:
    none | The person does not speak the language at all
    poor | The person has minimal functional capability in the language
    useable | The person can use the language, but may not be full conversant, particularly with regards to health concepts
    fluent | The person is fully capable of using the language
  • Person.relatedPerson.role is bound to the concept domain PersonRelationship: "The relationship a person has to the subject, including familial, marital, financial, legal, and casual relationships"

Notes:

  • There are various types of people of interest - patients, employees, etc. Different types of people might come from different service end points.
  • The administrative gender of the patient is that one that matters for the record. This may match the gendor of birth or the current socially-reported gender.
  • Qualifications covers both formal education gained in the past, and ongoing certification and accreditation often associated with healthcare providers.
  • Various jurisdictions define their own qualification and/or codes, and some care about this more than others.
  • The organization references are all optional, so can be replaced by simple text rather than a full resource reference
  • A related person can be either reference to another resource using the id, or can provide what is known about the person directly

Searching Criteria

The following simple search/filter parameters are defined for person:

name | a portion of name in any name part
phonetic | a portion of name using some kind of phonetic matching algorithm
id | search id in any identifiers
contact | the value in any kind of contact
address | an address in any kind of address/part
gender | gender of the person

The standard search parameters also apply (see Searching).

Formal Definitions

The formal definitions for the elements above. Also available as an XML file

Person
Definition | A person who is involved in the healthcare process
Control | Mandatory, 1..1
Requirements | Need to track persons across multiple roles
RIM Mapping | Person(classCode=PSN, determinerCode=INST)
Person.id
Definition | Master Resource Id, always first in all resources
Control | Mandatory, 1..1
Type | id
RIM Mapping | .id(scope=OBJ)
Person.identifier
Definition | Identifier for the person that is used to identify the person across multiple disparate systems and also for face to face identification of the person
Control | 0..*
Type | HumanId
Must Understand | true
Requirements | People are known by a variety of ids. Some institutions maintain several, and most collect identifiers for exchange with other organizations concerning the patient.
RIM Mapping | .plays:Role(classCode='IDENT').id
v2 Mapping | PID-3
Person.name
Definition | A name associated with the person
Control | 0..*
Type | HumanName
Must Understand | true
Requirements | Need to be able to track the person by multiple names
Comments | Person may have multiple names with different uses or applicable periods
RIM Mapping | .name
v2 Mapping | PID-5, PID-9
Person.address
Definition | An address for the person
Control | 0..*
Type | Address
Requirements | May need to keep track of persons addresses for contacting, billing or reporting requirements and also to help with identification
Comments | Person may have multiple addresses with different uses or applicable periods
RIM Mapping | .addr
v2 Mapping | PID-11
Person.contact
Definition | A contact detail for the person
Control | 0..*
Type | Contact
Requirements | May need to have options for contacting the person urgently, and also to help with identification
Comments | Person may have multiple contacts with different uses or applicable periods
RIM Mapping | .telecom
v2 Mapping | PID-13, PID-14
Person.dob
Definition | The birth date for the person
Control | Optional, 0..1
Type | dateTime
Must Understand | true
Requirements | Age of person drives many clinical processes.
Comments | At least a estimated year should be provided as a guess if the real dob is unknown
RIM Mapping | .birthTime
Person.gender
Definition | Administrative Gender
Control | Optional, 0..1
Type | CodeableConcept from AdministrativeGender
Must Understand | true
Requirements | Patient Identification, and also for managing the patient
RIM Mapping | .administrativeGender
Person.religion
Definition | The religious denomination to which a person professes affiliation
Control | Optional, 0..1
Type | CodeableConcept from Religion
Requirements | The religion of a person may influence ancilliary processes around the provision of healthcare, and may provide general advice with regard to diet, etc
Comments | Not all people have a formal religious affiliation
RIM Mapping | .religiousAffiliationCode
Person.race
Definition | blah balh
Control | Optional, 0..*
Type | CodeableConcept from Race
Requirements | This is added because many jurisdictions insisted on it
Comments | Some places do not use this!
RIM Mapping | .raceCode
Person.qualification
Definition | The qualifications a person has, including formal educational achievements, accreditations, and current certifications. All these qualifications may be used to determine what roles a person may play in a healthcare environment
Control | 0..*
Requirements | For many persons in healthcare, it is necessary to track the qualifications a person has - formal.
RIM Mapping | .plays:Role(classCode='QUAL')
Person.qualification.id
Definition | The identifier of a qualification
Control | Optional, 0..1
Type | Identifier
Requirements | Allows a link back to a qualification registry, if one exists
RIM Mapping | .identifier
Person.qualification.code
Definition | The type of the qualification
Control | Optional, 0..1
Type | CodeableConcept from Qualifications
Requirements | commonly used to determine the roles a person may play
RIM Mapping | .code
Person.qualification.institution
Definition | The organisation that confered/confers the qualification
Control | Optional, 0..1
Type | Resource(Organization)
Requirements | May determine the significance of the qualification, and allows a link back to a qualification registry, if one exists
RIM Mapping | .scopedBy:Organization
Person.qualification.period
Definition | The period for which a qualification is held
Control | Optional, 0..1
Type | Interval(date)
Requirements | Some qualifications are only conferred for a limited time period and must be re-acquired or forfeited
Comments | Formal degrees may have a known start date, but no end date
RIM Mapping | .effectiveTime:IVL_TS
Person.language
Definition | A language spoken by the person, with proficiency
Control | 0..*
Requirements | If a patient does not speak the local language, interpreters may be required, so languages spoken and profiency is an important things to keep track of both for patient and other persons of interest
Comments | If no language is specified, this *implies* that the default local language is spoken
RIM Mapping | .LanguageCommunicationCode
Person.language.code
Definition | A code that identifies the language
Control | Mandatory, 1..1
Type | code from Language
Comments | So just ISO 639-3? Not allowing ENG-CA or something?
RIM Mapping | .languageCode
Person.language.use
Definition | A code the describes how well the language is spoken
Control | Optional, 0..1
Type | code from LanguageUse
Comments | No differentiation is made between spoken and written functionality here
RIM Mapping | .proficiencyLanguageCode
Person.relatedPerson
Definition | Other persons who are related to this person. The relationship might be one of several types: kin (familial or marital), financial or legal (such as guardian), biological (e.g. donor, donation-recipient) or casual (i.e. friend).
Control | 0..*
Requirements | Need to be able to track next of kin, or other people who may need to contacted/consulting regarding the patient's healthcare status or who might otherwise influence their treatment
RIM Mapping | .plays:Role(classCode='REL')
Person.relatedPerson.id
Definition | Identifier the related person - may be a full link to a Person resource, or some other kind of identifier
Control | Optional, 0..1
Type | HumanId
Requirements | may have an identifier for the person that can be used to source contact details
RIM Mapping | .scopedBy:Person.identifier
Person.relatedPerson.role
Definition | Code that specifies how this person is related to the subject. A code is required.
Control | Mandatory, 1..1
Type | CodeableConcept from PersonRelationship
Requirements | Need to know how the person is related
RIM Mapping | .code
Person.relatedPerson.name
Definition | A name should be specified for the related person
Control | Optional, 0..1
Type | HumanName
RIM Mapping | .scopedBy:Person.name
Person.relatedPerson.contact
Definition | Contact details (phone, email etc) should be provided for the person
Control | 0..*
Type | Contact
RIM Mapping | .scopedBy:Person.telecom
Person.extensions
Definition | See Extensions
Control | Optional, 0..1
Person.text
Definition | Text summary of person, for human interpretation
Control | Mandatory, 1..1
Type | Narrative


Animal - FHIR v0.01

Animal

An animal that has relevance to the care process -usually this is for animals that are patients..

The relative url is /animals

Content

<Animal xmlns="http://www.hl7.org/fhir">
  <id> mand id Master Resource Id, always first in all resources</id>
  <identifier> Zero+ HumanId Human identifiers for this animal</identifier>
  <name> Zero+ HumanName A name associated with the animal</name>
  <dob> opt dateTime The birth date for the animal</dob>
  <species> opt CodeableConcept Species for the Animal</species>
  <strain> opt CodeableConcept Strain for the Animal</strain>
  <gender> opt CodeableConcept Gender for the Animal</gender>
  <relatedEntity>  <!-- Zero+ Kin, owner, care giver etc -->
   <id> opt HumanId Identifier for the entity</id>
   <role> mand CodeableConcept Type of relationship</role>
   <name> opt HumanName Name of the related entity</name>
   <address> Zero+ Address An address (usually human, but may be kin)</address>
   <contact> Zero+ Contact Contact details (usually for humans)</contact>
  </relatedEntity>
  <extensions> opt See Extensions   See Extensions </extensions>
  <text> mand Narrative Text summary of animal, fall back for human interpretation</text>
</Animal>

Schema for Animal and an example (or formatted for browser)

Terminology Bindings

  • Animal.species is bound to the concept domain AnimalSpecies: "The species of an animal"
  • Animal.strain is bound to the concept domain AnimalStrain: "The strain of an animal"
  • Animal.gender is bound to the concept domain AnimalGender: "The gender of an animal"
  • Animal.relatedEntity.role is bound to the concept domain AnimalRelationship: "The relationship of an animal to another entity (person, corporation, or other animal)"

Notes:

  • Animals are assigned human names, since humans tend to assign names using human patterns.
  • Related entities include owners, and care givers, as well as the kin of the animal should that be relevant.
  • The organization references are all optional, so can be replaced by simple text rather than a full resource reference
  • The organization references are all optional, so can be replaced by simple text rather than a full resource reference
  • A related entity can be either reference to another resource using the id, or can provide what is known about the entity directly

Searching Criteria

The following simple search/filter parameters are defined for person:

name | a portion of name in any name part
species | the species, including by subsumption if the coding supports this
phonetic | a portion of name using some kind of phonetic matching algorithm
id | search id in any identifiers

The standard search parameters also apply (see Searching).

Formal Definitions

The formal definitions for the elements above. Also available as an XML file

Animal
Definition | An animal that has relevance to the care process -usually this is for animals that are patients.
Control | Mandatory, 1..1
Requirements | Need to be able to track animals - vetinary medicine is an active user of HL7 standards
Comments | Animals differ because you need to track species and strain, and also different kind of relationships - owners
RIM Mapping | NonPersonLivingSubject(classCode=ANM, determinerCode=INST)
Animal.id
Definition | Master Resource Id, always first in all resources
Control | Mandatory, 1..1
Type | id
To Do | .id(scope=OBJ)
Animal.identifier
Definition | Identifier for the animal that is used to identify the person across multiple disparate systems and also for face to face identification of the person
Control | 0..*
Type | HumanId
Must Understand | true
Requirements | Animals are known by a variety of ids. Some institutions maintain several, and most collect identifiers for exchange with other organizations concerning the animal
RIM Mapping | .scopes[Role](classCode=IDENT)
Animal.name
Definition | A name associated with the animal. The use code maiden does not apply.
Control | 0..*
Type | HumanName
Must Understand | true
Requirements | Some animals have names, which are assigned by humans for human reasons, and follow human naming patterns
RIM Mapping | .name
Animal.dob
Definition | The birth date for the animal
Control | Optional, 0..1
Type | dateTime
Must Understand | true
Requirements | Age of the animal drives many clinical processes.
RIM Mapping | .dateOfBirth
To Do | RIM change to support human date (time only - but is this needed in this context?)
Animal.species
Definition | Species for the animal
Control | Optional, 0..1
Type | CodeableConcept from AnimalSpecies
Must Understand | true
Requirements | Need to know what kind of animal
RIM Mapping | .code
Animal.strain
Definition | Strain for the animal
Control | Optional, 0..1
Type | CodeableConcept from AnimalStrain
Must Understand | true
Requirements | May need to know the specific kind within the species
RIM Mapping | .strainText
To Do | Not sure why this is ED in the RIM. Should probably change to SC.
Animal.gender
Definition | Gender for the Animal
Control | Optional, 0..1
Type | CodeableConcept from AnimalGender
Must Understand | true
Requirements | For managing the animal
Comments | Note that some animals have additional gender not encountered in humans?
RIM Mapping | .administrativeGenderCode
Animal.relatedEntity
Definition | Kin, owner, care giver etc
Control | 0..*
Animal.relatedEntity.id
Definition | Identifier for the entity
Control | Optional, 0..1
Type | HumanId
Animal.relatedEntity.role
Definition | Type of relationship
Control | Mandatory, 1..1
Type | CodeableConcept from AnimalRelationship
Animal.relatedEntity.name
Definition | Name of the related entity
Control | Optional, 0..1
Type | HumanName
Animal.relatedEntity.address
Definition | An address (usually human, but may be kin)
Control | 0..*
Type | Address
Animal.relatedEntity.contact
Definition | Contact details (usually for humans)
Control | 0..*
Type | Contact
Animal.extensions
Definition | See Extensions
Control | Optional, 0..1
RIM Mapping | [varies]
Animal.text
Definition |
Control | Mandatory, 1..1
Type | Narrative
To Do | .text


Organization - FHIR v0.01

Organization

For any organization/institution/government department that has relevance to the care process.

The relative url is /organizations

Content

<Organization xmlns="http://www.hl7.org/fhir">
  <id> mand id Master Resource Id, always first in all resources</id>
  <identifier> Zero+ HumanId Identifier for this organization</identifier>
  <name>  <!-- Zero+ -->
   <value> mand string A name associated with the organization</value>
   <period> opt Interval(date) When this name is/was in use</period>
  </name>
  <address> Zero+ Address An address for the organization</address>
  <contact> Zero+ Contact A contact detail for the organization</contact>
  <code> opt CodeableConcept kind of organisation</code>
  <industryCode> opt CodeableConcept kind of industry</industryCode>
  <accreditation>  <!-- Zero+ -->
   <id> opt Identifier Identifier for the accreditation</id>
   <code> opt CodeableConcept What kind of accreditation</code>
   <institution> opt (Organization) Who conferred it</institution>
   <period> opt Interval(date) When the accreditation is valid</period>
  </accreditation>
  <relatedOrganization>  <!-- Zero+ sub-, super-, and partner organisations -->
   <id> opt HumanId Identifier for the organization</id>
   <code> mand CodeableConcept How the organizations are related</code>
   <name> opt string Name of the organization</name>
   <address> Zero+ Address An address for the organization</address>
   <contact> Zero+ Contact General contact details for the organization</contact>
   <period> opt Interval(date) When the organizations were related</period>
  </relatedOrganization>
  <extensions> opt See Extensions   See Extensions </extensions>
  <text> Narrative Text summary of organization, fall back for human interpretation</text>
</Organization>

Schema for Organization and an example (or formatted for browser)

Terminology Bindings

  • Organization.code is bound to the concept domain OrganisationType: "The type of an organisation". A good candidate for codes is SNOMED-CT, and the HL7 v3 Entity Code table
  • Organization.industryCode is bound to the concept domain Industry: "Code for the type of industry". For example values, see HL7 v3 OrganizationIndustryClass value set
  • Organization.accreditation.code is bound to the concept domain Accreditation: "Accreditations an organization may be granted"
  • Organization.relatedOrganization.code is bound to the concept domain OrganizationRelationship: "The relationship an organization has to the subject, including sub and super organizations, and other kind of relationships such as partner organisations"

Notes:

  • The organization references are all optional, so can be replaced by simple text rather than a full resource reference

Searching Criteria

The following simple search/filter parameters are defined for organization:

name | a portion of name in any name part
phonetic | a portion of name using some kind of phonetic matching algorithm
id | search id in any identifiers

The standard search parameters also apply (see Searching).

Formal Definitions

The formal definitions for the elements above. Also available as an XML file

Organization
Definition | For any organization/institution/government department that has relevance to the care process
Control | Mandatory, 1..1
RIM Mapping | Organization(classCode=ORG, determinerCode=INST)
Organization.id
Definition | Master Resource Id, always first in all resources
Control | Mandatory, 1..1
Type | id
RIM Mapping | .id(scope=OBJ)
Organization.identifier
Definition | Identifier for the organization that is used to identify the organization across multiple disparate systems
Control | 0..*
Type | HumanId
Must Understand | true
Requirements | Organizations are known by a variety of ids. Some institutions maintain several, and most collect identifiers for exchange with other organizations concerning the organization.
RIM Mapping | .scopes[Role](classCode=IDENT)
Organization.name
Definition | A name associated with the organization
Control | 0..*
Must Understand | true
Requirements | Need to use the name as the label of the organization
Comments | Don't use HumanName since that has many non-organization things in it
RIM Mapping | .name
Organization.name.value
Definition | The actual name of the organization
Control | Mandatory, 1..1
Type | string
Must Understand | true
RIM Mapping | .part[1](type=NULL,qualifier=NULL).value
Organization.name.period
Definition | The period that this name was in use by the organization
Control | Optional, 0..1
Type | Interval(date)
Requirements | Organizations have a habit of renaming themselves, and the current and past names are required
RIM Mapping | .validTime
To Do | This is 80%??
Organization.address
Definition | An address for the organization
Control | 0..*
Type | Address
Requirements | May need to keep track of the organizations addresses for contacting, billing or reporting requirements
Comments | Organization may have multiple addresses with different uses or applicable periods. The use code home is not to be used
RIM Mapping | .address
Organization.contact
Definition | A contact detail for the organization
Control | 0..*
Type | Contact
Requirements | Human contact for the organization
Comments | The use code home is not to be used. Note that these contacts are not the contact details of people who are employed by or represent the organization, but official contacts for the organization itself
RIM Mapping | .telecom
Organization.code
Definition | The kind of organization that this is
Control | Optional, 0..1
Type | CodeableConcept from OrganisationType
Requirements | Need to be able to track the kind of organization that this is - different organization types have different uses
Comments | Organizations can be corporations, wards, sections, clinical teams, government departments, etc. Note that code is generally a classifier of the type of organization; in many applications, codes are used to identity a particular organization (say, ward) as opposed to another of the same type - these are identifiers, not codes
RIM Mapping | .code
To Do | Name code is too RIM-like. Should be typeCode or type.
Organization.industryCode
Definition | The industry that this organization is involved in
Control | Optional, 0..1
Type | CodeableConcept from Industry
Requirements | For some organization types, an industry code is required for statistical reporting requirements
RIM Mapping | .standardIndustryClassCode
To Do | Is this really in the 80%??
Organization.accreditation
Definition | The qualifications a person has, including format educational achievements, accreditations, and current certifications. All these qualifications may be used to determine what roles a person may play in a healthcare environment
Control | 0..*
Requirements | For many persons in healthcare, it is necessary to track the qualifications a person has - formal.
RIM Mapping | .plays[Role](classCode='QUAL')
To Do | Not sure if qualified & accredited are the same. Could potentially propose a new classCode
Organization.accreditation.id
Definition | The identifier of the accreditation
Control | Optional, 0..1
Type | Identifier
Requirements | Allows a link back to a accreditation registry, if one exists
RIM Mapping | .identifier
To Do | Not a humanId?
Organization.accreditation.code
Definition | The type of the accreditation
Control | Optional, 0..1
Type | CodeableConcept from Accreditation
Requirements | commonly used to determine the roles an organization may perform
RIM Mapping | .code
Organization.accreditation.institution
Definition | The organization that confered/confers the accreditation
Control | Optional, 0..1
Type | Resource(Organization)
Requirements | May determine the significance of the qualification, and allows a link back to a qualification registry, if one exists
RIM Mapping | .scopedBy[Organization]
To Do | Do we need jurisdiction as well? (The jurisdiction is often more relevant than the accrediting org.)
Organization.accreditation.period
Definition | The period for which the accreditation is held
Control | Optional, 0..1
Type | Interval(date)
Requirements | Most accreditations are only conferred for a limited time period and must be re-acquired or forfeited
RIM Mapping | .effectiveTime[IVL<TS>]
Organization.relatedOrganization
Definition | Other organizations who are related to this person. The relationship might be one of several types: sub- or super- orgnizations (i.e. ward in a hospital, owning corporation of a hospital) or partner organizations (i.e. the operating corporation for a hospital)
Control | 0..*
Requirements | Need to be able to track many kinds of organizational relationships and use to determine roles and mediate workflows
To Do | There's no reason why this wouldn't point to another resource. Will map when updated accordingly.
Organization.relatedOrganization.id
Definition | Identifier the related organization - may be a full link to an Organization resource, or some other kind of identifier
Control | Optional, 0..1
Type | HumanId
Requirements | may have an identifier for the organization that can be used to source contact details
Organization.relatedOrganization.code
Definition | Code that specifies how this organization is related to the subject. A code is required.
Control | Mandatory, 1..1
Type | CodeableConcept from OrganizationRelationship
Requirements | Need to know how the organization is related
Organization.relatedOrganization.name
Definition | A name should be specified for the related organization
Control | Optional, 0..1
Type | string
Organization.relatedOrganization.address
Definition | Postal addresses may be provided for the related organization
Control | 0..*
Type | Address
Organization.relatedOrganization.contact
Definition | Contact details (phone, email etc) may be provided for the related organization
Control | 0..*
Type | Contact
Organization.relatedOrganization.period
Definition | The period during which the organizations were related in this fashion
Control | Optional, 0..1
Type | Interval(date)
Requirements | Organization relationships are changing all the time
Organization.extensions
Definition | See Extensions
Control | Optional, 0..1
RIM Mapping | [varies]
Organization.text
Definition | Text summary of organization, fall back for human interpretation
Control | 1..1
Type | Narrative
To Do | .text


Agent - FHIR v0.01

Agent

A person who represents an organisation, and is authorised to perform actions on it's behalf.

The relative url is /agents

Content

<Agent xmlns="http://www.hl7.org/fhir">
  <id> mand id Master Resource Id, always first in all resources</id>
  <person> mand (Person) The person who is the agent</person>
  <organization> mand (Organization) The represented organization</organization>
  <role> mand One+ CodeableConcept A role the agent has</role>
  <period> opt Interval(date) The period for which this agency applies</period>
  <identifier> Zero+ HumanId A Human identifier for the person as this agent</identifier>
  <address> Zero+ Address An address that applies for the person as this agent</address>
  <contact> Zero+ Contact A contact that applies for the person as this agent</contact>
  <extensions> opt See Extensions   See Extensions </extensions>
  <text> mand Narrative Text summary of the agent, for human interpretation</text>
</Agent>

Schema for Agent and an example (or formatted for browser)

Terminology Bindings

  • Agent.role is bound to the concept domain AgentRole: "The role a person plays representing an organization"

Notes:

  • Any person can represent the same organisation in multiple different ways. This may be represented as a single agent resource with multiple role codes, or multiple agent resources. Which is correct depends on whether the combined roles share other attributes, such as identifiers and time periods.
  • The person and organization references are mandatory, so must be a full resource reference by identifier

Searching Criteria

The following simple search/filter parameters are defined for person:

person | The identity of a person
organization | The identity of an organization
id | search id in any agent identifiers

The standard search parameters also apply (see Searching).

Formal Definitions

The formal definitions for the elements above. Also available as an XML file

Agent
Definition | A person who represents an organisation, and is authorised to perform actions on it's behalf
Control | Mandatory, 1..1
Requirements | Need to track doctors, staff, locums etc for both healthcare providers, funders, etc.
RIM Mapping | Role
v2 Mapping | PRD (as one example)
Agent.id
Definition | Master Resource Id, always first in all resources
Control | Mandatory, 1..1
Type | id
RIM Mapping | .id(scope=OBJ)
Agent.person
Definition | The person who acts as the agent
Control | Mandatory, 1..1
Type | Resource(Person)
Must Understand | true
Requirements | Need to be able to track the person who represents the organisation separately
v2 Mapping | PRD-2
Agent.organization
Definition | The organisation that is being represented
Control | Mandatory, 1..1
Type | Resource(Organization)
Must Understand | true
Requirements | Need to be able to track the represented organisation separately
v2 Mapping | PRD-10 (-> 14)
Agent.role
Definition | The way in which the person represents the organisation - what role do they have?
Control | Mandatory, 1..*
Type | CodeableConcept from AgentRole
Must Understand | true
Requirements | Need to know what authority the agent has - what can they do?
Comments | A person may have more than one role. At least one role is required - why have an agent who isn't actually an agent?
v2 Mapping | PRD-1
Agent.period
Definition | The time period during which the agent was/is authorised to represent the organisation.
Control | Optional, 0..1
Type | Interval(date)
Requirements | Agencies are often for a limited period of time, and can be revoked. Even after the agencies is revoked, the fact that it existed must still be recorded
v2 Mapping | PRD-8/9
Agent.identifier
Definition | An identifier that applies to this person in this role
Control | 0..*
Type | HumanId
Must Understand | true
Requirements | Often, specific identifies are assigned for the agent
Comments | The identifier changes when a new/different person steps into the same role
v2 Mapping | PRD-7
Agent.address
Definition | A postal address for this person playing this role
Control | 0..*
Type | Address
Comments | i.e. the address is not their personal address. For many agents, this is the same as their work address
v2 Mapping | PRD-3
To Do | What about place? (PRD-4)
Agent.contact
Definition | A contact detail address for this person playing this role
Control | 0..*
Type | Contact
Comments | i.e. the contact is not their personal contact. For many agents, this is the same as their work contacts. Note that a person may choose to use a personal mobile phone (for instance) for their contact in a given role - in this case, the contact detail will be repeated in the agent resource
v2 Mapping | PRD-5
Agent.extensions
Definition | See Extensions
Control | Optional, 0..1
Agent.text
Definition | Text summary of the agent, for human interpretation
Control | Mandatory, 1..1
Type | Narrative


Patient - FHIR v0.01

Patient

A patient is a person or animal that is receiving care.

The relative url is /patients

Content

<Patient xmlns="http://www.hl7.org/fhir">
  <id> mand id Master Resource Id, always first in all resources</id>
  <link> mand Zero+ (Patient) Other patients linked to this resource</link>
  <active> mand boolean Whether this patient record is active (in use)</active>
  <person> cond (Person) The person who is the patient</person>
  <animal> cond (Animal) The animal which is the patient</animal>
  <provider> mand (Organization) Organization managing the patient</provider>
  <identifier> Zero+ HumanId An identifier for the person as this patient</identifier>
  <diet> opt CodeableConcept Dietary restrictions for the patient</diet>
  <confidentiality> opt CodeableConcept Confidentiality of the patient records</confidentiality>
  <recordLocation> opt CodeableConcept Where the paper record is</recordLocation>
  <extensions> opt See Extensions   See Extensions </extensions>
  <text> mand Narrative Text summary of person, for human interpretation</text>
</Patient>

Schema for Patient and an example (or formatted for browser)

Terminology Bindings

  • Patient.diet is bound to the concept domain PatientDiet: "casual dietary restrictions associated with this patient"
  • Patient.confidentiality is bound to the concept domain PatientConfidentiality: "The confidentiality of the records associated with this patient"
  • Patient.recordLocation is bound to the concept domain PaperRecordLocation: "A physical location for a record. (Usually site specific)"

Notes:

  • Links: linking patient records is an assertion that they both are about the same actual person. If any patient record is linked to another, then the other must be linked back to the source record.
  • The patient may be a person or an animal (in order to support vetinary medicine). Either a person or an animal resource link must be provided, but not both.
  • The dietary restrictions are not for specifying medical diets, but for casual dietary restrictions such as vegetarian, diary-free, nut-free, etc

Managing Patient Registration

Managing Patient registration is a well known difficult problem. Around 2% of registrations are in error, mostly duplicate records. Sometimes the duplicate record is caught fairly quickly and retired before much data is accumulated. In other cases, substantial amounts of data may accumulate. For these and other reasons, the identifiers associated with a patient may change over time.

The master identifier for the Patient Resource can never change. For this reason the identifiers with which humans are concerned (often called MRN - Medical Record Number, or UR - Unit Record) should not be used as the master identifier. Instead they should be represented in the Patient.identifier list where they can be managed. This is also useful for the case of institutions that have acquired multiple numbers because of mergers of patient record systems over time.

In this specification, patient records are never merged. If multiple patient records are found to be duplicates, they are linked. In a RESTful context, this is done using the "link patients" transaction described below. In other contexts, equivalent functionality will be needed. When patient resources are linked, one may be chosen as the "master" - the correct record. In this case, the active status of all the other resources is set to false, and all the content is moved to the active record by updating it directly.

Patient records may only be in one of two statuses: active and retired. A normal record is active - it is in use. The status retired is used when a record is created in error. Once the error is discovered, it can either be retired or deleted. A record does not need to be linked to be retired.

RESTful Transactions

The patient resource type defines one special transaction provided by the patient manager: "Link" for linking resources. The reason is that linking records is effectively a transaction that involves at least two resources, and all or none must change. Since the transaction involves multiple resources, it is implemented on the resource manager as a POST to [todo]

There is no content model for the response, except for an HTTP status code.

Searching Criteria

The following simple search/filter parameters are defined for person:

person | The identity of a person
provider | The identity of an organization
id | search id in any patient identifiers

The standard search parameters also apply (see Searching).

Formal Definitions

The formal definitions for the elements above. Also available as an XML file

Patient
Definition | A patient is a person or animal that is receiving care
Control | Mandatory, 1..1
Requirements | Tracking patient is the center of the healthcare process
RIM Mapping | Patient
Patient.id
Definition | Master Resource Id, always first in all resources
Control | Mandatory, 1..1
Type | id
To Do | .id(scope=OBJ)
Patient.link
Definition | A linked patient record is a record that concerns the same patient. Records are linked after it is realised that at least one was created in error.
Control | Mandatory, 0..*
Type | Resource(Patient)
Must Understand | true
Requirements | Due to the clerical errors associated with the difficulties of identifying humans consistently, duplicate patient records are frequently created in error
Comments | More then two patient records may be linked. Note that there is a special transaction for linking patient records in the RESTful context, as record linking consistency must be maintained
Patient.active
Definition | Whether the patient record is in use, or has been removed from active use
Control | Mandatory, 1..1
Type | boolean
Must Understand | true
Requirements | Need to be able to mark a patient record as not to be used because it was created in error
Comments | If a record is inactive, and linked to an active record, then future patient/person/record updates should occur on the other patient
Patient.person
Definition | The person that this patient record is about
Control | Conditional, 0..1: Either an animal or a person must be provided, but not both
Type | Resource(Person)
Must Understand | true
Requirements | Need to link this patient record to a known and identifiable person (or animal)
Patient.animal
Definition | The animal that this patient record is about
Control | Conditional, 0..1: Either an animal or a person must be provided, but not both
Type | Resource(Animal)
Requirements | Need to link this patient record to a known and identifiable animal (or person)
Patient.provider
Definition | The provider for whom this is a patient record
Control | Mandatory, 1..1
Type | Resource(Organization)
Must Understand | true
Requirements | Need to know who recognises this patient record
To Do | But is thie same as institution above?
Patient.identifier
Definition | An identifier that applies to this person as a patient
Control | 0..*
Type | HumanId
Must Understand | true
Requirements | Patients are almos always assigned specific numerical identifiers
Patient.diet
Definition | Dietary restrictions for the patient
Control | Optional, 0..1
Type | CodeableConcept from PatientDiet
Requirements | Track patients reported dietary restrictions to help with catering requirements
Comments | not for specifying medical diets, but for casual dietary restrictions such as vegetarian, diary-free, nut-free, etc
Patient.confidentiality
Definition | Confidentiality of the patient records
Control | Optional, 0..1
Type | CodeableConcept from PatientConfidentiality
Requirements | Need to be able to track which patient records are particularly sensitive
Comments | Confidentiality tracking also occurs at more detailed points in the medical record
Patient.recordLocation
Definition | The location of the paper record for the patient, if there is one
Control | Optional, 0..1
Type | CodeableConcept from PaperRecordLocation
Requirements | Track old paper records where these are still in use
Patient.extensions
Definition | See Extensions
Control | Optional, 0..1
Patient.text
Definition | Text summary of person, for human interpretation
Control | Mandatory, 1..1
Type | Narrative


Document - FHIR v0.01

Document

A documentation of clinical observations and services that are aggregated together into a single statement of clinical meaning that establishes it's own context. A clinical document is composed of a set of resources that include both human and computer readable portions. A human must attest to the accuracy of the human readable portion, and may authenticate and/or sign the entire whole.

The relative url is /documents

Content

<Document xmlns="http://www.hl7.org/fhir">
  <id> mand id Master Resource Id = document Id</id>
  <instant> mand instant Document Creation Time</instant>
  <type> mand CodeableConcept Document Type (LOINC if possible)</type>
  <title> opt string Document Title</title>
  <setId> cond id Id fixed across all document revisions</setId>
  <version> opt integer used to version successive replacement documents</version>
  <replaces> cond id If this document replaces another</replaces>
  <subject> mand (Patient|Group) who the document is about</subject>
  <author> mand  <!-- One+ Author (contributed content to document) -->
   <time> opt dateTime When authoring happened</time>
   <party> mand (Person|Device) who/what authored the final document</party>
  </author>
  <attestor> opt  <!-- Zero+ attests to accuracy of document -->
   <mode> mand code personal | professional | legal | official</mode>
   <time> opt dateTime When document attested</time>
   <party> opt (Person|Organisation) who attested the document</party>
  </attestor>
  <recipient> opt Zero+ (Person|Organization) expected to receive a copy </recipient>
  <custodian> mand (Organization) org which maintains the document.</custodian>
  <event> opt (Any) the clinical item being documented</event>
  <encounter> opt (Admission|InterestOfCare) context of the document</encounter>
  <section> mand  <!-- One+ Document is broken into sections -->
   <type> opt CodeableConcept type of section (recommended)</type>
   <instant> opt instant Section Creation Time</instant>
   <author> opt  <!-- if section author different to document -->
    <time> opt dateTime When authoring happened</time>
    <party> mand (Person|Device) who/what authored the section</party>
   </author>
   <enterer> opt (Person|Device) The source of the data entry</enterer>
   <subject> opt (Person|Group) if section different to document</subject>
   <informant> opt (Person) provided information in section</informant>
   <content> cond (Any) the actual content of the section</content>
   <section> cond  <!-- Zero+ nested Section -->
     <!-- Content as for Document.Section -->
   </section>
  </section>
  <extensions> opt See Extensions   See Extensions </extensions>
  <text> mand Narrative Text summary of message, for human interpretation</text>
</Document>

Schema for Document and an example (or formatted for browser)

Terminology Bindings

  • Document.type is bound to the concept domain DocumentType: "Type of a clinical document". If an appropriate code exists in LOINC then it should be used
  • Document.attestor.mode is bound to the concept domain DocumentAuthenticationMode: "The way in which a person authenticated a document". Possible values:
    personal | The person authenticated the document in their personal capacity
    professional | The person authenticated the document in their professional capacity
    legal | The person authenticated the document and accepted legal responsibility for it's content
    official | The organization authenticated the document as consistent with their policies and procedures
  • Document.section.type is bound to the concept domain DocumentSectionType: "Type of a clinical document section". If an appropriate code exists in LOINC then it should be used

Notes:

  • The Document resource can be used in a RESTful framework as a stand-alone resource, or as the basis for a full document in the document framework.
  • The author and the attestor are often the same person, but this may not be the case in many clinical workflows
  • The attestor attests to the collated narrative portions of the resources
  • The author, subject, enterer, and informant features are inherited in contained sections, and need not be repeated. Specifying any of these in a section replaces the inherited value
  • The custodian is responsible for the maintainance of the document. Principally, they are responsible for the policy regarding persistence of the documents. They need not actually retain a copy of the document, but they should do so.

Displaying a document

The human display of the Document is the collated narrative portions of following resources (in order):

  1. The Document itself
  2. The subject resource
  3. Resources referenced in the section.content

The document narrative should summarise the important parts of the document header that are required to establish clinical context for the document (other than the subject, which is displayed in it's own right). To actually build the combined narrative, simply append all the narratives xhtml fragments. The viewer program can provide it's own stylesheet (.css) for the combined html of the narrative, but cannot change any styles specified internally in the existing narratives.

Originator Responsibilities

A document originator is an application that creates a document resource. The originator may create new content resources or assemble already existing content resources while doing so. A document originator has the following responsibilities:

  • Build a document that conforms to the Document rules, and links to content resources that also conform to the rules for the resources
  • Ensure that the content of the document is frozen and easily reproducible, either by aggregating the document, or using version specific resource references in a FHIR conformant RESTful framework
  • Ensure that the content of the documend and other resources conforms to any applicable conformance statements and declared clinical patterns.

Recipient Responsibilities

A document recipient is an application that receives documents from a document originator or document management system. The document recipient is responsible for ensuring that received CDA documents are processed and/or rendered in accordance to this specification. A document recipient has the following responsibilities:

  • Assume default values where they are defined in the FHIR specification (see the list here)
  • Render the document following the rules described above
  • A recipient is allowed to extract resources or data from the document, but doing so voids the attestation, and the recipient should always ensure that the user can access the original document when displaying extracted data
  • Warn users when a superceded document is displayed, and either withdraw data extracted from superceded documents, or warn users when they view it

Formal Definitions

The formal definitions for the elements above. Also available as an XML file

Document
Definition | A documentation of clinical observations and services that are aggregated together into a single statement of clinical meaning that establishes it's own context. A clinical document is composed of a set of resources that include both human and computer readable portions. A human must attest to the accuracy of the human readable portion, and may authenticate and/or sign the entire whole
Control | Mandatory, 1..1
Must Understand | true
Requirements | For document based framework
To Do | Confidentiality? Language? Consent? Signatures
Document.id
Definition | the unique id of a clinical document
Control | Mandatory, 1..1
Type | id
Must Understand | true
Requirements | Each document needs a unique identifier so other documents and underlying infrastructure can reference it
Comments | must be globally unique. UUIDs are recommended
Document.instant
Definition | the document creation time, when the document first came into being. Where the CDA document is a transform from an original document in some other format, the ClinicalDocument.effectiveTime is the time the original document is created.
Control | Mandatory, 1..1
Type | instant
Must Understand | true
Document.type
Definition | specifying the particular kind of document (e.g. History and Physical, Discharge Summary, Progress Note)
Control | Mandatory, 1..1
Type | CodeableConcept from DocumentType
Must Understand | true
Document.title
Definition | the title of the document
Control | Optional, 0..1
Type | string
Comments | It's commonly the case that clinical documents do not have a title, and are collectively referred to by the display name of Document.type (e.g. a "consultation" or "progress note"). Where these display names are rendered to the clinician, or where the document has a unique title, the Document.title value should be used
Document.setId
Definition | Represents an identifier that is common across all document revisions
Control | Conditional, 0..1: cannot have both setId and replaces
Type | id
Must Understand | true
Document.version
Definition | used to version successive replacement documents
Control | Optional, 0..1
Type | integer
Must Understand | true
Comments | An integer value is recommended
Document.replaces
Definition | If this document replaces another
Control | Conditional, 0..1: cannot have both setId and replaces
Type | id
Must Understand | true
Document.subject
Definition | who the document is about
Control | Mandatory, 1..1
Type | Resource(Patient|Group)
Must Understand | true
Document.author
Definition | Author (contributed content to document)
Control | Mandatory, 1..*
Document.author.time
Definition | When authoring happened
Control | Optional, 0..1
Type | dateTime
Document.author.party
Definition | who/what authored the final document
Control | Mandatory, 1..1
Type | Resource(Person|Device)
Document.attestor
Definition | a participant who has attested to the accuracy of the document
Control | Optional, 0..*
Document.attestor.mode
Definition | The type of attestation the authenticator offers
Control | Mandatory, 1..1
Type | code from DocumentAuthenticationMode
Document.attestor.time
Definition | When document attested
Control | Optional, 0..1
Type | dateTime
Document.attestor.party
Definition | who attested the document
Control | Optional, 0..1
Type | Resource(Person|Organisation)
Document.recipient
Definition | expected to receive a copy
Control | Optional, 0..*
Type | Resource(Person|Organization)
Document.custodian
Definition | org which maintains the document.
Control | Mandatory, 1..1
Type | Resource(Organization)
Document.event
Definition | the main Act, such as a colonoscopy or an appendectomy, being documented
Control | Optional, 0..1
Type | Resource(Any)
Comments | The event needs to be consistent with the type element, though can provide further information if desired
Document.encounter
Definition | context of the document
Control | Optional, 0..1
Type | Resource(Admission|InterestOfCare)
Document.section
Definition | Document is broken into sections
Control | Mandatory, 1..*
Document.section.type
Definition | type of section (recommended)
Control | Optional, 0..1
Type | CodeableConcept from DocumentSectionType
Document.section.instant
Definition | the section creation time (sections are often re-used in several documents).
Control | Optional, 0..1
Type | instant
Document.section.author
Definition | if section author different to document
Control | Optional, 0..1
Document.section.author.time
Definition | When authoring happened
Control | Optional, 0..1
Type | dateTime
Document.section.author.party
Definition | who/what authored the section
Control | Mandatory, 1..1
Type | Resource(Person|Device)
Document.section.enterer
Definition | The person or device that performed the data entry leading to this section. Where there is more than one candidate, pick the most proximal to the message. Can provide other enterers in extensions
Control | Optional, 0..1
Type | Resource(Person|Device)
Document.section.subject
Definition | if section different to document
Control | Optional, 0..1
Type | Resource(Person|Group)
Must Understand | true
Document.section.informant
Definition | provided information in section
Control | Optional, 0..1
Type | Resource(Person)
Document.section.content
Definition | the actual content of the section
Control | Conditional, 0..1: a section must have content or one or more sections
Type | Resource(Any)
Must Understand | true
Document.section.section
Definition | nested Section
Control | Conditional, 0..*: a section must have content or one or more sections
Document.section.section.#
Definition | contents as for a section
Control | Mandatory, 1..1
Type | @Document.Section
Document.extensions
Definition | See Extensions
Control | Optional, 0..1
Document.text
Definition |
Control | Mandatory, 1..1
Type | Narrative


LabReport - FHIR v0.01

LabReport

The findings and interpretation of pathology tests performed on tissues and body fluids. This is typically done in a laboratory but may be done in other environments such as at the point of care.

The relative url is /labreports

Content

<LabReport xmlns="http://www.hl7.org/fhir">
  <id> mand id Master Resource Id, always first in all resources</id>
  <status> mand code Registered|Interim|Final|Amended|Cancelled|Withdrawn</status>
  <issued> mand instant date issed for current status</issued>
  <patient> mand (Patient) The patient the report is about</patient>
  <admission> opt (Admission) Admission Context</admission>
  <laboratory> mand (Organization) Responsible Laboratory</laboratory>
  <reportId> opt id Id for external references to this report</reportId>
  <requestDetail>  <!-- Zero+ -->
   <requestOrderId> opt Identifier Id assigned by requester</requestOrderId>
   <receiverOrderId> opt Identifier Receiver's Id for the request</receiverOrderId>
   <requestTest> Zero+ CodeableConcept Test Requested</requestTest>
   <requester> opt (Agent|Organization) Responsible for request</requester>
   <clinicalInfo> opt (Any) Clinical information provided</clinicalInfo>
  </requestDetail>
  <reportName> mand CodeableConcept Name for the entire report</reportName>
  <service> opt CodeableConcept Biochemistry, Haematology etc</service>
  <diagnosticTime> mand dateTime Effective time of diagnostic report</diagnosticTime>
  <specimen> Zero+ (Specimen) Specimen (incl. time of collection)</specimen>
  <resultGroup>  <!-- One+ -->
   <name> opt CodeableConcept What defines the group</name>
   <specimen> opt (Specimen) Specimen details</specimen>
   <result>  <!-- One+ -->
    <name> opt CodeableConcept Name or code of the result</name>
    <value[x]> opt Quantity|CodeableConcept|Attachment|
              Ratio|Choice|Interval(dateTime)|string Result. [x] = type name</value[x]>
    <flag> opt code + | ++ | +++ | - | -- | --- </flag>
    <status> mand code Registered|Interim|Final|Amended|Cancelled|Withdrawn</status>
    <comments> opt string Comments about result</comments>
    <referenceRange>  <!-- Zero+ -->
     <meaning> opt CodeableConcept The meaning of this range</meaning>
     <range[x]> mand Quantity|Interval(Quantity)|string Reference</range[x]>
    </referenceRange>
   </result>
  </resultGroup>
  <conclusion> opt Narrative Clinical Interpretation of test results</conclusion>
  <codedDiagnosis> Zero+ CodeableConcept Codes for the conclusion</codedDiagnosis>
  <representation> One+ Attachment Entire Report as issued</representation>
  <extensions> opt See Extensions   See Extensions </extensions>
  <text> mand Narrative Text summary of report, for human interpretation</text>
</LabReport>

Schema for LabReport and an example (or formatted for browser)

Terminology Bindings

  • LabReport.status and LabReport.resultGroup.result.status are bound to the concept domain LabReportStatus: "The status of a report or result item". Possible values:
    registered | The existence of the result is registered, but there is no result yet available
    interim | This is an initial or interim result: data may be missing or verification not been performed
    final | The result is complete and verified by the responsible pathologist
    amended | The result has been modified subsequent to being Final, and is complete and verified by the responsible pathologist
    cancelled | The result is unavailable because the test was not started or not completed (also sometimes called aborted)
    withdrawn | The result has been withdrawn following previous Final release
  • LabReport.requestDetail.requestTest is bound to the concept domain LabRequests: "codes for requestable tests"
  • LabReport.reportName is bound to the concept domain LabReportNames: "codes for report names". If an appropriate code exists in LOINC then it should be used
  • LabReport.service is bound to the concept domain LabServices: "codes for laboratory services". For example values, see HL7 v2 table 0074
  • LabReport.resultGroup.name is bound to the concept domain LabResultGroupNames: "codes for result groups". If an appropriate code exists in LOINC then it should be used
  • LabReport.resultGroup.result.name is bound to the concept domain LabResultNames: "codes for results". If an appropriate code exists in LOINC then it should be used
  • LabReport.resultGroup.result.value[x] is not bound to a concept domain
  • LabReport.resultGroup.result.flag is bound to the concept domain LabResultFlag: "codes for result flags". Possible values:
    -
    --
    ---
    +
    ++
    +++
  • LabReport.resultGroup.result.referenceRange.meaning is bound to the concept domain LabReferenceRanges: "Code for the meaning of a reference range"
  • LabReport.codedDiagnosis is bound to the concept domain LabDiagnosisCodes: "Codes for laboratory diagnoses". A good candidate for codes is SNOMED-CT

Notes:

  • About naming: a laboratory produces "reports" that is a collection of "tests" that produce "results". Clinical consumers call the whole collection "the results". There is much potential confusion around these names. The confusion is worsened because "the report" is sometimes a document which entirely contains narrative, sometimes it is purely atomic data results, and sometimes it's a mix of both.
  • The scope of this resource is the laboratory reporting process. While this resource includes some elements that relate to the ordering cycle, these are only included to the degree that it is useful for the final report to refer back to the orders. Different resources are required for supporting the ordering cycle.
  • This laboratory report model provides a 3 level structure for the results - a report contains a list of groups, each of which contains a list of results. Results are grouped by either a specimen or a code that indicates that nature of the grouping (e.g. organism isolate/sensitivity or antibody functional testing). While many common lab reports don't need or benefit directly from the group structure, this lab report model imposes the group structure anyway. This means that these lab reports have a single group which has no code on it, and which contains all the results. The advantage of this model is that all the results are found at the same point in the heirarchy, and there is a single point on the heirarchy - the group - that may influence the meaning of the test.
  • The element that contains the actual value of the result has a variable name depending on the type. The name is "value" + the type name, ignoring parameters, with a capital on the first letter, e.g. valueInterval or valueString
  • The clinical information associated with a request can be a simple text summary, or a reference to another resource
  • The diagnosticTime can be inferred from the specimens, if they are provided, but specimen details are often not provided, and the value of diagnosticTime is always important. The value of the diagnosticTime element must be consistent with the speciment collection times
  • Applications consuming lab reports must take careful note of updates to lab reports, and particularly note withdrawn reports. A report shouldn't be final until all the results are final or amended. If a report is withdrawn, all the results must be withdrawn by replacing every result value with the Concept "withdrawn" in the internal terminology "Special values" (sid = "urn:hl7-org:sid/fhir/special-values"), and setting the conclusion (if provided) and the text narrative to some text like "This report has been withdrawn". A reason may be provided in the narrative.

Relationship between results, narrative, and synoptic reports

One difficult aspect of the design of this resource can be captured with a simple question: “just what is a result?” There is a wide range of variation in the answers to this question; some respond that a result is inherently measurement based, while others focus on the clinical utility of the data item.

Some practical examples:

  • Tumour dimensions in synoptic reports
  • Injection volumes in radiology reports
  • Phenotypes and genotypes in pathology reports
  • Images (Scatter plots, electrophoresis photos, slide photos, chromatograms)

Which of these are results? For this resource, we have chosen to take an inclusive view; any of these things can be a result, as long as they have a formal code or name that has a clinical meaning, and some kind of (possible) value then they can be a result.

Searching Criteria

The following simple search/filter parameters are defined for person:

id | an identifier associated with the report
test | the name or code of either a requested test, the report or a report group
result | the name or code or result value of a result
specimen | Either of the specimens. The parameter is then followed by an additional parameter (separated for a ".") that species search/filter inside specimen
patient | The identity of a patient
laboratory | The identity of an laboratory

The standard search parameters also apply (see Searching).

Formal Definitions

The formal definitions for the elements above. Also available as an XML file

LabReport
Definition | The findings and interpretation of pathology tests performed on tissues and body fluids. This is typically done in a laboratory but may be done in other environments such as at the point of care
Control | Mandatory, 1..1
Requirements | Use to record any pathology test result, including the result of a test on a specimen taken as part of a composite procedure or operation.
Comments | Not to be used for reporting on non-pathology test results e.g. diagnostic imaging, ECG or respiratory function tests. Not to be used to represent an entire cumulative report. This Pathology test result archetype represents only one of the result sets that is usually viewed as a vertical in a cumulative test report. A cumulative report is a view that is constructed from the results represented by multiple OBSERVATION archetypes. This archetype is suitable for representation of general pathology test results, but not intended to cover full synoptic reports. For these, additional resources are required to represent the data properly
RIM Mapping | Observation[isNormalAct() and subsumesCode("ActClass#OBS", classCode) and moodCode="EVN" and domainMember("LabObservationType", code)]
LabReport.id
Definition | Master Resource Id, always first in all resources
Control | Mandatory, 1..1
Type | id
RIM Mapping | unique(./id[isNormalDatatype() and displayable="false" and scope="OBJ" and reliability="ISS"])
LabReport.status
Definition | The status of the pathology test result as a whole
Control | Mandatory, 1..1
Type | code from LabReportStatus
Must Understand | true
Requirements | Labs routinely issue provisional/incomplete reports, or withdraw previously released reports
RIM Mapping | registered: ./statusCode[isNormalDatatype()]="new"; interim: ./statusCode[isNormalDatatype()]="active"; final: ./statusCode[isNormalDatatype()]="complete" and not(./inboundRelationship[typeCode="SUBJ" and isNormalActRelationship()]/source[subsumesCode("ActClass#CACT") and moodCode="EVN" and domainMember("ReviseLabOrder", code) and isNormalAct()]); amended: ./statusCode[isNormalDatatype()]="complete" and ./inboundRelationship[typeCode="SUBJ" and isNormalActRelationship()]/source[subsumesCode("ActClass#CACT") and moodCode="EVN" and domainMember("ReviseLabOrder", code) and isNormalAct() and statusCode="completed"]; cancelled: ./statusCode[isNormalDatatype()]="aborted"; withdrawn: ./statusCode[isNormalDatatype()]="obsolete"
LabReport.issued
Definition | The date and/or time that the result was issued from the source for the recorded â€˜Test result status
Control | Mandatory, 1..1
Type | instant
Must Understand | true
Requirements | Clinicians need to be able to check the date that the report was released
Comments | May be different from LabReport.updated, because that is the status of this record, not the report the record is about
RIM Mapping | firstOf(unique(./participation[isHighest(priorityCode) and typeCode="VRF" and isNormalParticipation()]/time[type="TS"]), unique(./participation[isHighest(priorityCode) and typeCode="AUT" and isNormalParticipation()]/time[type="TS"]))
LabReport.patient
Definition | The patient about who the report is about
Control | Mandatory, 1..1
Type | Resource(Patient)
Must Understand | true
Requirements | Must know the patient context
RIM Mapping | unique(./participation[isHighest(priorityCode) and typeCode="SBJ" and isNormalParticipation()]/role[classCode="PAT"])
To Do | need to check the wording -is it about, upon, for?
LabReport.admission
Definition | The admission that this diagnostic investigation is associated with
Control | Optional, 0..1
Type | Resource(Admission)
Requirements | Some institutions track and file diagnostic reports under a specific admission
RIM Mapping | unique(./inboundRelationship[isHighest(priorityCode) and typeCode="SUBJ" and isNormalActRelationship()]/source[subsumesCode("ActClass#ENC", code) and moodCode="EVN" and isNormalAct()])
To Do | Reckon this is not 80%
LabReport.laboratory
Definition | The laboratory service that issued the report
Control | Mandatory, 1..1
Type | Resource(Organization)
Requirements | Need to know how to contact if there are queries about the results. Also may need to track the source of reports for secondary data analysis
Comments | This is not necessarily the source of the atomic reports - it's the lab that takes responsibility for the clinical report
RIM Mapping | unique(./participation[isHighest(priorityCode) and typeCode="AUT" and isNormalParticipation()]/role[subsumesCode("RoleClass#ASSIGN", classCode)]/scoper[subsumesCode("EntityClass#ORG", classCode) and determinerCode="INSTANCE"])
LabReport.reportId
Definition | The local ID assigned to the report by the order filler, usually by the Laboratory Information System (LIS).
Control | Optional, 0..1
Type | id
Requirements | Need to know what identifier to use when making queries about this report from the source laboratory
RIM Mapping | unique(./id[displayable="true" and scope="OBJ"])
LabReport.requestDetail
Definition | Details concerning a single pathology test requested.
Control | 0..*
Requirements | Need to be able to track completion of requests based on reports issued, and also to report what diagnostic test swere requested (not always the same as what is delivered)
Comments | Note: Usually there is one test request for each result, however in some circumstances multiple test requests may be represented using a single Pathology test result resource
RIM Mapping | unique(./outboundRelationship[typeCode="FLFS" and isNormalActRelationship()]/target[subsumesCode("ActClass#OBS", classCode) and subsumes("ActMood#PRMS", moodCode) and isNormalAct()])
LabReport.requestDetail.requestOrderId
Definition | The local ID assigned to the order by the order requester.
Control | Optional, 0..1
Type | Identifier
Requirements | Need to be able to track completion of requests based on reports issued
Comments | Equivalent to the Placer Order Identifier
RIM Mapping | unique(./outboundRelationship[typeCode="FLFS" and isNormalActRelationship()]/target[subsumesCode("ActClass#OBS", classCode) and subsumes("ActMood#RQO", moodCode) and isNormalAct()]/id[scope="OBJ" and displayable="true"])
To Do | Reckon this is not 80%
LabReport.requestDetail.receiverOrderId
Definition | The local ID assigned to the test order by the order filler, usually by the Laboratory Information System (LIS).
Control | Optional, 0..1
Type | Identifier
Requirements | Need to be able to track completion of requests based on reports issued
Comments | Usually equivalent to the DICOM Accession Number and the Filler Order Identifier.
RIM Mapping | unique(./id[scope="OBJ" and displayable="true"])
To Do | Reckon this is not 80%
LabReport.requestDetail.requestTest
Definition | Identification of pathology test requested,
Control | 0..*
Type | CodeableConcept from LabRequests
Requirements | Need to be able to report what diagnostic test swere requested (not always the same as what is delivered)
Comments | Useful where the test requested differs from the test actually performed.
RIM Mapping | ./code
LabReport.requestDetail.requester
Definition | Details of the clinician or organisation requesting the laboratory test.
Control | Optional, 0..1
Type | Resource(Agent|Organization)
Requirements | The requesting clinician may need to be contacted concerning the interpretation of the lab report
RIM Mapping | Agent: unique(./participation[isHighest(priorityCode) and typeCode="AUT" and isNormalParticipation()]/role[subsumesCode("RoleClass#ASSIGN", classCode)] Organization: unique(./participation[isHighest(priorityCode) and typeCode="AUT" and isNormalParticipation()]/role[subsumesCode("RoleClass#ASSIGN", classCode)]/scoper[subsumesCode("EntityClass#ORG", classCode) and determinerCode="INSTANCE" and code[isNormalDatatype]])
LabReport.requestDetail.clinicalInfo
Definition | Details of the clinical information provided to the laboratory along with the original request
Control | Optional, 0..1
Type | Resource(Any)
Requirements | Knowing the clinical information may influence the interpretation of the result
RIM Mapping | ./outboundRelationship[typeCode="PERT" and isNormalActRelationship()]/target
To Do | This isn't really *ANY* resource. You can't send a drug or an Animal or a bunch of other things. What you really want here are "acts", and I suspect there's a constraint that the subject of the LabReport must have participated in them as subject or perhaps in some other way.
LabReport.reportName
Definition | Identification of the pathology test performed, sometimes including specimen type.
Control | Mandatory, 1..1
Type | CodeableConcept from LabReportNames
Must Understand | true
Requirements | Need to know what report this is, so clinicians can filter/find the reports they are looking for
Comments | A test result may be for a single analyte, or a group of items, including panel tests.
RIM Mapping | ./code
LabReport.service
Definition | The diagnostic service that performs the examination e.g. biochemistry, haematology.
Control | Optional, 0..1
Type | CodeableConcept from LabServices
Requirements | Help clinicians filter/find the reports they are looking for
RIM Mapping | unique(./inboundRelationship[typeCode="COMP" and isNormalActRelationship()]/source[subsumesCode("ActClass#LIST", classCode) and moodCode="EVN" and inDomain(code,"Lab Service") and isNormalAct()]/code
To Do | I'm not sure this is in the 80%.
LabReport.diagnosticTime
Definition | The diagnostically relevant time for this report
Control | Mandatory, 1..1
Type | dateTime
Must Understand | true
Requirements | Need to know where in the patient history to file/present this report
Comments | The diagnostically relevant time can be derived from the specimen collection times, but the specimen information is not always available, and the exact relationship is not always automatic
RIM Mapping | ./effectiveTime[type="TS"]
LabReport.specimen
Definition | Details about the specimen if all individual test results are derived from the same specimen
Control | 0..*
Type | Resource(Specimen)
Requirements | Need to be able to report information about the collected specimens on which the report is based
Comments | If the specimen is sufficiently specified with a code in the Test result name, then this additional data may be redundant. If there are multiple specimens, these may be represented per 'Result group'
RIM Mapping | unique(./participation[typeCode="SUBJ" and isNormalParticipation()]/role[subsumesCode("RoleClass#SPEC", classCode)])
LabReport.resultGroup
Definition | A group of results. Results may be grouped by specimen, or by some value in LabReport.resultGroup.name to describe what binds all the results together.
Control | 1..*
Must Understand | true
Requirements | Need to be able to report groups of results, where the result grouping is arbitrary, but meaningful
Comments | Many (most) lab reports don't really have a meaningful group. In these cases, just create a single group with no specimen or name
RIM Mapping | ./outboundRelationship[typeCode="COMP" and isNormalActRelationship()]/target[isNormalAct() and subsumesCode("ActClass#OBS", classCode) and moodCode="EVN" and fromDomain(code, "LabObservationBattery")]
LabReport.resultGroup.name
Definition | A code or name that describes the group of results
Control | Optional, 0..1
Type | CodeableConcept from LabResultGroupNames
Must Understand | true
Comments | For example, the antibody code for a goup of antibody related test, or the organism code for a group of isolate/sensitivities. Leave blank if there is no particular meaning associated with the group
RIM Mapping | ./code
LabReport.resultGroup.specimen
Definition | Details about the individual specimen to which these â€˜Result groupâ€™ test results refer, where testing of multiple specimens is required.
Control | Optional, 0..1
Type | Resource(Specimen)
Requirements | Need to be able to report information about the collected specimens on which the report is based
RIM Mapping | unique(./participation[typeCode="SBJ" and isNormalParticipation()]/role[subsumesCode("RoleClass#SPEC", classCode)])
LabReport.resultGroup.result
Definition | Specific detailed result, including both the value of the result item, and additional information that may be useful for clinical interpretation. Results include whatever specific data items pathology labs report as part of the clinical service; it is not confined to measurements.
Control | 1..*
Must Understand | true
Requirements | Need to report results with information that assist with interpretation
RIM Mapping | ./outboundRelationship[typeCode="COMP" and isNormalActRelationship()]/target[subsumesCode("ActClass#OBS", classCode) and moodCode="EVN" and isNormalAct() and fromDomain(code, "LabObservationResult")]
LabReport.resultGroup.result.name
Definition | Identifies the meaning of the value
Control | Optional, 0..1
Type | CodeableConcept from LabResultNames
Must Understand | true
Requirements | Need to know what the result is about
Comments | results are fundamentally a name - value pair with additional clarifying information
RIM Mapping | ./code
LabReport.resultGroup.result.value[x]
Definition | Actual value of the result. Most result values will be numerical measurements, but others may be coded concepts, free text, or multimedia images
Control | Optional, 0..1
Type | Quantity|CodeableConcept|Attachment|Ratio|Choice|Interval(dateTime)|string from *unbound*
Must Understand | true
Requirements | Need a value for the result
RIM Mapping | ./value
LabReport.resultGroup.result.flag
Definition | Flag indicating the abnormal status of the result
Control | Optional, 0..1
Type | code from LabResultFlag
Must Understand | true
RIM Mapping | ./interpretationCode
To Do | The proposed set of codes are too narrow (and doesn't map well to v3.)
LabReport.resultGroup.result.status
Definition | The status of the result value
Control | Mandatory, 1..1
Type | code from LabReportStatus
Must Understand | true
Requirements | Need to track the status of individual results - some results are finalised before the whole report is finalised
RIM Mapping | (as per LabReport.status)
LabReport.resultGroup.result.comments
Definition | May include statements about significant, unexpected or unreliable. values, or information about the source of the value where this may be relevant to the interpretation of the result.
Control | Optional, 0..1
Type | string
Must Understand | true
Requirements | Need to be able to provide free text additional information
RIM Mapping | unique(./inboundRelationship[typeCode="SUBJ" and isNormalActRelationship()]/source[subsumesCode("ActClass#OBS", classCode) and moodCode="EVN" and mapsTo(code, "LOINC# 48767-8") and isNormalAct()]/value[type="ST"])
LabReport.resultGroup.result.referenceRange
Definition | Guidance on how to interpret the value by comparison to a normal or recommended range
Control | 0..*
Must Understand | true
Requirements | Need to be able to provide multiple reference ranges
Comments | Most results only have one reference range. Some non-numerical results don't have a reference range
RIM Mapping | ./outboundRelationship[typeCode="REFV" and isNormalActRelationship()]/target[subsumesCode("ActClass#OBS", classCode) and moodCode="EVN" and isCriterionInd="true" and isNormalAct()]
To Do | Are multiple reference ranges in the 80%?
LabReport.resultGroup.result.referenceRange.meaning
Definition | Code for the meaning of the reference range
Control | Optional, 0..1
Type | CodeableConcept from LabReferenceRanges
Requirements | Need to be able to say what kind of reference range this is - normal, recommended, therapeutic, or perhaps what state this reference range applies to (i.e. hormonal cycles)
RIM Mapping | ./interpretationCode
LabReport.resultGroup.result.referenceRange.range[x]
Definition | Actual value of the reference range. May be a quantity (<20mg/L), an interval (10-20 umol/L), or some text
Control | Mandatory, 1..1
Type | Quantity|Interval(Quantity)|string
Requirements | Need to be able to report numerical or text reference ranges, and handle legacy data
Comments | Text reference ranges are typically used in endocrinology, or for legacy data with string reference ranges
RIM Mapping | ./value[type=("PQ", "IVL_PQ", "ST")]
LabReport.conclusion
Definition | Concise and clinically contextualised narrative interpretation of the pathology test results.
Control | Optional, 0..1
Type | Narrative
Must Understand | true
Requirements | Need to be able to provide a conclusion that is not lost amongst the basic result data
Comments | common reports don't have a conclusion, but some do
RIM Mapping | unique(./inboundRelationship[typeCode="SPRT" and isNormalActRelationship()]/source[subsumesCode("ActClass#OBS", classCode) and moodCode="EVN" and mapsTo(code, "LOINC# 48767-8") and isNormalAct()]/value[type="ST"])
To Do | Is this in the 80%?
LabReport.codedDiagnosis
Definition | Codes for the conclusion
Control | 0..*
Type | CodeableConcept from LabDiagnosisCodes
RIM Mapping | unique(./inboundRelationship[typeCode="SPRT" and isNormalActRelationship()]/source[subsumesCode("ActClass#OBS", classCode) and moodCode="EVN" and subsumesCode(code, "LOINC# 54531-9") and isNormalAct()]/value[type="CD"])
LabReport.representation
Definition | Rich text representation of the entire result as issued by the diagnostic service. Multiple formats are allowed but they must be semantically equivalent.
Control | 1..*
Type | Attachment
Must Understand | true
Requirements | Laboratory needs to be able to provide it's own fully formatted report for clinical fidelity
Comments | Possible formats: text/html, text/plain, text/rtf, application/msword, application/pdf, application/rtf, application/vnd.oasis.opendocument.text, application/vnd.openxmlformats-officedocument.wordprocessingml.document
RIM Mapping | ./text[type="ED"]
LabReport.extensions
Definition | See Extensions
Control | Optional, 0..1
RIM Mapping | N/A
LabReport.text
Definition | Text summary of report, for human interpretation
Control | Mandatory, 1..1
Type | Narrative
RIM Mapping | unique(./text[type="ST"])


Prescription - FHIR v0.01

Prescription

Directions provided by a prescribing practitioner for a specific medication to be administered to an individual.

The relative url is /prescriptions

Content

<Prescription xmlns="http://www.hl7.org/fhir">
  <id> mand id Master Resource Id, always first in all resources</id>
  <identifier> mand Zero+ HumanId Prescription identification</identifier>
  <status> mand code Status: Active|Completed</status>
  <patient> mand (Patient) Patient receiving medicine</patient>
  <prescriber> mand (Agent) Prescribing doctor</prescriber>
  <prescribed> mand dateTime Date/time prescribed</prescribed>
  <dispense> opt  <!-- Details of included dispense request -->
   <repeats> opt integer Number of repeats</repeats>
   <quantity> mand Quantity Quantity per repeat</quantity>
   <dispenser> opt (Agent|Organization) Person to fullfil the requested dispense</dispenser>
  </dispense>
  <medicine> mand  <!-- Prescribed medicine -->
   <productCode> cond Coding Coded representation of medicine</productCode>
   <description> cond string Textual description of medicine</description>
   <activeIngredient> opt  <!-- Zero+ Active substance -->
    <productCode> mand Coding Coded representation of active ingredient</productCode>
    <quantity> opt Ratio Relative quantity of active ingredient</quantity>
   </activeIngredient>
   <inactiveIngredient> opt  <!-- Zero+ Inactive substance -->
    <productCode> mand Coding Coded representation of inactive ingredient</productCode>
    <quantity> opt Ratio Relative quantity of inactive ingredient</quantity>
   </inactiveIngredient>
  </medicine>
  <administrationRequest> mand  <!-- Instructions for use -->
   <description> opt string Textual instructions for use</description>
   <totalPeriodicDosis> opt Ratio Total periodic dosis</totalPeriodicDosis>
   <start> cond dateTime Startdate for administration</start>
   <end> cond dateTime Enddate for administration</end>
   <duration> cond Quantity Total duration of administration</duration>
   <numberOfAdministrations> cond integer Maximum number of separate administrations</numberOfAdministrations>
   <dosageInstruction> mand  <!-- One+ Dosage instruction -->
    <precondition> opt Zero+ CodeableConcept Precondition for starting administration</precondition>
    <prn> opt code Pro re nate: Yes|No</prn>
    <additionalInstruction> opt Zero+ CodeableConcept Additional instructions</additionalInstruction>
    <route> opt CodeableConcept Route of administration</route>
    <dose[x]> mand Quantity|Interval(Quantity) Dose per administration</dose[x]>
    <rate> opt Quantity Flow-rate for IV</rate>
    <schedule> mand One+ Schedule Schedule for administration</schedule>
   </dosageInstruction>
  </administrationRequest>
  <reason> opt CodeableConcept Reason for prescription</reason>
  <extensions> opt See Extensions   See Extensions </extensions>
  <text> mand Narrative Text summary of the prescription, for human interpretation</text>
</Prescription>

Schema for Prescription and an example (or formatted for browser)

Terminology Bindings

  • Prescription.status is bound to the concept domain PrescriptionStatus: "The status of a prescription". Possible values:
    active | Patient is using the prescribed medicin
    completed | Prescription is no longer current
  • Prescription.medicine.productCode, Prescription.medicine.activeIngredient.productCode and Prescription.medicine.inactiveIngredient.productCode are bound to the concept domain MedicationKind: "The kind of medication, vaccine or therapeutic material". The possible values are those specified in G-Standaard (Netherlands), AMT (Australie)
  • Prescription.administrationRequest.dosageInstruction.precondition is bound to the concept domain AdministrationPrecondition: "Precondition for administering medication". The possible values are those specified in NHG Table 25b
  • Prescription.administrationRequest.dosageInstruction.prn is bound to the concept domain BooleanYesNo: "Either yes or no, true or false". Possible values:
    yes | TRUE
    no | FALSE
  • Prescription.administrationRequest.dosageInstruction.additionalInstruction is bound to the concept domain AdministrationInstruction: "Instructions for administering medication". The possible values are those specified in NHG Table 25b
  • Prescription.administrationRequest.dosageInstruction.route is bound to the concept domain AdministrationRoute: "Route by which a medication is administered". The possible values are those specified in G-Standaard subtable 0007
  • Prescription.reason is bound to the concept domain PrescriptionReason: "Medical reason for prescribing a medicine". The possible values are those specified in ICD-10, ICPC-1

Notes:

  • TODO

RESTful Transactions

TODO

There is no content model for the response, except for an HTTP status code.

Searching Criteria

The following simple search/filter parameters are defined for prescription:

patient | The identity of a patient to list prescriptions for
prescriber | The identity of a prescriber to list prescriptions from
startdate | Return only prescriptions made starting from this date
enddate | Return only prescriptions made before this date
id | search id in any prescription identifiers

The standard search parameters also apply (see Searching).

Formal Definitions

The formal definitions for the elements above. Also available as an XML file

Prescription
Definition | Directions provided by a prescribing practitioner for a specific medication to be administered to an individual
Control | Mandatory, 1..1
Requirements | Used to record details about the prescribed medication, administration schedule, dosage and dispensing.
RIM Mapping | SubstanceAdministration
Prescription.id
Definition | Master Resource Id, always first in all resources
Control | Mandatory, 1..1
Type | id
Prescription.identifier
Definition | A identifier used in an external system and associated with this medication
Control | Mandatory, 0..*
Type | HumanId
Must Understand | true
Requirements | Prescriptions are almost always assigned specific numerical identifiers
RIM Mapping | .id
Prescription.status
Definition | Actual status of the prescription
Control | Mandatory, 1..1
Type | code from PrescriptionStatus
Must Understand | true
RIM Mapping | .statusCode
Prescription.patient
Definition | The patient the prescription is prescribing medicine for
Control | Mandatory, 1..1
Type | Resource(Patient)
Must Understand | true
Prescription.prescriber
Definition | The clinician or doctor prescribing the medication
Control | Mandatory, 1..1
Type | Resource(Agent)
Prescription.prescribed
Definition | Date/time on which the prescription was written
Control | Mandatory, 1..1
Type | dateTime
Prescription.dispense
Definition | Details of the dispense as requested by the prescriber
Control | Optional, 0..1
Prescription.dispense.repeats
Definition | Requested number of repeats
Control | Optional, 0..1
Type | integer
Comments | Default is "1"
Prescription.dispense.quantity
Definition | Requested quantity per repeat
Control | Mandatory, 1..1
Type | Quantity
Prescription.dispense.dispenser
Definition | Person to fullfil the requested dispense
Control | Optional, 0..1
Type | Resource(Agent|Organization)
Prescription.medicine
Definition | The one single medicatine, vaccine or therapeutic good prescribed in this prescription.
Control | Mandatory, 1..1
Prescription.medicine.productCode
Definition | Coded representation of medicine
Control | Conditional, 0..1: Can only be left empty if it cannot be coded
Type | Coding from MedicationKind
Must Understand | true
To Do | Conformance should be "Required", not "Optional"
Prescription.medicine.description
Definition | Textual description of medicine, including strength and ingredients
Control | Conditional, 0..1: Mandatory when medication cannot be coded
Type | string
Prescription.medicine.activeIngredient
Definition | The substance in the medication formulation that is pharmaceutically active and is responsible for the medication's therapeutic effect
Control | Optional, 0..*
Prescription.medicine.activeIngredient.productCode
Definition | Coded representation of active ingredient
Control | Mandatory, 1..1
Type | Coding from MedicationKind
Prescription.medicine.activeIngredient.quantity
Definition | Quantity of active ingredient expressed in relation to the whole of the prepared medicine
Control | Optional, 0..1
Type | Ratio
Prescription.medicine.inactiveIngredient
Definition | Ingredients in the medication that are not active
Control | Optional, 0..*
Prescription.medicine.inactiveIngredient.productCode
Definition | Coded representation of the inactive ingredient
Control | Mandatory, 1..1
Type | Coding from MedicationKind
Prescription.medicine.inactiveIngredient.quantity
Definition | Quantity of inactive ingredient expressed in relation to the whole of the prepared medicine
Control | Optional, 0..1
Type | Ratio
Prescription.administrationRequest
Definition | Instructions for the use of the medication. Includes details about the timing schedule, dosis amounts and additional usage instructions.
Control | Mandatory, 1..1
Prescription.administrationRequest.description
Definition | Textual description of the use of the medication.
Control | Optional, 0..1
Type | string
Comments | Can contain more details than the structured information under this element, but must be in accordance with it. May not contain information about the medicine itself.
Prescription.administrationRequest.totalPeriodicDosis
Definition | Total dose per day/week or other period when more specific information is missing or cannot be expressed using the timing specifications.
Control | Optional, 0..1
Type | Ratio
Requirements | It should be possible, as a last resort, to specify e.g. a daily dosis, even if more specific details are unknown
Prescription.administrationRequest.start
Definition | First moment on which medication should be taken
Control | Conditional, 0..1: Duration is given OR (Start is given AND (Duration OR End is given)) OR (Duration, Start and End are not given)
Type | dateTime
Prescription.administrationRequest.end
Definition | Last moment on which medication should be taken
Control | Conditional, 0..1: Duration is given OR (Start is given AND (Duration OR End is given)) OR (Duration, Start and End are not given)
Type | dateTime
Prescription.administrationRequest.duration
Definition | Total duration of administration
Control | Conditional, 0..1: Duration is given OR (Start is given AND (Duration OR End is given)) OR (Duration, Start and End are not given)
Type | Quantity
Prescription.administrationRequest.numberOfAdministrations
Definition | Maximum number of separate administrations before the instruction ends.
Control | Conditional, 0..1: Can be given instead of Duration, as specified above
Type | integer
Prescription.administrationRequest.dosageInstruction
Definition | Specification of dose and schedule for administration
Control | Mandatory, 1..*
Comments | The can be >1 dosage instruction to support administration of varying doses, resulting in 1 instruction per fixed dose.
Prescription.administrationRequest.dosageInstruction.precondition
Definition | Precondition for starting the administration specified in this instruction
Control | Optional, 0..*
Type | CodeableConcept from AdministrationPrecondition
Prescription.administrationRequest.dosageInstruction.prn
Definition | Pro re nate, "If necessary": Specifies whether administration depens on the state and symptoms of the patient
Control | Optional, 0..1
Type | code from BooleanYesNo
Comments | Default is "false"
Prescription.administrationRequest.dosageInstruction.additionalInstruction
Definition | Additional details to guide administration. Especially relevant for medicine administered by patient
Control | Optional, 0..*
Type | CodeableConcept from AdministrationInstruction
Prescription.administrationRequest.dosageInstruction.route
Definition | Route of administration (oral, nasal, intravenous)
Control | Optional, 0..1
Type | CodeableConcept from AdministrationRoute
Comments | Since the route of administration is generally determined by the choice of medication, it is not necessary to provide a value in route
Prescription.administrationRequest.dosageInstruction.dose[x]
Definition | Dose per administration, expressed in units of the (prepared) product
Control | Mandatory, 1..1
Type | Quantity|Interval(Quantity)
Comments | Dose may be an interval, "2-3 tablets per 4 hours"
Prescription.administrationRequest.dosageInstruction.rate
Definition | Flow-rate for IV
Control | Optional, 0..1
Type | Quantity
Prescription.administrationRequest.dosageInstruction.schedule
Definition | Schedule for administration. If multiple are given, they are considered to be active in parrallel
Control | Mandatory, 1..*
Type | Schedule
Comments | Will submit proposal to change Schedule type.
Prescription.reason
Definition | Diagnosis which is the reason for prescribing this medicine
Control | Optional, 0..1
Type | CodeableConcept from PrescriptionReason
Prescription.extensions
Definition | See Extensions
Control | Optional, 0..1
Prescription.text
Definition | Text summary of the prescription, for human interpretation
Control | Mandatory, 1..1
Type | Narrative


Example Instance for Agent

<Agent xmlns="http://www.hl7.org/fhir">
  <id>1</id>

  <person>
    <type>Person</type>
    <id>32344</id>
  </person>
  <organization>
    <type>Organization</type>
    <id>3</id>
  </organization>

  <!--   Referring Provider for the first 3 months of 2012   -->
  <role>
    <coding>
      <code>RP</code>
      <system>urn:hl7-org:sid/v2-0286</system>
    </coding>
  </role>

  <period>
    <low>2012-01-01</low>
    <high>2012-03-31</high>
  </period>

  <identifier>
    <identifier>
      <system>htp://www.acme.org/providers</system>
      <id>23</id>
    </identifier>
  </identifier>

  <text>
    <status>generated</status>
    <div xmlns="http://www.w3.org/1999/xhtml">
      <p>Dr Adam Careful is a Referring Provider for Acme Hospital from 1-Jan 2012 to 31-Mar 2012</p>
    </div>
  </text>
</Agent>


Example Instance for Animal

<Animal xmlns="http://www.hl7.org/fhir">
  <id>wer234fwde234</id>

  <!--   Dog tag, under Maroondah City council   -->
  <identifier>
    <type>
      <code>microchip</code>
      <system>urn:hl7-org:sid/fhir/identifier-type</system>
    </type>
    <identifier>
      <system>http://http://www.maroondah.vic.gov.au/AnimalRegFees.aspx</system>
      <id>1234123123312332</id>
    </identifier>
    <period>
      <low>2010-05-31</low>
    </period>
    <assigner>
      <text>Maroondah City Council</text>
    </assigner>
  </identifier>

  <!--   Dog's name: Kenzi   -->
  <name>
    <use>usual</use>
    <part>
      <type>given</type>
      <value>Kenzi</value>
    </part>
  </name>

  <dob>2010-03-23</dob>
  <!--   todo: how do you code a species?   -->
  <species>
    <coding>
      <code>Canis lupus familiaris</code>
      <system>http://en.wikipedia.org/wiki/Biological_classification</system>
    </coding>
  </species>
  <strain>
    <coding>
      <code>58108001</code>
      <system>http://snomed.info</system>
      <display>Golden retriever</display>
    </coding>
  </strain>
  <gender>
    <coding>
      <code>F</code>
      <system>urn:hl7-org:sid/v2-0001</system>
    </coding>
  </gender>

  <!--   owner   -->
  <relatedEntity>
    <role>
      <coding>
        <code>OWN</code>
        <system>urn:hl7-org:sid/v2-0063</system>
        <display>Owner</display>
      </coding>
    </role>
    <name>
      <use>official</use>
      <part>
        <type>given</type>
        <value>Peter</value>
      </part>
      <part>
        <type>given</type>
        <value>James</value>
      </part>
      <part>
        <type>family</type>
        <value>Chalmers</value>
      </part>
    </name>
    <address>
      <use>home</use>
      <part>
        <type>line</type>
        <value>534 Erewhon St</value>
      </part>
      <part>
        <type>city</type>
        <value>PleasantVille</value>
      </part>
      <part>
        <type>state</type>
        <value>Vic</value>
      </part>
      <part>
        <type>zip</type>
        <value>3999</value>
      </part>
    </address>
    <contact dataAbsentReason="unknown">
      <use>home</use>
    </contact>
    <contact>
      <system>phone</system>
      <value>(03) 5555 6473</value>
      <use>work</use>
    </contact>
  </relatedEntity>

  <text>
    <status>generated</status>
    <div xmlns="http://www.w3.org/1999/xhtml">
      <table>
        <tbody>
          <tr>
            <td>Id</td>
            <td>Kenzi (Dog: Golden Retriever)</td>
          </tr>
          <tr>
            <td>Owner</td>
            <td>Peter Chalmers, 534 Erewhon, Pleasantville, Vic, 3999</td>
          </tr>
          <tr>
            <td>Contacts</td>
            <td>Home: unknown. Work: (03) 5555 6473</td>
          </tr>
          <tr>
            <td>Id</td>
            <td>Microchip: 1234123123312332 (Maroondah City Council)</td>
          </tr>
        </tbody>
      </table>
    </div>
  </text>
</Animal>


Example Instance for Conformance

<Conformance xmlns="http://www.hl7.org/fhir">
  <id>6cb96d2f-cfa5-4da9-a5a6-d1a087da0baf</id>
  <date>2012-01-04</date>
  <publisher>
    <name>ACME Corporation</name>
    <contact>
      <system>email</system>
      <value>wile@acme.org</value>
    </contact>
  </publisher>
  <software>
    <name>EHR</name>
    <version>0.00.020.2134</version>
  </software>
  <mode>server</mode>
  <resource>
    <type>Patient</type>
  </resource>
  <operation>
    <read>true</read>
    <vread>true</vread>
    <update>true</update>
    <delete>false</delete>
    <validate>false</validate>
    <history>true</history>
    <transaction>
      <name>link</name>
    </transaction>
    <search>
      <param>name</param>
      <param>gender</param>
    </search>
    <create>
      <id>server</id>
    </create>
    <updates>true</updates>
    <schema>false</schema>
  </operation>

  <text>
    <status>generated</status>
    <div xmlns="http://www.w3.org/1999/xhtml">
      <p>The EHR Server supports the following transactions for the resource "Patient": read, vread, update, history, transaction(link), search(name,gender), create(server-id only), and updates</p>
    </div>
  </text>
</Conformance>


Example Instance for Document

<Document xmlns="http://www.hl7.org/fhir">
  <id>1cbdfb97-5859-48a4-8301-d54eab818d68</id>
  <instant>2012-01-04T09:10:14Z</instant>
  <type>
    <coding>
      <code>11488-4</code>
      <system>urn:hl7-org:sid/loinc</system>
      <display>Consultation note</display>
    </coding>
  </type>
  <setId>2.16.840.1.113883.19.7.bb35</setId>
  <version>2</version>
  <subject>
    <type>Patient</type>
    <id>12.123.451.23.1.23</id>
    <text>Henry Levin the 7th</text>
  </subject>
  <author>
    <party>
      <type>Person</type>
      <id>233123</id>
      <text>Robert Dolin MD</text>
    </party>
  </author>
  <attestor>
    <mode>legal</mode>
    <party>
      <type>Person</type>
      <id>233123</id>
      <text>Robert Dolin MD</text>
    </party>
  </attestor>
  <custodian>
    <type>Organization</type>
    <id>2.16.840.1.113883.19.5</id>
    <text>Good Health Clinic</text>
  </custodian>
  <section>
    <type>
      <coding>
        <code>10164-2</code>
        <system>urn:hl7-org:sid/loinc</system>
      </coding>
    </type>
    <content dataAbsentReason="error">
      <!--   ClinicalNote   -->
      <id>34124</id>
    </content>
  </section>
  <text>
    <status>generated</status>
    <div xmlns="http://www.w3.org/1999/xhtml">
      <p>Consultation note for Henry Levin the 7th</p>
    </div>
  </text>
</Document>


Example Instance for Documentconformance

<DocumentConformance xmlns="http://www.hl7.org/fhir">
  <id>6c8d7aec-05b8-4093-8101-7f5eab5a416d</id>
  <date>2012-01-04</date>
  <publisher>
    <name>ACME Corporation</name>
    <contact>
      <system>email</system>
      <value>wile@acme.org</value>
    </contact>
  </publisher>
  <software>
    <name>EHR</name>
    <version>0.00.020.2134</version>
  </software>

  <!--   1 document profile.   -->
  <document>
    <name>General</name>
    <purpose>Basic rules for all documents in the EHR system</purpose>
    <resource>
      <!--   document resource first, as required   -->
      <type>Document</type>
      <element>
        <path>Document.id</path>
        <min>1</min>
        <max>1</max>
        <type>id</type>
        <conformance>Mandatory</conformance>
      </element>
      <element>
        <path>Document.instant</path>
        <min>1</min>
        <max>1</max>
        <type>dateTime</type>
        <conformance>Mandatory</conformance>
      </element>
      <element>
        <path>Document.type</path>
        <min>1</min>
        <max>1</max>
        <type>CodeableConcept</type>
        <conformance>Mandatory</conformance>
      </element>
      <element>
        <path>Document.title</path>
        <min>1</min>
        <max>1</max>
        <type>string</type>
        <conformance>Mandatory</conformance>
      </element>
      <element>
        <path>Document.setId</path>
        <purpose>All EHR documents must be versioned using setId/Version</purpose>
        <min>1</min>
        <max>1</max>
        <type>id</type>
        <conformance>Mandatory</conformance>
      </element>
      <element>
        <path>Document.version</path>
        <min>1</min>
        <max>1</max>
        <type>integer</type>
        <conformance>Mandatory</conformance>
      </element>
      <element>
        <path>Document.replaces</path>
        <min>0</min>
        <max>0</max>
        <type>id</type>
        <conformance>Prohibited</conformance>
      </element>
      <element>
        <path>subject</path>
        <purpose>Only individual humans in the EHR</purpose>
        <min>1</min>
        <max>1</max>
        <type>Resource(Patient)</type>
        <conformance>Mandatory</conformance>
      </element>
      <element>
        <path>Document.author</path>
        <min>1</min>
        <max>1</max>
        <conformance>Mandatory</conformance>
      </element>
      <element>
        <path>Doument.author.time</path>
        <min>1</min>
        <max>1</max>
        <conformance>Mandatory</conformance>
      </element>
      <element>
        <path>Document.author.party</path>
        <purpose>Only humans author documents</purpose>
        <min>1</min>
        <max>1</max>
        <type>Resource(Person)</type>
        <conformance>Mandatory</conformance>
      </element>
      <element>
        <path>Document.attestor</path>
        <min>1</min>
        <max>1</max>
        <conformance>Mandatory</conformance>
      </element>
      <element>
        <path>Doument.attestor.mode</path>
        <purpose>Only legal authentication</purpose>
        <min>1</min>
        <max>1</max>
        <conformance>Mandatory</conformance>
        <value>
         <code>legal</code>
        </value>
      </element>
      <element>
        <path>Doument.attestor.time</path>
        <min>1</min>
        <max>1</max>
        <conformance>Mandatory</conformance>
      </element>
      <element>
        <path>Document.attestor.party</path>
        <min>1</min>
        <max>1</max>
        <conformance>Mandatory</conformance>
      </element>
      <!--   etc, though stopping here simply means, no rules made about the other elements   -->
    </resource>
  </document>

  <text>
    <status>generated</status>
    <div xmlns="http://www.w3.org/1999/xhtml">
      <p>General EHR Document rules (Acme Healthcare): </p>
      <ul>
        <li>EHR documents must be versioned using setId</li>
        <li>Only individual humans in the EHR</li>
        <li>Only humans author documents</li>
        <li>Only legal authentication</li>
      </ul>
    </div>
  </text>
</DocumentConformance>


Example Instance for Labreport

<LabReport xmlns="http://www.hl7.org/fhir">
  <id>1</id>
  <!--   first, various administrative/context stuff   -->
  <status>final</status> <!--   all this report is final   -->
  <issued>2011-03-04T11:45:33+11:00</issued>
  <patient>
    <type>Patient</type>
    <id>23453</id>
  </patient>
  <laboratory>
    <type>Organization</type>
    <id>1832473e-2fe0-452d-abe9-3cdb9879522f</id>
    <text>Acme Laboratory, Inc</text>
  </laboratory>
  <reportId>5234342</reportId>
  <reportName>
    <coding>
      <code>15430-2</code>
      <system>urn:hl7-org:sid/loinc</system>
      <display>FULL BLOOD EXAMINATION</display>
    </coding>
    <coding>
      <code>CBC</code>
      <system>http://www.nata.asn.au/accreditation</system>
      <display>MASTER FULL BLOOD COUNT</display>
    </coding>
  </reportName>
  <service>
    <coding>
      <code>HM</code>
      <system>urn:hl7-org:sid/v2-0074</system>
    </coding>
  </service>
  <diagnosticTime>2011-03-04T08:30:00+11:00</diagnosticTime>

  <!--   now the atomic results   -->
  <resultGroup>
    <!--   null group, so no name or speciment   -->
    <result>
      <name>
        <coding>
          <code>718-7</code>
          <system>urn:hl7-org:sid/loinc</system>
          <display>Haemoglobin</display>
        </coding>
      </name>
      <valueQuantity>
        <value>176</value>
        <units>g/L</units>
        <code>g/L</code>
        <system>urn:hl7-org:sid/ucum</system>
      </valueQuantity>
      <status>final</status>
      <referenceRange>
        <rangeInterval>
          <low>
            <value>135</value>
            <units>g/L</units>
            <code>g/L</code>
            <system>urn:hl7-org:sid/ucum</system>
          </low>
          <high>
            <value>180</value>
            <units>g/L</units>
            <code>g/L</code>
            <system>urn:hl7-org:sid/ucum</system>
          </high>
        </rangeInterval>
      </referenceRange>
    </result>

    <result>
      <name>
        <coding>
          <code>789-8</code>
          <system>urn:hl7-org:sid/loinc</system>
          <display>Red Cell Count</display>
        </coding>
      </name>
      <valueQuantity>
        <value>5.9</value>
        <units>x10*12/L</units>
        <code>10*12/L</code>
        <system>urn:hl7-org:sid/ucum</system>
      </valueQuantity>
      <status>final</status>
      <referenceRange>
        <rangeInterval>
          <low>
            <value>4.2</value>
            <units>x10*12/L</units>
            <code>10*12/L</code>
            <system>urn:hl7-org:sid/ucum</system>
          </low>
          <high>
            <value>6.0</value>
            <units>x10*12/L</units>
            <code>10*12/L</code>
            <system>urn:hl7-org:sid/ucum</system>
          </high>
        </rangeInterval>
      </referenceRange>
    </result>

    <result>
      <name>
        <coding>
          <code>4544-3</code>
          <system>urn:hl7-org:sid/loinc</system>
          <display>Haematocrit</display>
        </coding>
      </name>
      <valueQuantity>
        <value>0.55</value>
      </valueQuantity>
      <flag>+</flag>
      <status>final</status>
      <referenceRange>
        <rangeInterval>
          <low>
            <value>0.38</value>
          </low>
          <high>
            <value>0.52</value>
          </high>
        </rangeInterval>
      </referenceRange>
    </result>

    <result>
      <name>
        <coding>
          <code>787-2</code>
          <system>urn:hl7-org:sid/loinc</system>
          <display>Mean Cell Volume</display>
        </coding>
      </name>
      <valueQuantity>
        <value>99</value>
        <units>fL</units>
        <code>fL</code>
        <system>urn:hl7-org:sid/ucum</system>
      </valueQuantity>
      <flag>+</flag>
      <status>final</status>
      <referenceRange>
        <rangeInterval>
          <low>
            <value>80</value>
            <units>fL</units>
            <code>fL</code>
            <system>urn:hl7-org:sid/ucum</system>
          </low>
          <high>
            <value>98</value>
            <units>fL</units>
            <code>fL</code>
            <system>urn:hl7-org:sid/ucum</system>
          </high>
        </rangeInterval>
      </referenceRange>
    </result>

    <result>
      <name>
        <coding>
          <code>785-6</code>
          <system>urn:hl7-org:sid/loinc</system>
          <display>Mean Cell Haemoglobin</display>
        </coding>
      </name>
      <valueQuantity>
        <value>36</value>
        <units>pg</units>
        <code>pg</code>
        <system>urn:hl7-org:sid/ucum</system>
      </valueQuantity>
      <flag>+</flag>
      <status>final</status>
      <referenceRange>
        <rangeInterval>
          <low>
            <value>27</value>
            <units>pg</units>
            <code>pg</code>
            <system>urn:hl7-org:sid/ucum</system>
          </low>
          <high>
            <value>35</value>
            <units>pg</units>
            <code>pg</code>
            <system>urn:hl7-org:sid/ucum</system>
          </high>
        </rangeInterval>
      </referenceRange>
    </result>

    <result>
      <name>
        <coding>
          <code>777-3</code>
          <system>urn:hl7-org:sid/loinc</system>
          <display>Platelet Count</display>
        </coding>
      </name>
      <valueQuantity>
        <value>444</value>
        <units>x10*9/L</units>
        <code>10*9/L</code>
        <system>urn:hl7-org:sid/ucum</system>
      </valueQuantity>
      <status>final</status>
      <referenceRange>
        <rangeInterval>
          <low>
            <value>150</value>
            <units>x10*9/L</units>
            <code>10*9/L</code>
            <system>urn:hl7-org:sid/ucum</system>
          </low>
          <high>
            <value>450</value>
            <units>x10*9/L</units>
            <code>10*9/L</code>
            <system>urn:hl7-org:sid/ucum</system>
          </high>
        </rangeInterval>
      </referenceRange>
    </result>

    <result>
      <name>
        <coding>
          <code>6690-2</code>
          <system>urn:hl7-org:sid/loinc</system>
          <display>White Cell Count</display>
        </coding>
      </name>
      <valueQuantity>
        <value>4.6</value>
        <units>x10*9/L</units>
        <code>10*9/L</code>
        <system>urn:hl7-org:sid/ucum</system>
      </valueQuantity>
      <status>final</status>
      <referenceRange>
        <rangeInterval>
          <low>
            <value>4.0</value>
            <units>x10*9/L</units>
            <code>10*9/L</code>
            <system>urn:hl7-org:sid/ucum</system>
          </low>
          <high>
            <value>11.0</value>
            <units>x10*9/L</units>
            <code>10*9/L</code>
            <system>urn:hl7-org:sid/ucum</system>
          </high>
        </rangeInterval>
      </referenceRange>
    </result>

    <result>
      <name>
        <coding>
          <code>770-8</code>
          <system>urn:hl7-org:sid/loinc</system>
          <display>Neutrophils</display>
        </coding>
      </name>
      <valueQuantity>
        <value>20</value>
        <units>%</units>
        <code>%</code>
        <system>urn:hl7-org:sid/ucum</system>
      </valueQuantity>
      <status>final</status>
    </result>

    <result>
      <name>
        <coding>
          <code>751-8</code>
          <system>urn:hl7-org:sid/loinc</system>
          <display>Neutrophils</display>
        </coding>
      </name>
      <valueQuantity>
        <value>0.9</value>
        <units>x10*9/L</units>
        <code>10*9/L</code>
        <system>urn:hl7-org:sid/ucum</system>
      </valueQuantity>
      <flag>---</flag>
      <status>final</status>
      <referenceRange>
        <rangeInterval>
          <low>
            <value>2.0</value>
            <units>x10*9/L</units>
            <code>10*9/L</code>
            <system>urn:hl7-org:sid/ucum</system>
          </low>
          <high>
            <value>7.5</value>
            <units>x10*9/L</units>
            <code>10*9/L</code>
            <system>urn:hl7-org:sid/ucum</system>
          </high>
        </rangeInterval>
      </referenceRange>
    </result>

    <result>
      <name>
        <coding>
          <code>736-9</code>
          <system>urn:hl7-org:sid/loinc</system>
          <display>Lymphocytes</display>
        </coding>
      </name>
      <valueQuantity>
        <value>20</value>
        <units>%</units>
        <code>%</code>
        <system>urn:hl7-org:sid/ucum</system>
      </valueQuantity>
      <status>final</status>
    </result>

    <result>
      <name>
        <coding>
          <code>731-0</code>
          <system>urn:hl7-org:sid/loinc</system>
          <display>Lymphocytes</display>
        </coding>
      </name>
      <valueQuantity>
        <value>0.9</value>
        <units>x10*9/L</units>
        <code>10*9/L</code>
        <system>urn:hl7-org:sid/ucum</system>
      </valueQuantity>
      <flag>-</flag>
      <status>final</status>
      <referenceRange>
        <rangeInterval>
          <low>
            <value>1.1</value>
            <units>x10*9/L</units>
            <code>10*9/L</code>
            <system>urn:hl7-org:sid/ucum</system>
          </low>
          <high>
            <value>4.0</value>
            <units>x10*9/L</units>
            <code>10*9/L</code>
            <system>urn:hl7-org:sid/ucum</system>
          </high>
        </rangeInterval>
      </referenceRange>
    </result>

    <result>
      <name>
        <coding>
          <code>5905-5</code>
          <system>urn:hl7-org:sid/loinc</system>
          <display>Monocytes</display>
        </coding>
      </name>
      <valueQuantity>
        <value>20</value>
        <units>%</units>
        <code>%</code>
        <system>urn:hl7-org:sid/ucum</system>
      </valueQuantity>
      <status>final</status>
    </result>

    <result>
      <name>
        <coding>
          <code>742-7</code>
          <system>urn:hl7-org:sid/loinc</system>
          <display>Monocytes</display>
        </coding>
      </name>
      <valueQuantity>
        <value>0.9</value>
        <units>x10*9/L</units>
        <code>10*9/L</code>
        <system>urn:hl7-org:sid/ucum</system>
      </valueQuantity>
      <status>final</status>
      <referenceRange>
        <rangeInterval>
          <low>
            <value>0.2</value>
            <units>x10*9/L</units>
            <code>10*9/L</code>
            <system>urn:hl7-org:sid/ucum</system>
          </low>
          <high>
            <value>1.0</value>
            <units>x10*9/L</units>
            <code>10*9/L</code>
            <system>urn:hl7-org:sid/ucum</system>
          </high>
        </rangeInterval>
      </referenceRange>
    </result>

    <result>
      <name>
        <coding>
          <code>713-8</code>
          <system>urn:hl7-org:sid/loinc</system>
          <display>Eosinophils</display>
        </coding>
      </name>
      <valueQuantity>
        <value>20</value>
        <units>%</units>
        <code>%</code>
        <system>urn:hl7-org:sid/ucum</system>
      </valueQuantity>
      <status>final</status>
    </result>

    <result>
      <name>
        <coding>
          <code>711-2</code>
          <system>urn:hl7-org:sid/loinc</system>
          <display>Eosinophils</display>
        </coding>
      </name>
      <valueQuantity>
        <value>0.92</value>
        <units>x10*9/L</units>
        <code>10*9/L</code>
        <system>urn:hl7-org:sid/ucum</system>
      </valueQuantity>
      <flag>++</flag>
      <status>final</status>
      <referenceRange>
        <rangeInterval>
          <low>
            <value>0.04</value>
            <units>x10*9/L</units>
            <code>10*9/L</code>
            <system>urn:hl7-org:sid/ucum</system>
          </low>
          <high>
            <value>0.40</value>
            <units>x10*9/L</units>
            <code>10*9/L</code>
            <system>urn:hl7-org:sid/ucum</system>
          </high>
        </rangeInterval>
      </referenceRange>
    </result>

    <result>
      <name>
        <coding>
          <code>706-2</code>
          <system>urn:hl7-org:sid/loinc</system>
          <display>Basophils</display>
        </coding>
      </name>
      <valueQuantity>
        <value>20</value>
        <units>%</units>
        <code>%</code>
        <system>urn:hl7-org:sid/ucum</system>
      </valueQuantity>
      <status>final</status>
    </result>

    <result>
      <name>
        <coding>
          <code>704-7</code>
          <system>urn:hl7-org:sid/loinc</system>
          <display>Basophils</display>
        </coding>
      </name>
      <valueQuantity>
        <value>0.92</value>
        <units>x10*9/L</units>
        <code>10*9/L</code>
        <system>urn:hl7-org:sid/ucum</system>
      </valueQuantity>
      <status>final</status>
      <referenceRange>
        <rangeQuantity>
          <value>0.21</value>
          <status><</status>
          <units>x10*9/L</units>
          <code>10*9/L</code>
          <system>urn:hl7-org:sid/ucum</system>
        </rangeQuantity>
      </referenceRange>
    </result>

  </resultGroup>

  <representation>
    <mimeType>application/pdf</mimeType>
    <data>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</data>
    <title>HTML Report</title>
  </representation>

  <text>
    <status>generated</status>
    <div xmlns="http://www.w3.org/1999/xhtml">
      <h3>CBC Report for Wile. E. COYOTE (MRN: 23453) issued 3-Mar 2011 11:45</h3>
      <!--   you could use a table here, but laboratories are still back in the dark ages using fixed text tables...   -->
      <pre>
Test                  Units        Value       Reference Range
Haemoglobin           g/L         176         135 - 180
Red Cell Count        x10*12/L    5.9         4.2 - 6.0
Haematocrit                       0.55+       0.38 - 0.52
Mean Cell Volume      fL          99+         80 - 98
Mean Cell Haemoglobin pg          36+         27 - 35
Platelet Count        x10*9/L     444         150 - 450
White Cell Count      x10*9/L     4.6         4.0 - 11.0
Neutrophils           %           20
Neutrophils           x10*9/L     0.9---      2.0 - 7.5
Lymphocytes           %           20
Lymphocytes           x10*9/L     0.9-        1.1 - 4.0
Monocytes             %           20
Monocytes             x10*9/L     0.9         0.2 - 1.0
Eosinophils           %           20
Eosinophils           x10*9/L     0.92++      0.04 - 0.40
Basophils             %           20
Basophils             x10*9/L     0.92+++     <0.21
      </pre>
      <p>Acme Laboratory, Inc signed: Dr Pete Pathologist</p>
    </div>
  </text>
</LabReport>


Example Instance for Message

<Message xmlns="http://www.hl7.org/fhir">
  <id>1cbdfb97-5859-48a4-8301-d54eab818d68</id>
  <instant>2012-01-04T09:10:14Z</instant>
  <event>admin-update</event>
  <response>
    <id>5015fe84-8e76-4526-89d8-44b322e8d4fb</id>
    <code>ok</code>
    <duplicate>false</duplicate>
  </response>
  <source>
    <type>Device</type>
    <id>2501</id>
  </source>
  <destination>
    <type>Device</type>
    <id>a23</id>
  </destination>
  <author>
    <type>Person</type>
    <id>3455bc23</id>
  </author>
  <data>
    <type>Person</type>
    <id>342356</id>
  </data>
  <text>
    <status>generated</status>
    <div xmlns="http://www.w3.org/1999/xhtml">
      <p>Update Person resource for Peter James CHALMERS ("Jim"), MRN: 12345 (Acme Healthcare)</p>
    </div>
  </text>
</Message>


Example Instance for Messageconformance

<MessageConformance xmlns="http://www.hl7.org/fhir">
  <id>37ce5d0d-6782-4f9c-9a30-3fb73d162545</id>
  <date>2012-01-04</date>
  <publisher>
    <name>ACME Corporation</name>
    <contact>
      <system>email</system>
      <value>wile@acme.org</value>
    </contact>
  </publisher>
  <software>
    <name>PAS</name>
    <version>1.02-012341</version>
  </software>
  <event>
    <code>admin-create</code>
    <resource>Person</resource>
    <mode>sender</mode>
    <request>
      <resource>
        <type>Person</type>
        <name>focus</name>
        <element>
          <path>Person.id</path>
          <min>1</min>
          <max>1</max>
          <conformance>Mandatory</conformance>
        </element>
        <element>
          <path>Person.identifier</path>
          <min>1</min>
          <max>1</max>
          <conformance>Mandatory</conformance>
        </element>
        <element>
          <path>Person.identifier.type</path>
          <min>1</min>
          <max>1</max>
          <type>Coding</type>
          <conformance>Mandatory</conformance>
          <value>
            <Coding>
              <code>patient</code>
              <system>urn:hl7-org:sid/fhir/identifier-type</system>
            </Coding>
          </value>
        </element>
        <element>
          <path>Person.identifier.identifier</path>
          <min>1</min>
          <max>1</max>
          <type>Identifier</type>
          <conformance>Mandatory</conformance>
        </element>
        <element>
          <path>Person.identifier.period</path>
          <min>0</min>
          <max>0</max>
          <type>Interval(humanDate)</type>
          <conformance>Prohibited</conformance>
        </element>
        <element>
          <path>Person.identifier.assigner</path>
          <min>0</min>
          <max>0</max>
          <type>Resource(Organization)</type>
          <conformance>Prohibited</conformance>
        </element>
      </resource>
    </request>
  </event>
  <event>
    <code>admin-update</code>
    <resource>Person</resource>
    <mode>sender</mode>
    <!--   no constraints on resources here - we are just declaring that the event is supported without saying anything about the content   -->
  </event>
  <text>
    <status>generated</status>
    <div xmlns="http://www.w3.org/1999/xhtml">
      <p>Update Person resource for Peter James CHALMERS ("Jim"), MRN: 12345 (Acme Healthcare)</p>
    </div>
  </text>
</MessageConformance>


Example Instance for Organization

<Organization xmlns="http://www.hl7.org/fhir">
  <id>34234</id>

  <!--   Clinical Team "Gastroenterology" at Acme Hospital   -->
  <identifier>
    <identifier>
      <system>http://www.acme.org.au/units</system>
      <id>Gastro</id>
    </identifier>
    <assigner>
      <text>Acme Healthcare</text>
    </assigner>
  </identifier>

  <name>
    <value>Gastroenterology</value>
  </name>

  <contact>
    <system>phone</system>
    <value>+1 555 234 3523</value>
    <use>mobile</use>
  </contact>
  <contact>
    <system>email</system>
    <value>gastro@acme.org</value>
    <use>work</use>
  </contact>

  <relatedOrganization>
    <code>
      <coding>
        <code>TERR</code>
        <system>oid:2.16.840.1.113883.5.110</system>
      </coding>
    </code>
    <name>Acme Hospital</name>
  </relatedOrganization>

  <text>
    <status>generated</status>
    <div xmlns="http://www.w3.org/1999/xhtml">
      <p>Gastroenterology @ Acme Hospital. ph: +1 555 234 3523, email: <a href="mailto:gastro@acme.org">gastro@acme.org</a></p>
    </div>
  </text>
</Organization>


Example Instance for Patient

<Patient xmlns="http://www.hl7.org/fhir">
  <id>1.2.36.146595217.4.19.1</id>

  <link>
    <type>Patient</type>
    <id>25bd34</id>
  </link>

  <active>true</active>

  <person>
    <type>Person</type>
    <id>35623</id>
    <text>Donald DUCK, Male, 3-April 1951</text>
  </person>
  <provider>
    <type>Organization</type>
    <id>3</id>
    <text>ACME Healthcare, Inc</text>
  </provider>
  <identifier>
    <type>
      <code>MR</code>
      <system>urn:hl7-org:sid/v2-0203</system>
    </type>
    <identifier>
      <system>oid:0.1.2.3.4.5.6.7</system>
      <id>123456</id>
    </identifier>
  </identifier>

  <text>
    <status>generated</status>
    <div xmlns="http://www.w3.org/1999/xhtml">
      <p>Patient Donald DUCK @ Acme Healthcare, Inc. MR = 123456</p>
    </div>
  </text>
</Patient>


Example Instance for Person

<Person xmlns="http://www.hl7.org/fhir">
  <id>34234</id>

  <!--   MRN assigned by ACME healthcare on 6-May 2001   -->
  <identifier>
    <type>
      <code>MR</code>
      <system>urn:hl7-org:sid/v2-0203</system>
    </type>
    <identifier>
      <system>oid:1.2.36.146.595.217.0.1</system>
      <id>12345</id>
    </identifier>
    <period>
      <low>2001-05-06</low>
    </period>
    <assigner>
      <text>Acme Healthcare</text>
    </assigner>
  </identifier>

  <!--   Peter James Chalmers, but called "Jim"   -->
  <name>
    <use>official</use>
    <part>
      <type>given</type>
      <value>Peter</value>
    </part>
    <part>
      <type>given</type>
      <value>James</value>
    </part>
    <part>
      <type>family</type>
      <value>Chalmers</value>
    </part>
  </name>
  <name>
    <use>usual</use>
    <part>
      <type>given</type>
      <value>Jim</value>
    </part>
  </name>

  <address>
    <use>home</use>
    <part>
      <type>line</type>
      <value>534 Erewhon St</value>
    </part>
    <part>
      <type>city</type>
      <value>PleasantVille</value>
    </part>
    <part>
      <type>state</type>
      <value>Vic</value>
    </part>
    <part>
      <type>zip</type>
      <value>3999</value>
    </part>
  </address>

  <contact dataAbsentReason="unknown">
    <use>home</use>
  </contact>
  <contact>
    <system>phone</system>
    <value>(03) 5555 6473</value>
    <use>work</use>
  </contact>

  <dob>1974-12-25</dob>

  <text>
    <status>generated</status>
    <div xmlns="http://www.w3.org/1999/xhtml">
      <table>
        <tbody>
          <tr>
            <td>Name</td>
            <td>Peter James <b>Chalmers</b> ("Jim")</td>
          </tr>
          <tr>
            <td>Address</td>
            <td>534 Erewhon, Pleasantville, Vic, 3999</td>
          </tr>
          <tr>
            <td>Contacts</td>
            <td>Home: unknown. Work: (03) 5555 6473</td>
          </tr>
          <tr>
            <td>Id</td>
            <td>MRN: 12345 (Acme Healthcare)</td>
          </tr>
        </tbody>
      </table>
    </div>
  </text>
</Person>


Example Instance for Prescription

<Prescription xmlns="http://www.hl7.org/fhir">
  <id>1.2.36.146595217.4.19.1.3141</id>

  <identifier>
    <type>
      <code>MR</code>
      <system>urn:hl7-org:sid/v2-0203</system>
    </type>
    <identifier>
      <system>oid:0.1.2.3.4.5.6.7</system>
      <id>123456</id>
    </identifier>
  </identifier>

  <status>active</status>

  <patient>
    <type>Patient</type>
    <id>23453</id>
  </patient>

  <prescriber>
    <type>Agent</type>
    <id>567</id>
  </prescriber>

  <prescribed>2011-03-04T11:45:33+01:00</prescribed>

  <dispense>
    <repeats>2</repeats>
    <quantity>
      <value>50</value>
      <units>ml</units>
    </quantity>
    <dispenser>
      <type>Organization</type>
      <id>567111</id>
    </dispenser>
  </dispense>

  <medicine>
    <description>Penicillin VK oral suspension, 125mg/5ml</description>
    <activeIngredient>
      <productCode>
        <code>XXXXX</code>
        <system>urn:hl7.org:sid/atc</system>
        <display>Penicillin</display>
      </productCode>
      <quantity>
        <numerator>
          <value>125</value>
          <code>mg</code>
          <system>urn:hl7-org:sid/ucum</system>
        </numerator>
        <denominator>
          <value>5</value>
          <code>ml</code>
          <system>urn:hl7-org:sid/ucum</system>
        </denominator>
      </quantity>
    </activeIngredient>
    <inactiveIngredient>
      <productCode>
        <code>YYYYY</code>
        <system>urn:hl7.org:sid/atc</system>
        <display>Water</display>
      </productCode>
      <quantity>
        <numerator>
          <value>5</value>
          <code>ml</code>
          <system>urn:hl7-org:sid/ucum</system>
        </numerator>
      </quantity>
    </inactiveIngredient>
  </medicine>

  <administrationRequest>
    <description>250 mg po tid x 10 days</description>

    <totalPeriodicDosis>
      <numerator>
        <value>750</value>
        <code>mg</code>
        <system>urn:hl7-org:sid/ucum</system>
      </numerator>
      <denominator>
        <value>1</value>
        <code>d</code>
        <system>urn:hl7-org:sid/ucum</system>
      </denominator>
    </totalPeriodicDosis>

    <duration>
      <value>10</value>
      <code>d</code>
      <system>urn:hl7-org:sid/ucum</system>
    </duration>

    <dosageInstruction>
      <route>
        <coding>
          <code>363743006</code>
          <system>http://snomed.info</system>
          <display>oral administration of treatment</display>
        </coding>
      </route>
      <doseQuantity>
        <value>250</value>
        <code>mg</code>
        <system>urn:hl7-org:sid/ucum</system>
      </doseQuantity>
      <schedule>
        <repeat>
          <frequency>3</frequency>
          <duration>
            <value>1</value>
            <units>day</units>
            <code>d</code>
            <system>urn:hl7-org:sid/ucum</system>
          </duration>
        </repeat>
      </schedule>
    </dosageInstruction>
  </administrationRequest>

  <reason>
    <coding>
      <code>G44.1</code>
      <system>urn:hl7-org:sid/icd-10</system>
    </coding>
    <text>general headache</text>
  </reason>

  <text>
    <status>generated</status>
    <div xmlns="http://www.w3.org/1999/xhtml">
      <p>Penicillin VK oral suspension, 125mg/5ml, 250 mg po tid x 10 days</p>
    </div>
  </text>
</Prescription>


Example Instance for Profile

<Conformance xmlns="http://www.hl7.org/fhir">
  <id>6cb96d2f-cfa5-4da9-a5a6-d1a087da0baf</id>
  <date>2012-01-04</date>
  <publisher>
    <name>ACME Corporation</name>
    <contact>
      <system>email</system>
      <value>wile@acme.org</value>
    </contact>
  </publisher>
  <software>
    <name>EHR</name>
    <version>0.00.020.2134</version>
  </software>
  <mode>server</mode>
  <resource>
    <type>Patient</type>
  </resource>
  <operation>
    <read>true</read>
    <vread>true</vread>
    <update>true</update>
    <delete>false</delete>
    <validate>false</validate>
    <history>true</history>
    <transaction>
      <name>link</name>
    </transaction>
    <search>
      <param>name</param>
      <param>gender</param>
    </search>
    <create>
      <id>server</id>
    </create>
    <updates>true</updates>
    <schema>false</schema>
  </operation>

  <text>
    <status>generated</status>
    <div xmlns="http://www.w3.org/1999/xhtml">
      <p>The EHR Server supports the following transactions for the resource "Patient": read, vread, update, history, transaction(link), search(name,gender), create(server-id only), and updates</p>
    </div>
  </text>
</Conformance>